Rooted Desire - Google Play Force Close


  1. raxx

    raxx New Member

    Hi Everyone - Newbie here and hoping you lovely folks can help.

    I recently rooted my Desire and am currently happily running MildWild CM-5.0.

    Everything has been brilliant until the last week or so, when Google Play Store (v. 3.5.16) keeps force closing and I am unable to download or update any apps.

    I first get the Force Close error message "The process android.process.media has stopped unexpectedly", followed by "The application Google Play Store (process com.android.vending) has stopped unexpectedly"

    This happens, regardless of whether I am on Wi-Fi or mobile data.

    I have already tried clearing the data and cache for Google Play Store and Google Services Framework to no avail.

    I would like to uninstall and reinstall the app, but am not able to do so - neither with Uninstaller nor via the Manage Applications settings.

    I would appreciate any suggestions.

    Many thanks.

    Advertisement
    :
  2. Tyseyh

    Tyseyh Well-Known Member

    Moving to all things root.
  3. Jon_LTD

    Jon_LTD Well-Known Member


    Try using fastboot to swap out the vending.apk and replace with another (instructions in the Sticky). Or perhaps reflash MildWild over the top to see if it fixes this? You won't have to wipe/delete anything to do this so you wont lose anything.
    raxx and Hadron like this.
  4. Hadron

    Hadron Well-Known Member Contributor

    Try reflashing the ROM is simplest. You must be S-On, so the alternative is to use adb from recovery, but the ROM flash will be simpler.
    raxx likes this.
  5. raxx

    raxx New Member

    Hi! Thanks for your suggestions.

    I tried them both, but it didn't work.

    I am going to wipe and start again and see if it works.
  6. girolez

    girolez Often Off Piste Guide

    Hi

    I have exactly the same problem with redux 1.2 - google play FCs as you describe and cannot be used at all. My only solution has been to replace it with the old android Market 2.3.3 app (which works) and disable the auto updates with titanium backup.

    Roger
    raxx likes this.
  7. raxx

    raxx New Member

    Thanks Girolez - it worked! :p
  8. davo26

    davo26 Well-Known Member

    ive got exactly the same problem on my wifes desire, so trying to sort it. but......how do you install market 2.3.3 app and titanium, if the market wont open to download the apps? :)

    thanks
  9. Hadron

    Hadron Well-Known Member Contributor

    What ROM, S-On or S-Off?

    You need to get the market installed first. So a flashable zip, installed from recovery would be a solution if S-On. Don't have one to hand, but there are various market zips at XDA. If S-Off could try uninstalling, cleaning dalvik, then manually installing an apk. Either way a web search should dig one up.

    I'd normally recommend a gapps package from goo.im, but it's not so easy to tell the market version there - you'll probably get something newer.

    You can also download a ROM that comes with the old market (e.g. dGB) and extract the apk from there. Even replace the one in your current rom zip with that and reflash, if you are happy editing zips.

    You always take a nandroid before flashing anything, of course :)
    davo26 likes this.
  10. davo26

    davo26 Well-Known Member

    dont really understand all these rooting terms, but ive just looked and its S-ON.
    you say id need market installed first, but isnt that a given? doesnt every phone and every rom have market installed as part of the software?
    FWIW i just thought id try re-flashing the original rom, redux 1.2 and try that. ive done it and market is working, and ive downloaded titanium.
    but...... the problem i fear will return as soon as market updates itself again? how do i stop this from happening?

    thanks a lot

    EDIT: i just went to market to instal facebook, and straight away its come up with market is going to upgrade to google play, continue. ive gone back rather thn coninue, and hope its not doing it automatically. how can i stop this?

    thanks

    EDIT EDIT: the icons changed to play, but its still hanging on the continue page. is it too late? :-/
  11. Hadron

    Hadron Well-Known Member Contributor

    If you are S-On you may have to reflash the ROM yet again. Turn off the phone's data connection to stop an update, then use Titanium to see what version of the market/play store you currently have (to see whether it's done it already).

    You need to disable the "market updater" app to stop this happening. If the market has not updated, use Titanium Backup to "freeze" the market updater. That should suffice. If it has updated, you'll need to flash the ROM again to undo that (no wipe, of course), then freeze it without letting it connect to the internet first.

    The other way is to edit the zip before flashing, removing the market updater from /system/app, which will then mean that when you reflash the zip you will no longer have the market updater installed. Astro can edit zips on the phone (enter the zip, select the app, delete, back out of the zip. Then go in again and check it's gone, because it is sometimes tempermental), or there are utilities to do this on a computer (I'm not a Windows person, and can't remember what SUroot recommended for this).
    davo26 likes this.
  12. davo26

    davo26 Well-Known Member

    thanks. what i did before i read your post was go into setting, applications, markey (play) and uninstal updates. icon stayed as play, but the market was the actual market app. however, its trying to update again. looking in titanium, it looks as if it has already, as theres no market in there, (there is a market updater and feedback agent) but there is 'play 3.7.15 (updated)'

    i tried to freeze it, but was told the free version of titanium wont do that. i dont mind paying for apps, but i never have done yet as im loathe to put my card details into a phone.

    and i cant download astro to edit, as itll update play first :)

    what should i do next?

    thanks
  13. davo26

    davo26 Well-Known Member

    btw, just went into market, downloaded astro, edited zip to remove market updater, it took ages to delete, and now theres nothing named market in the app folder. have i done right? do i need to download another market app and put it in that folder?

    ta
  14. Hadron

    Hadron Well-Known Member Contributor

    You can uninstall updates again I guess - that should give you the market back. What's happening there is that as you are S-On, your market app isn't removed by the update (because there's no write access to /system when running android), so the update is going into /data/app. Uninstalling update then still leaves the original market in place.

    So one option is to try that again, then either get Ti Pro or install Astro.

    Otherwise, you need to edit a copy of the ROM zip on your computer and remove the market updater from there.

    Or, you could try this:

    * set up adb on your computer, if you haven't already (see the ADB and Fastboot FAQ, from the All Things Root Guide sticky post)
    * boot into recovery and connect phone to computer
    * use the following adb commands

    adb shell mount /system
    adb shell rm /system/app/MarketUpdater.apk

    you can check the file is gone using

    adb shell ls /system/app

    * I'd probably clear cache and dalvik from recovery before rebooting, just to keep things clean

    What that does is use the Android Debug Bridge (adb) to issue some linux terminal commands to remove the apk from the system. Being S-On you can't do that while android is running, but when you are in recovery android is not running. You may have to run this as an administrator.
  15. Hadron

    Hadron Well-Known Member Contributor

    The market is called Vending.apk, so if that's there you are fine.
  16. davo26

    davo26 Well-Known Member

    thanks for that mate, you were probably typing as i posted again ^^^^

    does that change things?

    thanks

    EDIT: we seem to be typing at the same time :)
  17. davo26

    davo26 Well-Known Member

    just checked, vending is there :)

    so are you advising i clear cache/dalvik, then go into recovery and just flash rom again? itll overwrite with no updater?

    thanks a lot
  18. Hadron

    Hadron Well-Known Member Contributor

    If you've removed the market updater then just flashing the ROM with no wipe should be fine. Clear dalvik to be tidy, but with a ROM flash I don't think it will matter so much.

    Flashing a ROM overwrites /system, so if the updater is not in the ROM zip it will be gone after the flash.
    davo26 likes this.
  19. davo26

    davo26 Well-Known Member

    hadron you are a genius :-D

    reflashed, everything seems fine right now, astro shows no updater, my wife will be happy now (i think :)

    i noticed the kernel is back to redux rather than the manu one i had before, but i assume i just go back into recovery and flash the manu 1.4 kernel, and everythings sweet?

    thanks ever so much
  20. Hadron

    Hadron Well-Known Member Contributor

    Yeah, kernel is part of ROM, so reflashing the ROM reverts to the ROM's default kernel. But you can reflash ManU as you say and all is well. :)
    davo26 likes this.
  21. davo26

    davo26 Well-Known Member

    sorry, just one more thing you may or may not be able to help with. the rom did have a battery percentaage indicator instead of just the battery, i seem to remember flashing a download for that as its not part of the original rom. i cant find it anywhere. ive looked on the redux site too.

    any idea where i can get little customised downloads such as this for redux?

    thanks again
  22. Hadron

    Hadron Well-Known Member Contributor

    Most likely you made it at UOT Kitchen

    Look for a small zip on your SD card with "UOT" in the name. If you do find it, take a nandroid before flashing it (if it's for the wrong ROM the phone won't boot, so you'll need the nand backup).

    Otherwise make another one at UOT and flash that. Even here, where you've told it what ROM (Redux 1.2 is on the list of ROMs they already have the setup for) take a nandroid before flashing - my first ever bootloop came from making a mistake when flashing a theme mod ;)
    davo26 likes this.
  23. jerryetc

    jerryetc New Member

    hi Raxx and girolez, i got the same problem as you guys encountered with my Samsung Galaxy S i9000. You may want to download the latest gapps from http_//goo.im/gapps (due to my first post not allowing links to be included, you know what to replace to utilize the url :) ) and flash it onto your phone, it works perfectly with my JellyBean 4.1.2, cheers!
  24. carol jean

    carol jean New Member

    Hi everyone!!!:)

    i had the same problem!!!! :mad: <im tireD -__- of it>
    everytime i open some of my applications it "FORCE CLOSES" says.
    ("THE APPLICATION GOOGLE PLAY STORE(PROCESS.COM.ANDROID.VENDING)HAS STOPPED UNEXPECTEDLY.")
    (THE APPLICATION FACEBOOK (PROCESS.COM.FACEBOOK.KATANA.)HAS STOPPED UNEXPECTEDLY.") ........................etc.

    i have tried already <SETTINGS>APP<MANAGE APP>ALL<GOOGLE PLAY<CLEAR DATA<CLEAR CACHE> but didn't worK -_-
    huhuhu ='((( still biTTer -_-

    CAN YOU HELP ME GUYZ!!!!
    ^__^ANY HELP SURELY APPREACIATED ^__^ <3 <3 <3
    THANKS =D
  25. nicka3200

    nicka3200 Well-Known Member

    Did your ROM originally have the old "Market"? If you want to go back to that freeze the Market Updater app with titanium then clear data & cache from google play & uninstall updates.
Loading...

Share This Page