1. Good things coming in just a couple hours, stay tuned!
    Dismiss Notice

Rooted my 2.3.3 Commando - Thanks !!!


Last Updated:

  1. craptastic1

    craptastic1 New Member

    None of the automated "SuperOneClick" methods worked for me.
    I tried all the combinations of suggestions with the usb settings: charge only/media sync/storage/uplugging/replugging, etc.
    It would always hang at step #6.

    Finally I just broke down and followed the manual "Zergrush" instructions step by step.

    When something failed I just started over again at the beginning.

    The only kinda confusing part for me was determining when and where to use quotation marks with the commands. (I remember Dos but I'm not a linux guy sorry)

    Note: I just learned what Rooting was about 48 hours ago so I'm totally new to this.

    Removing all that verizon bull!@#$ felt great. It's like going to your friend's house and stripping all the preloaded crap off their new Dell.
    (everyone has a friend like that, right?)

    This is my first post here.

    I just wanted to thank everyone for the help and assure everyone that 2.3.3 can definitely be rooted.

    I removed almost 70 worthless apps!

    Thanks!!!

    Advertisement
  2. 4DAIVI PAI2K5

    4DAIVI PAI2K5 Well-Known Member

    post up a how to. Many people are stuck after a un rooting to get the update.
  3. craptastic1

    craptastic1 New Member

    The first step is to install the C771 driver. It's available everywhere. Once that is installed and you plug in your phone and set the USB to mass storage the phone will show up as a removable drive and you can see the file structure.

    Then I followed these directions that even include screenshots:

    http://ubuntuone.com/64OujxgkGMv1N2QSoPmXin

    I followed the screenshots exactly but some of the commands didn't work for me.
    If that happens take a close look at the quotation marks contained in the screenshots and try adding/moving or removing them until the command works.

    I also had an issue where the phone dropped it's connection to the laptop and made the "ding ding" sound as if I unplugged it while entering the commands.

    That happened twice. After that I just unplugged it and plugged it back in and made sure I could see the file structure on the phone.

    Then I started over at the beginning.

    Eventually it worked but it took a little experimenting with the command lines and general fiddling around.

    Good luck

    -Chris
  4. allmondjoy87

    allmondjoy87 New Member

  5. paxchristos

    paxchristos Well-Known Member

  6. bonser216

    bonser216 New Member

    I tried to download the one click root files you posted.. the ubuntu one downloads but when i go to unzip it, it says the file is not downloaded correctly? I really would like to root my commando but I would love to do the one click one rather then play around with all the command prompts unless the tutorial is up to date and the typos are fixed.
  7. paxchristos

    paxchristos Well-Known Member

    Try the dropbox link, that one should work. I have no idea why it's being a pain in the butt with ubuntu one...
  8. danbradley

    danbradley New Member

    i have only rooted the eris and that was with a oneclick method but it was in the form of an app does this need to run though my com and if how does this one work?
  9. paxchristos

    paxchristos Well-Known Member

    Yes, this root needs to be run on a pc. It is a windows batch file (pretty much a script) that users an exploit in adb to gain a temporary root, then pushes the files to make root permanent.. If you wanna see how it works, right click on "runme.bat" and choose edit, you can see what the actual "code" is :p
  10. kot222

    kot222 Member

    I made root Droid 2.2.1 and how do I know that it S-off? I work only HTC. How I do in bootloader?
  11. paxchristos

    paxchristos Well-Known Member

    Look in either your device's section on either this forum or forum.xda-developers.com
    Either site will have the answers for you.
  12. kot222

    kot222 Member

    But I have Casio Commando, and now I rooted it. How do I know that S-off?
  13. paxchristos

    paxchristos Well-Known Member

    Sorry, misunderstood. S-off is an htc thing. Unfortunately, nobody has figures out how to unlock the bootloader (i.e. fastboot)
    There is a recovery img that is possible to run, but you can only boot to it from a working (non-bricked) phone
  14. eppie20

    eppie20 Active Member

    ok tried the one click root I keep getting path to device not found.any thoughts?
    (for the casio 2.3.3)
  15. paxchristos

    paxchristos Well-Known Member

    Run the batch file in command prompt (and make sure everything is extracted :p )
    eppie20 likes this.
  16. eppie20

    eppie20 Active Member

    thank you!! I didnt have all files xtracted! worked like a charm!!:D

    now to get rid of all the VZ wear
  17. zer0space1

    zer0space1 Member

    Just used the Dropbox batch myself and it worked flawlessly!
    Thank you Paxchristos!
    Does anyone know of anybody writing custom Roms for this phone yet?
  18. chaos_efphect

    chaos_efphect Member

    been a few weeks but i also ran the dropbox script, worked great...
  19. brilars10

    brilars10 Active Member


    Neither one of these links is working for me. I get the "Internet Explorer has blocked this site from downloading files to your computer. Click here for options..." When I click download file, nothing happens.

    Also, does one still need to install Android SDK with platforms tools and adb before using the one click?
  20. paxchristos

    paxchristos Well-Known Member


    Android sdk isn't necessary.

    Google chrome is literally 1 million times better than ie... I highly suggest using it... (or firefox, chromium, opera, etc., just not ie)
  21. brilars10

    brilars10 Active Member

    Thanks! The script worked flawlessly. :)
  22. johnny31874

    johnny31874 New Member

    I have run the root windows batch file several times and no work. how do i run the batch file in command prompt?
  23. skybeex

    skybeex New Member

    Very nice.

    Thanks Paxchristo. also really appreciate seeing that ya are actively involved here. thanks again. :)
  24. masterroschi

    masterroschi New Member

    I have a Japanese version of the Comando (IS11CA). It is running gb 2.3.3, this batch is the first to actually recognize and attempt the rooting process, as follows:

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.
    C:\Documents and Settings\Administrator>cd /my documents/test
    C:\Documents and Settings\Administrator\My Documents\Test>/root
    '/root' is not recognized as an internal or external command,
    operable program or batch file.
    C:\Documents and Settings\Administrator\My Documents\Test>cd /root
    C:\Documents and Settings\Administrator\My Documents\Test\root>dir
    Volume in drive C has no label.
    Volume Serial Number is 3CC5-7BD2
    Directory of C:\Documents and Settings\Administrator\My Documents\Test\root
    12/21/2011 09:03 PM <DIR> .
    12/21/2011 09:03 PM <DIR> ..
    12/21/2011 09:03 PM <DIR> files
    10/26/2011 05:51 PM 3,083 runme.bat
    1 File(s) 3,083 bytes
    3 Dir(s) 34,605,469,696 bytes free
    C:\Documents and Settings\Administrator\My Documents\Test\root>runme.bat
    ---------------------------------------------------------------
    Easy rooting toolkit (v1.0)
    created by DooMLoRD
    using exploit zergRush (Revolutionary Team)
    Credits go to all those involved in making this possible!
    ---------------------------------------------------------------

    [*] This script will:
    (1) root ur device using zergRush exploit
    (2) install Busybox (1.18.4)
    (3) install SU files (3.0.5)

    [*] Before u begin:
    (1) make sure u have installed adb drivers for ur device
    (2) enable "USB DEBUGGING"
    from (Menu\Settings\Applications\Development)
    (3) enable "UNKNOWN SOURCES"
    from (Menu\Settings\Applications)
    (4) [OPTIONAL] increase screen timeout to 10 minutes
    (5) connect USB cable to PHONE and then connect to PC
    (6) skip "PC Companion Software" prompt on device
    ---------------------------------------------------------------
    CONFIRM ALL THE ABOVE THEN
    Press any key to continue . . .
    --- STARTING ----
    --- WAITING FOR DEVICE
    --- cleaning
    rm failed for *, No such file or directory
    --- pushing zergRush"
    1440 KB/s (23052 bytes in 0.015s)
    --- correcting permissions
    --- executing zergRush
    [**] Zerg rush - Android 2.2/2.3 local root
    [**] (C) 2011 Revolutionary. All rights reserved.
    [**] Parts of code from Gingerbreak, (C) 2010-2011 The Android Exploid Crew.
    [+] Found a GingerBread ! 0x00015118
    [*] Scooting ...
    [*] Sending 149 zerglings ...
    [*] Sending 189 zerglings ...
    [-] Hellions with BLUE flames !
    --- WAITING FOR DEVICE TO RECONNECT
    if it gets stuck over here for a long time then try:
    disconnect usb cable and reconnect it
    toggle "USB DEBUGGING" (first disable it then enable it)
    --- DEVICE FOUND
    --- pushing busybox
    191 KB/s (1075144 bytes in 5.484s)
    --- correcting permissions
    --- remounting /system
    mount: permission denied (are you root?)
    --- copying busybox to /system/xbin/
    /system/xbin/busybox: cannot open for write: Read-only file system
    --- correcting ownership
    Unable to chmod /system/xbin/busybox: No such file or directory
    --- correcting permissions
    Unable to chmod /system/xbin/busybox: No such file or directory
    --- installing busybox
    /system/xbin/busybox: not found
    --- pushing SU binary
    failed to copy 'files\su' to '/system/bin/su': Read-only file system
    --- correcting ownership
    Unable to chmod /system/bin/su: No such file or directory
    --- correcting permissions
    Unable to chmod /system/bin/su: No such file or directory
    --- correcting symlinks
    rm failed for /system/xbin/su, Read-only file system
    link failed Read-only file system
    --- pushing Superuser app
    failed to copy 'files\Superuser.apk' to '/system/app/./Superuser.apk': Read-only
    file system
    --- cleaning
    --- rebooting
    ALL DONE!!!
    Press any key to continue . . .



    Any assistance would be greatly appriciated. Any additional info that you need to help me ask and I will get it to you.
  25. dodgef25

    dodgef25 Well-Known Member

    I Rooted my Commando 2.2.1, now that there is the 2.3.3 update I want to update the phone. I restored all deleted stock apps and unrooted. The update downloads and runs but doesn't complete the installation.

    Is there something I'm missing?
    I used SuperOneClick, which is super easy compared to the examples described in this post.
    Does the SuperOneClick root 2.3.3 as easy as it does on 2.2.1? On SDK tools I got the 2.3.3 driver.


    For others use this how to. How To Root Your Android Phone With SuperOneClick

Share This Page