Rooted phone wont boot past HTC screen after uninstalling Superuser


Last Updated: 2013-01-21 22:46:06
  1. joecampyoung

    joecampyoung Member

    Okay so my phones rooted and I was trying to install Beats Audio on my phone and it didn't work at first so I looked into it. Found out I had to manually update. I was told to try a different app other than superuser to update so I tried super su i think it was, got it to update. Then I installed beats audio, restarted my phone and the beats audio didn't show up. So then I tried uninstalling the original superuser app I had for some dumb reason and nothing happened just yet. Then I went and tried to install beats audio again and when i tapped on "restart phone" my phone froze and I had to pull out the battery. Now every time I turn on my phone it wont boot past the htc screen. I've tried to factory reset (without my sd card in it, I don't know if that matters) and nothing helped. I even tried installing a rom but i had no idea if it was the right one or if I was doing it right but when I went to try and install it using the fast boot menu options it just says "installation aborted" I really don't mind wiping my sd card if that's what it takes, I just want my phone working again. I have an HTC Inspire 4G. Please any help would be greatly appreciated.

    Advertisement
  2. scotty85

    scotty85 Guides Guide

    How did you root?
  3. joecampyoung

    joecampyoung Member

    I'm not sure, I got the phone used and it was already rooted.
    Is there any way to find out?
  4. ral

    ral Well-Known Member

    Maybe you can copy SuperSu 0.99 from this link in your SDCard.

    Boot into recovery, flash the zip, than clear Dalvik and cache.

    This will restore Super User on your phone. After that, if the phone boots we can find out more about your phone and work out other issues.

    Best to wait for D-U-R-X or scotty85 to confirm before following my advice.
    scotty85 likes this.
  5. scotty85

    scotty85 Guides Guide

    It definately wouldn't hurt to wipe and flash superuser. If the phone still won't boot,best way to tell how the phone was rooted is to look on the hboot screen,and tell us the info there.

    In particular,wether you have s on,or s off,and if there is a big pink locked or unlocked present
    ral likes this.
  6. joecampyoung

    joecampyoung Member

    Thank you both for your assistance so far.
    I have super su installed. It was superuser I uninstalled but either way I'll give this a try.
    And when you say wipe, do you mean factory reset or or just wipe the Dalvik and cache?
    scotty85 likes this.
  7. joecampyoung

    joecampyoung Member

    This what it says on the hboot screen,
    ACE PVT SHIP S-OFF
    HBOOT-0.85.0019
    MICROP-0438
    RADIO-26.06.04.06_M
    eMMC-boot
    Dec 27 2010, 14:47:30
    There is nothing in pink.
    Also when I click Recovery it says my version is
    ClockworkMod Recovery v3.0.2.8
    scotty85 likes this.
  8. joecampyoung

    joecampyoung Member

    Yeah that didn't work. :/
  9. ral

    ral Well-Known Member

    Just Dalvik and cache. I take it that, it did not work. If you had both Super User and SuperSu installed only one of them was active. Neither one is required for a ROM to boot. Figured it would not hurt to give it a try since that appears to be where the problem started.

    Good thing is the phone is S-Off.

    I probably would try, updating ClockwordMod (I think its at version 4 or 5 now), and flashing a new ROM.

    Since your device is a Inspire 4G, which has some nuances which make it differ from a Desire HD. I also don't use CWM. Best follow Scotty lead.
    scotty85 likes this.
  10. scotty85

    scotty85 Guides Guide

    i would prolly recomend to switch to ext 4 recovery,it is much nicer than CW,and ral has the best guide ive ever seen on how to use it. :D

    i believe you just need a new rom on your inspire,i dont think you need to run an ruu at this point.

    either of these roms would be a good "get phone working" choice:

    based on stock att:
    http://forum.xda-developers.com/showthread.php?t=1810461

    based on wwe sense 3.0:
    http://forum.xda-developers.com/showthread.php?t=964841

    install ext 4 in this manner:
    download from here: PD98IMG_ace_recovery_ext_4.zip

    rename the download PD98IMG is youre using windows. transfer it to the root of your sd card via a card reader in the PC,or via usb storage in cw.

    now,power off,and on into hboot(vol down/power) and hboot should find the file,and ask you to update. note that your sd card MUST be formatted FAT32. you will need to remove PD98IMG from the sd card after the flash in order to access recovery.

    once you can boot to ext 4 recovery,transfer your rom to the sd card.

    now you can use rals guide to flash:
    http://androidforums.com/desire-hd-all-things-root/631481-4ext-recovery-how.html

    hopefully that will get you up and runing.

    if not,as a last resort,you can run the att ruu.
    -download from here: Shipped ROMs
    -cahrge phone to 100%
    -place phone in fastboot
    -run the ruu utility as admin if possible,and follow the on screen directions. the utility will update all partitions and reboot when finished. we can then go over with you how to re-root :)
    ral likes this.
  11. joecampyoung

    joecampyoung Member

    Okay so I installed the rom before I updated like an idiot but my phone actually booted past the htc screen and showed me this pretty cool Android picture made out of a bunch of code. Then my phone turned on and it looks like it was restored to how it would look if you were to buy it and turn it on for the first time.
    Which is the closest I've come to anything.
    I'm not sure how good or bad that is.
    But thank you!!! You guys are freaking awesome!!!! For getting me this far. I'm extremely happy to at least see the screen.
    I thought it was a gonner.
    Let me know if I should redo anything or if I should just leave it from there.
  12. scotty85

    scotty85 Guides Guide

    i personally would still swap to ext 4 recovery,it is a much nicer recovery,IMO,but that is entirely up to you. if youre happy with CW and the interface it has,nothing wrong in sticking with it. :)

    just make sure whenever you install new roms,with either recovery,to always make a backup of a good working rom,and always to a "full wipe" before flashing the new one.

    just holler if you have any questions :cool:
    joecampyoung likes this.
  13. joecampyoung

    joecampyoung Member

    Thanks so much. You guys are pro. :D
    I do have a couple sort of irrelevant questions.
    I've been unable to receive or send picture messages and my mobile data isn't working.
    Do you think that's caused by this or my data plan?
    Because my dad might have changed it but I haven't talked to him about it yet.
    Also I can't torrent anymore. I've tried every different torrent program.
    Know anything about that?
  14. scotty85

    scotty85 Guides Guide

    what ruu did you run? it may be just that you have no APN settings,wich will not let data work,wich in turn will not let mms work.

    somewhere in settings/mobile networks you hsould see a setting for APN. check and see if there is something there,with a dot or checkmark by it,or if that screen is blank.

    if you find apn settings present,it may be that your plan has been altered. if you find a blank screen,you may just need to re-enter the apns.
  15. joecampyoung

    joecampyoung Member

    The screen is blank.
    How do I re enter the apns?
  16. scotty85

    scotty85 Guides Guide

    touch the menu softkey,then choose "new apn" or something to that affect,i cant remember the exact menu option. then just enter the settings exactly,and then save the apn afterward. you should then see it as an option on that screen,and be able to select it for use. sometimes a reboot is needed,but usually data will appear shortly after selecting the apn.

    a quick search found these settings:
    Internet / WAP / APN / MMS SettingsTheUnlockr

    if they dont work,you may need to call att,or just do some further searching :)

    once data is back,mms should work also... hopefully that gets it sorted for you :)
    joecampyoung likes this.
  17. joecampyoung

    joecampyoung Member

    Yes! The picture messaging and mobile data are working, thank you!
    But the torrents still won't.
    I googled it and couldn't really find anything.
    What happens is ill click on "Get this torrent" and, well nothing happens,
    Sorry if it's too much trouble but either way I definitely appreciate all you've done for me.
    scotty85 likes this.
  18. scotty85

    scotty85 Guides Guide

    glad that got your data working :smokingsomb: unfortunately,i dont know anything about the torrents... may want to start a new thread,asking about that. :)

Share This Page