Rooted SetCPU tweaked with dmg rom 3.2 Battery Issues


Last Updated:

  1. DroidEDI

    DroidEDI Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    20
    Likes Received:
    1
    This is my first post as I've been trolling and gathering info to try and make my EVO better.

    I want to state that I LOVE my phone and it perfectly does everything I need it for. I just have a minor problem. With all the tweaks I've done (and redone) I can't for the life of me get my phone to last more then 8 (or less) hours.

    Here is my phone settings.

    I'm rooted via the new root method (ota simple) from xda. It worked flawlessly and then I installed the dmg rom on the Battery Saver method. Got a little bit of time. THEN I purchased and followed the SetCPU program tweaks and did that to the T. I also have the following: GPS On. Mobile Internet on (no wifi or bluetooth).

    I have all "Friends" syncing off but I have my gmail and work email on push (required via my job)

    I have my brightness set to almost the lowest and I have to charge my phone about 2pm everyday otherwise my phone is dead.

    Typical day: Wake up at 7am unplug phone. Check email/comics then go to work. I'm an IT sys admin and am required to have my phone/answer emails throughout the day. but at least 4 hours the phone is just sitting there or I'm lightly texting on it. But no matter how little or how often I use it it gets about 30% dead about 2pm with ALL the tweaks i've done.

    Now: This might make all the difference. I have LOW signal at work and home (1 little bitty bar to none). And my cell standby is almost always above 50%. But with all the tweaks (yes I've done the network app and yes its on CDMA) with PRL and profile updates (rooted and unrooted) it still has the problem.

    I'm writing this in hopes I've missed something drastic and do NOT have to get a "2700MAH EXTENDED BATTERY" from China. I do NOT want the added bulk or need it.


    Any questions/comments are welcome that can help me. I've read most of the evo forums here and xda and from what I've read I should have "kick ass" battery life in standby and in general tweaks.
     

    Advertisement
  2. dzar

    dzar Well-Known Member

    Joined:
    May 25, 2010
    Messages:
    132
    Likes Received:
    39
    I have a similar experience to you and I believe that the low signal is the culprit. On the weekends at home (where I can see the tower across the street), I get over 24 hours of run time on a single charge (and I use the phone with email/twitter all day long as well as a call or two). When I go to work, where I get lousy reception in by building/office, I lose at least 50% of my battery in about 8 hours. There is really no other difference in how I use the phone. The low "bars" makes the phone search for better signal all the time which uses a lot of energy.
     
  3. DroidEDI

    DroidEDI Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    20
    Likes Received:
    1

    AWww man. I was afraid of that. So what kind of options do we got? Petitioning sprint for better service? Is there a way to boost my signal with anything?

    Or is it really coming down to having a battery that drains at work and one that drains at home? At least at home i get a solid 1 bar instead of an "off and on" bar that I get at work :(
     
  4. cabbie

    cabbie Well-Known Member

    Joined:
    Mar 23, 2010
    Messages:
    1,344
    Likes Received:
    553
    a few things stick out

    if you are in IT, i imagine you are almost around wifi. Use wifi instead of 3g wherever possible, "better service" isn't going to make a real difference in building penetration.
    and since you are in IT, i can't imagine you are far away from your computer or laptop. plug it in.
    use setcpu to ondemand and where it will underclock while asleep
    use juice defender from the market. that may cause lag in your email though.
    buy an extra battery with external charger and swap them out at lunch
     
  5. DroidEDI

    DroidEDI Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    20
    Likes Received:
    1
    Cabbie,

    Thanks for the tips.

    So I never tested this. Wifi... Would that make my battery more stable then relying then the crappy cell phone internet? Would that cause less battery drain?

    I was trying to have to stay away from the spare battery and charging during the day. But I've been doing the charging and since I'm normally always at a PC I don't have a problem doing it. Just was wondering if I was missing something tweak or phone setting wise to fix it or if it really was the horrible cell phone reception.

    Thanks again!
     
  6. cabbie

    cabbie Well-Known Member

    Joined:
    Mar 23, 2010
    Messages:
    1,344
    Likes Received:
    553
    the 3g radio pulling hard to find a signal is going to annihilate a battery. put it on wifi, MUCH better all other things equal. and they dont even seem equal with the cruddy 3G you are getting.
     
  7. PSULightingGuy

    PSULightingGuy Active Member

    Joined:
    Jun 6, 2010
    Messages:
    27
    Likes Received:
    1
    The other thing is I noticed DamageControl tends to override SetCPU and actually I switched away from it for that very reason. Check by running the CPU up and down, then doing a long benchmark in the info tab. If the results vary with the CPU, then you're fine on that count, but if they stay the same (or really close), then it's being overridden, just like the stock ROM with it's perflock limit.

    Though I do agree, WiFi uses much less power than 3G and will override it if connected, might actually help.
     
  8. wkendrvr

    wkendrvr Member

    Joined:
    May 7, 2010
    Messages:
    16
    Likes Received:
    6
    Had the same problem.

    Here is what I did.

    First:

    MAKE SURE THAT SETCPU is actually working! If your Kernel is not tweaked, you MUST use the version that disables PERFLOCK

    With SETCPU make sure that you set it to go to 245 while the screen is off. This makes a HUGE difference. to extend battery even more, I have mine set to throttle down to 768 if the battery is above 45%. At that point I have it throttle down to 345.

    Also, look at getting setting Profiles

    It will allow you to turn off the extra radios automatically based on time, gps, wifi networks, and bluetooth devices.

    I have mine set up to turn off GPS, bluetooth, WIFI (none available at work) and it also turns off auto sync when unplugged (this is probably the biggest battery hog!) I would look at using just a mail client and set it to sync every 15 - 30 min unless your response time needs to be quicker. If you have to use gmail, turn off contact sync, and calendar if you aren't using them.

    AND make sure that your 4g is off! Just idling with no other traffic, 4g will by itself kill your battery in 8hrs.
     
  9. Velocd

    Velocd Well-Known Member

    Joined:
    Jun 19, 2010
    Messages:
    67
    Likes Received:
    4
    Have you looked in Settings>About Phone>Battery>Battery Use>Cell Standby. Mine spends 6 out of the 8 hours here without signal. I get 10 hours on a charge for work days and over a day when I am at home.
     
  10. DroidEDI

    DroidEDI Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    20
    Likes Received:
    1
    Thanks all for the tips and info.

    So anybody else having this problem can know what fixed it for me:

    Wifi.

    I enabled wifi at home and in the office and after a full charge I have 12 hours of it being unplugged and am at 70%.

    Just to recap:

    SetCPU enabled with the SetCPU configured and rooted with dmg control rom 3.2x and wifi enabled due to poor signal strength at work and home will make this phone easily last more then 12 hours on normal useage and work.

    Thanks again!
     

Share This Page

Loading...