1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

rooting a droid x 2 with current updates applied todate


  1. bondjaymbond

    bondjaymbond New Member

    ok.. so Ihad a droid 2 global.. had it rooted....then it fired the other day... so i went and picked up a droid x2 off craiglist.. id like to get itrooted..however.. i have installed all the drivers and tried about5 diffrentmethods.. idk how uptodate they are ..none of them have worked thus far..sothat i can run barnacle wifi teather.......... tried ginger breakk.. it just ran for like thirty mins before i gave up on that... tried moto fail..says it rooted it but non gettin my super user abilitys .. same thing with onclick.. and the droid threeroot script.. any one have a way for me to check my root acess...and or get me a better rooting app ...??? please any and all info will be appreciated.. very frusterated at this point:eek:

    Advertisement
    :
  2. AliKitten

    AliKitten New Member

    I am having the same issue but I have the Milestone X2 2.3.6 it and the droid x2 are like twins. I CAN NOT get any help so that leads me to believe there are not may who know how to root this phone (milestone) I know it has a boot loader that is pretty much unable to be unlocked. So does anyone know how to do this or do i need to stop wasting my time.
  3. coolpoete

    coolpoete Well-Known Member

    bondjaymbod, what version of Gingerbread are you running? 2.3.4 or something else? The easiest way to check is to see if you are rooted is if you have the SuperUser icon in your programs listing.

    AliKitten, I don't know much about the Milestone X2 but if it is running a stock 2.3.6 iteration from the factory then it is possible that a root method has not been found for the phone yet. The bootloader being locked has no effect on whether or not you can achieve root. This is the case with all Motorola Droid's, all of their bootloaders are locked.

    I know that Motorola has been pushing updates for the DX1 and is about to release an update for the DX2. It is entirely possible and rumored that the proposed "security update" patch that is included is a means to stop folks from rooting or performing an SBF to a different version of Gingerbread. This was the case on the last update on the DX1. 2.3.6 stock hasn't hit the DX2 yet but if it comes and whomever takes the update may be in the same position you are in now.. untill someone finds an exploit.
  4. AliKitten

    AliKitten New Member

    the droid x2 and the milestone are almost twins just a couple different things mx2 does not have the camera button on the side just little things like that nothing big other than the mx2 has a locked bootloader so i have no idea I really just want to down grade and get rid of 2.3.6
  5. coolpoete

    coolpoete Well-Known Member

    Looks like here on XDA-Developers they are porting the 2.3.6 ROM from the Milestone X2 to the DX2. I would try asking the ROM maker if there is a way to root your device.
  6. Hightest

    Hightest Member

    I had my last DX with the same issues I couldnt get any of the oneclick roots to work. I did alot of reading and found that I needed to sbf back to previous versions that were rootable. I finally sbf'd back to froyo then downloaded the latest GB leak onto my card and flashed a rooted version of the latest gingerbread 2.3.6
  7. Shantarias

    Shantarias New Member

    Where do I get the rooted sbf gingerbread file?
  8. coolpoete

    coolpoete Well-Known Member

    The SBF file is meant to restore your phone back factory gingerbread settings so it's a 2 step process. After you perform the SBF you then have to root the phone.
    Read through carefully and follow directions HERE
Loading...

Share This Page