Rooting a Lenovo IdeaTab A2107Support


Last Updated: 2013-03-04 02:04:35
  1. n1hilum

    n1hilum New Member

    Hey! I'm new to the forums, and the whole Android thing. Yesterday, I got myself a Lenovo IdeaTab A2107, but it was filled to the brim with (excuse my language) shit bloatware. I've managed to disable a couple, but I'm unsure as to how to completely remove them. I've read that I can do this through rooting, and after scouring I've turned up with nothing. I'm a Linux user, so the whole concept of rooting and getting root privileges has sort of bled into me. Can anyone help me out with this though? Uhh, I can't link anything due to forum first post rules, so you could just google the specs.

    Advertisement
  2. OutOfPhase

    OutOfPhase Premium Member Guide

  3. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    I moved this over to the Ideapad 2107 forum so hopefully the OP will get some better help.
  4. cognus

    cognus Well-Known Member

    no tech help from me, but I wanted to comment that this is a better device than I initially thought. If one looks through all the specs, and the early reviews, and if in the states go by OfficeDepot and take a test drive, it adds up. You can pay $100 for a more powerful chipset/processor/gpu but the odds of a happy experience down the road after hard use wane. This one uses a proven technical base [phones - lots of them], includes 3G, includes microSD, has a decent screen though not tech-edgy, and seems to have excellent WIFI reception where more expensive trendy ones suffer [ahem...]. Standing in a OfficeDepot with horrible wifi coverage, this one would lock-on when others wouldn't or couldn't, and was snappier than I thought it would be from the specs. lovely display but I didn't look at small things zoomed big ...

    hope it gets a lot of loving attention from the technical crowd here
  5. basoodler

    basoodler Well-Known Member

    ^ I agree with the last comment.. it exceeds expectations so far

    I found a root tool made for this tablet.. but it is in some foreign language and I can't read it.

    ျ

    I agree with the solid wifi..plus the device itself is well built.. there is nothing flimsy about it. now if I can get my girlfriends pantech breakout to send a non adhoc wifi signal through tether.



    I found a root method on XDA. http://forum.xda-developers.com/showthread.php?t=1982334




    I uploaded it to my google drive to save the OP's bandwidth. All credit goes to ichi go from xda

    Download link-
    https://docs.google.com/open?id=0B-NYG919j6eQQXd6bjVBakFyWXc
  6. cognus

    cognus Well-Known Member

  7. basoodler

    basoodler Well-Known Member

    It is going to take me a bit of time to figure out how that works.. it seems to go on for 15 pages of them trying to trial and error it.

    They are also having a lot of trouble with comparability of google apps and apps from market. I am pretty sure the ROM does not have OEM and they are trying to add the google apps , google play and compatibility back in

    Honestly the tablet wasn't overly bloated to begin with. I do want to root it so I can take the odd bloat off that came with it. I would love to overclock it. the MDK A9 processor has been overclocked to 3.1ghz in a production phone

    I am pleasantly surprised with this tablet. I bought it for my GF and did not know what to expect.. its actually a pretty slick little unit
  8. basoodler

    basoodler Well-Known Member

    Oh snap on page 18!


  9. cognus

    cognus Well-Known Member

    i follow that thread, and part of the missteps are caused by people who are not careful to check their exact version of the device.
    the only 'bug' or issue I have seen is that the device wants to show chinese only when it is finally 'done', and pemergency has explained how to switch it ... its odd, and apparently has nothing to do with this particular rom, cause if you google about on that issue, you will see notes about it all over, including from people who simply got the update to the original factory rom!
    lenovo or their supplier did not have this one wellbaked before release
  10. basoodler

    basoodler Well-Known Member

    thanks for clearing that up. I have not taken the OTA yet.. I just got it yesterday lol


    I am working on uploading all of the stuff to google drive and will dump it in a thread on the all things root forum. If you can detail how to use this stuff it would probably help the mod to add it to the main guide thread
  11. crankbait

    crankbait New Member

    OK so here goes this is what I posted over at XDA just a few moments ago, use it if you will

    To Start this post I want to clarify that the device I am referencing is the A2107A-F model. But theres no reason this won't help the other variants

    I've been very suspicious that the lag and other issues I've been having with my childrens tablets were due to poor development of this little guy. Last night I went through the rooting process which I found I was not able to use the "patient" version in the beginning of this thread. I had to use the MTK tools to root. I read the Specs of the MTK6575 chip and I knew I shouldn't have been experiencing these issues, It was more than capable of handling the loads my children were giving it.

    After installing Root and CWM I made a full backup of the ROM on each of the Tablets. I do plan to make a ROM dump clean it up and upload it incase someone may need one.

    Secondly I removed all bloatware that I believed the tablet and the OS wasn't dependant on. This made a huge difference in responsiveness of the tablets.

    Third point I would like to make was the biggest improvement overall. I ran the CoD tweaks as I had previously mentioned. WOW I couldn't believe the performance increase. I have used these tweaks on a lot of my other devices so I fiqured I would give them a shot here.
    For anyone that's interested here is the link, read and follow directions and you'll do just fine. Yes you have to be rooted.
    (THIS IS A LINK THAT I CANNOT POST BE CREATIVE TO GET IT TO WORK) androplasty.com/content.php/2...1-0-2-12-04-11

    In the last part of the guide for SD tweak I have not found a customized kernel yet so the init.d tweak is not applicable

    What prompted me to do this was the fact that the device would literally run out of RAM. I have seen them drain it down to <30mb of Free RAM space. Now it seems to be maintaining >150mb free RAM space. Major Major performance increase.

    If I run across any other tweaks and what nots for this gem I'll post them.
    Ultimawar likes this.
  12. Ultimawar

    Ultimawar New Member

    Crankbait, I don't actually understand how to use MTK tools to root. I've googled around but I keep finding people linking to .bat files and I'm not sure if those are applicable to our device.

    Any chance you could direct me to a noobfriendly guide on using mtk tools?

Share This Page