Rooting: A quick guide (Updated 3/10/09)

Last Updated:

  1. dlammons

    dlammons Member

    I must be the stupid one here... I have followed all the directions and still can't get telnetd to work. Then there is the question of the telnet client.. ANY help would be appreciated. What I have done so far is downgrade to rc29 and here I sit... everytime I type telnetd is just sits there, I even tried the reboot command, just not happening..

  2. shivers316

    shivers316 Godmember VIP Member

    You won't actually see anything happen when you type it. It will just work.
  3. justjimjpc

    justjimjpc Premium Member VIP Member

    Are you set for Debugging mode on the G1 ?? I haven't done this but I thought you had to have it set:

    System Settings|Applications|Development|USB Debugging (checked)
  4. shivers316

    shivers316 Godmember VIP Member

    Debugging is set as default in the modified RC29. I think he's waiting to see something actually happen, which it won't.
  5. justjimjpc

    justjimjpc Premium Member VIP Member

    But I think he said (or as i understand him) that he has the Stock RC29 before any root-Block was in place...
  6. dlammons

    dlammons Member

    I have just the rc29 and no mods, mybe I am missing something, if you type telnetd and nothing happens, at what point or what do I do to telnet into the phone,, ie client and usb cable connected to PC??? maybe that's the part missing,, the .apk files I see I thought were for the phone to telnet to itself,, ie localhost...
  7. shivers316

    shivers316 Godmember VIP Member

  8. dlammons

    dlammons Member

  9. dlammons

    dlammons Member

    nevermind got it finally,, love it,, thanks alot
  10. justjimjpc

    justjimjpc Premium Member VIP Member

    Would be nice if you shared the solution ... so if others get stumped ... the can do what you did ... to fix their issue as well !
  11. dlammons

    dlammons Member


    Actually I may be doing it again, as I seem to have lost root access when I did the JF rc33 update, so I will be tinkering, back to RC29, HardSPL then JF RC30 the JF rc33.. may be overkill but I wanted to tinker,, unless I have overlooked something,, any ideas??

    Original,, telnetd worked after I flashed with the RC29 link Shivers316 gave me, then used Telnet from Market, then input:

    Borrowed from devolio post above...

    Copy recovery_testkeys.img onto the Micro SD Card


    mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /systemdd if=/system/bin/sh of=/system/bin/su

    chmod 4755 /system/bin/su


    cd /systemcat /sdcard/recovery_testkeys.img > recovery.img

    flash_image recovery recovery.img

    Then flashed with Engineering SPL, then ,JF1.42_ RC33 with the RC33 Radio Update.

    I may have skipped a step
  12. dlammons

    dlammons Member

    Geeez, sometimes I feel like such a moron,, I still have root just access it different is all,,, ""READ THE POSTS"" ,, um all is working,, I do have a minor question,, If I want to change the bootloader do I have to start from scratch or can I just doit as an update as before??
  13. savageman22

    savageman22 New Member

    hi i was thinking of rooting my newly acquired g1 but have 1 question is rc33 the same as rc9?
  14. justjimjpc

    justjimjpc Premium Member VIP Member

    I have my second G1 (experiment-play-with) phone ...

    Possibly Step #1 did not go right ... therefore I cant use Telnet in Step #2???

    I am braving into Rooting it and have gotten hung up at Step 2.

    It was definately me ... failing in Step #1 ...

    I formated the SDcard to Fat32 .. But not in the phone ... Rather than Formatting the Device ... the entire phone memory ... Which prepares the way for putting the Dream RC29 image (pre-Root_Block) Build on the phone.

    In Step 2:
    I had previous tried to use Terminal Emulator in place of Telnet...
    That was a mistake ... so be sure to use Telnet ...

    In Step 3:
    The first time I renamed the image file to "" and it should be just "Update" ... as the flasher looks for a zip-type file called "Update"

    After those stumbles the rest went fine....

    I copied the 'testkeys.img' onto the SDCard
    I have telnet app downloaded...

    I have the phone connected to the Computer ... SD is mounted ...

    I tried .. "- Type enter, then telnetd enter to start telnet" and I get nothing but kicked into the phone contacts...

    I have tried starting the Telnet App and iget a screen like:
    "[ Localhost ]" "[ 23 ]"
    Button "Connect to Sever"

    I press the "Connect to Server" button ... and get "Error while connecting to server: Localhost/

    Do I need to put other info in the windows of --Localhost and [23] ?
    Should something be running on the PC ...??
  15. exmortis

    exmortis Member

    right i have manage to down garde from rc9 to rc7 ok no probs
    start the first step ok on post instructions
    second step it says all the time cannot create recovery.img read only
    what am i doing wrong have gone through steps all fine i think
  16. AndroidSocialMedia

    AndroidSocialMedia Active Member

    I suggest this page for the BEST and most up to date instructions. We took the other best instructions online and clarified some of the questions.
  17. M@XLOL

    M@XLOL Well-Known Member

    The RC29 link is dead. I want to root my phone can someone point me in a direction where I may attain this file?
  18. justjimjpc

    justjimjpc Premium Member VIP Member

  19. M@XLOL

    M@XLOL Well-Known Member

    sorry for the double post but the file appears to be found here
  20. M@XLOL

    M@XLOL Well-Known Member

  21. M@XLOL

    M@XLOL Well-Known Member

    i cannot connect when trying to connect to localhost...

    what do i need to do?
  22. M@XLOL

    M@XLOL Well-Known Member

    am now conecting. when I type all of the commands in i get this message
    also getting message
  23. warbosspeter

    warbosspeter New Member


    I have a European (Dutch) vodafone magic phone. And was wondering if i could unroot it. I can't seem to find any guide to do this. It is build-nummer is CRB43.

  24. noonehereyet

    noonehereyet No One... VIP Member

  25. rieen

    rieen Member

    K i am on part 1, i did the first 3 task
    and now i got to press power for yes,
    but mine doesnt say power for yes, it says action for yes.
    so i pressed action, and 1 min later it said.

    Model ID incorrect!
    Update Fail!

Share This Page