Rooting after Official 2.2 Update

Last Updated:

  1. SpikerDallas

    SpikerDallas New Member

    I have rooted my Captivate before the official 2.2 update through AT&T but since the update, I have not been able to find an file that works. I get the E:Signature error. There is no lag fix software loaded. I do have Wave Secure running. Any ideas where I can find the most up to


  2. Rootmepls

    Rootmepls Well-Known Member

    I just got thru using AIO tool. Of course I flashed back to stock, rooted and then flashed a ROM. Not sure if this will help.

    I thought the oneclickroot was still working. Try it and let us know.
  3. vt6spd

    vt6spd Well-Known Member

  4. dbwill

    dbwill Active Member

    I have the same problem.

  5. F_L_Abs

    F_L_Abs New Member

    I've almost never had a problem rooting and installing custom roms on a Captivate until a friend of mine got an RMA replacement with the official 2.2 pre loaded...

    Anyone happen to find a solution yet?
  6. freq019

    freq019 New Member

    Super one click will root after the factory 2.2 update but in order to use and clockwork recovery you need to update the kernel to 2e using odin3 there are other threads discussing this which is how I found out how to do it.
  7. smpl_sid

    smpl_sid Member

    So I tried the SuperOneClick to hopefully root my Captivate nice and easy. Nope. I updated the official 2.2 on 3/18 and tried it. According to SuperOneClick it was successful. But when I go to Titanium Backup can't get the root rights so I can uninstall all of the bloatware that came with 2.2. The superuser app is there, and I've even gone back to the market and downloded the busybox again. Still nothing. I'm really stoked that the 2.2 is finally on my phone, But now I can't get the bloatware off?!!!
  8. kiyoshi

    kiyoshi New Member

    i have the exact same issue.. any help would be awesome
  9. SuFuCru

    SuFuCru Well-Known Member

    You have to reboot the phone after installing super one-click for the root to take effect. Had to learn that after trying 10 times.
    smpl_sid likes this.
  10. kiyoshi

    kiyoshi New Member

    Awesome! thank you!
  11. smpl_sid

    smpl_sid Member

    Hell yeah. Thanks a lot man! back to where I want to be =)

    MYFASTANG Member

    wtf...I have tried the one click method and can't get it to work. It doesn't respond when I use it. I have rooted my old captivate using the method and was done in 30 seconds. Any plans to create another one for Froyo updated captivates? I'm sick of this crap AT&T bloatware on my phone and want it gone. (If nothing else)

    MYFASTANG Member

    Ignore my last post, I needed to update my drivers from last week and then everything went smoothly. Rooted FroYo hell yeah!!!

Share This Page