Rooting an HTC EVO Shift for Dummies! (Last Updated 3/24/2010)


  1. SHMaRiM

    SHMaRiM Well-Known Member

    First of all I can almost guarantee that these are the most simple detailed instructions regarding the root process of a HTC EVO Shift that you will find on the web. This is nearly as simplified as anyone could ever make it. My information is compiled together from numerous sources and my own personal experience to give you less confident people what you need in order to root your phone and remain at ease.

    RED-Really Important Info
    BLUE-Notes from my experience and further explanations
    Purple-File names color coded for easy identification

    NOTE: I'm not responsible if you mess up your phone, however this process worked perfectly for me and it is pretty hard these days to brick your phone unless your trying.

    Rooting Process

    1.
    First, on your computer download the program "SDK" from Here. Download the file called "installer_r10-windows.exe". Install it. When prompted for the install path paste "C:\AndroidSDK" over the default path. Once finished, open it from the Start Menu. It should be right on your "C:\" drive. Now, select "Install Packages" and make sure you install "Android SKD Platform-Tools". Once finished, close out of Android SKD and AVD Manager.

    2. ONLY FOLLOW THIS STEP IF PROBLEMS INVOLVING LOADING SDK OCCUR. Next, Go to the start menu and right click on "My Computer". Select "Properties", then select "Advanced"/"Advanced System Settings", then "Environment Variables", now go to the lower box (system variables) and select "path" then "Edit". Paste the following as your path "C:\AndroidSDK\platform-tools", then select OK. This seems to have fixed most peoples problems.

    3.
    Now, on your phone, press "Menu", then "Settings", then "Applications", then "Development". Check the box that says "USB Debugging" and press "OK" when the confirmation box appears.

    4.
    Now, install HTC SYNC. There should be a folder on your SD card that came with the phone that has a HTC SYNC Setup in it. Just drag this to your desktop and run it. Otherwise download HTCSync. After installation, plug your phone into the computer and select "Disk drive" on your phones prompted menu.

    5. Next, download the z4root app from This bottom of this thread's first post and save it on your desktop. Once downloaded, Copy the file and Paste it to the SD Card root. Or in other words, drop the file in the first folder of the SD card on your phone.

    6.
    Next, switch your phone's connection status back to "Charge Only". Use any file manager (free from the android marketplace "ES File Explorer") to install the VISIONary app on your phone. On your phone just find the visionary installer in the file manager and click to install. (Icon should look like a caution sign). Once complete, open VISIONary on your phone and click "Temproot Now". Wait for the rooting process to take place. Shouldn't take long at all. At this point your phone is rooted. However, you may noticed that your phone is running slower than normal. Go back into VISIONary and put a check next to the box that says "temp root on boot". Now power off your phone and then turn back on. This will root your phone before background apps are running, thus making it much faster.

    7.
    Next, Download the root file Here. Once installed, connect your phone to your computer as a disk drive and right click on the "shift-root.zip", select extract here, then use browse to locate your phone, more specifically the root of your SD card. If you are having trouble extracting, download 7-Zip . Now change your connection type back to "Charge only" again.

    8.
    Next, Open the command prompt (Start > Run > type "cmd") and paste the following...
    Code:
    cd C:\AndroidSDK\platform-tools
    Hit enter, and type the following...
    Code:
    adb
    If adb runs you're golden. Type this...
    Code:
    adb shell
    Hit enter, you will see this...
    Code:
    $
    Now type...
    Code:
    su
    Hit enter. Now switch back to your phone. Superuser (an automatically installed program) will prompt you to "Allow" on your phone. Click it quickly to allow permissions! Now you will see this in the command prompt...
    Code:
    #
    You have root permissions. If you didn't click allow fast enough just retype "su" and click enter again.

    9.
    Next you have to Verify md5sum. Basically just make sure you copy and paste this EXACTLY...
    Code:
    md5sum /sdcard/Shift/hboot_orig.bin 
    Then hit enter.Your result should look like this...
    Code:
    386c19451e8dd18f9b98fad6b11be4c0  hboot_orig.bin
    Make sure the numbers match. You may have some extra path in front of hboot_orig.bin. Next copy and paste this exactly...
    Code:
    md5sum /sdcard/Shift/hboot_eng.nb0
    Then hit enter.Your result should look like this...
    Code:
    60ec1006e6ec2e8acb370d6aad35b17e  hboot_eng.nb0
    Make sure the numbers match. You may have some extra path in front of hboot_eng.nbo. If these do not match do not proceed. Delete the "shift-root.zip" file on your sd card and redownload.

    10. Now we're going to flash the "eng spl." This is where the unpleasant things can happen.Make sure you are in "adb shell" with superuser root permission (Granted a "#" symbol). This was explained in Step 8. If you are not in "adb shell" with root permissions (Granted a "#" symbol) then DO NOT proceed.

    Now DO NOT REBOOT until you are instructed to do so!!!
    In the command prompt, paste this EXACTLY...
    Code:
    dd if=/sdcard/Shift/hboot_eng.nb0 of=/dev/block/mmcblk0p18
    Hit enter. You have flashed the "eng spl." Now we need to make sure it flashed properly.

    11.
    Run this command to pull the newly flashed "hboot" to your sdcard. Copy and paste this EXACTLY...
    Code:
    dd if=/dev/block/mmcblk0p18 of=/sdcard/Shift/hboot_check.nb0
    Hit enter. Next you need to check the "md5" to see if it matches. In the command prompt, Copy and paste this EXACTLY...
    Code:
    md5sum /sdcard/Shift/hboot_check.nb0
    Hit enter. It should read...
    Code:
    60ec1006e6ec2e8acb370d6aad35b17e

    if the "md5sum" matches then congratulations its safe to reboot!! you
    can skip the next bit and continue on to step 12.

    If you absolutely cannot get the eng hboot to flash right then copy and paste this into the command prompt...

    Code:
    dd if=/sdcard/Shift/hboot_orig.bin of=/dev/block/mmcblk0p18

    Hit enter. Then pull it to check "md5"
    . Copy and paste this exactly...
    Code:
    dd if=/dev/block/mmcblk0p18 of=/sdcard/Shift/hboot_check1.bin

    Hit enter. Then check the "md5sum" by copying and Pasting this exactly...

    Code:
    md5sum /sdcard/Shift/hboot_check1.bin

    Hit enter. It should read...
    Code:
    386c19451e8dd18f9b98fad6b11be4c0

    If it doesn't, keep trying the previous 2 codes until it does but
    DO NOT!! reboot till it matches.

    12. Now we can Perm root!!! First you need to reboot your phone into "bootloader". Do this by turning off phone and hold (power + volume down) till it boots into bootloader. Look at the top and make sure it says "s" off. If so, reboot the phone back into android by turning off and then back on.

    13.
    Next Put the phone into airplane mode (hold down power and then click "airplane mode"). Go to setting, applications, manage applications and uninstall superuser.

    14.
    Next, temp root with z4root. After you are temp rooted then attempt to perm root with z4root. Your phone will reboot and you are now officially perm rooted any changes you make will now stick on reboot. If it didn't stick, try doing steps 13 and 14 again.

    Additional Sources:

    More Detailed Perm Root Instructions - xda-developers
    Beginner's Guide to Installing the SDK and Getting Started with ADB - xda-developers
    [GUIDE *WITH VIDEO*] ADB/Fastboot Easy 5 minute setup (Great for nOObs) - xda-developers
    [Guide] All About Rooting the HTC Shift: FAQ's & How To's (Updated 3/5/11) - Android Forums

    IF YOU THINK ANY OTHER INFORMATION SHOULD BE ADDED FEEL FREE TO SHOOT ME A PM AND I'D BE HAPPY TO ADD IT.

    ADDITIONALLY IF THIS GUIDE HELPED YOU OUT FEEL FREE TO LEAVE A THANK YOU.

    Advertisement
    deezndc, crump, frenchy714 and 13 others like this.
  2. SHMaRiM

    SHMaRiM Well-Known Member

    Simplified Backup (with WiMax Backup!)

    1. Find "ROM Manager" in the Market (free or paid) and install the app.


    2. Open it and select "Flash ClockworkMod Recovery".


    3. Click on "HTC Evo Shift 4G" and then give the app root permission if it prompts you.


    4. Once the flash is successful, you should see a dialog box that says "Successfully flashed ClockworkMod recovery!"

    5. Press OK.
    ClockworkMod should now be installed on the HTC Evo Shift 4G.

    6. Before you backup your phone, open the ROM Manager application and select "All Clockwork Recoveries".

    7. Select the most recent version, currently it is v.3.0.1.4 (If you already have the most current version skip to step 6)

    8. Press OK.

    9. Your phone will flash the most current recovery image.

    10. Now once your phone finished, open ROM Manager and select "Backup Current ROM".

    11. Press OK.

    12. Your phone will begin the backup process, including backup of your WiMax Partition.

    13. Once finished your phone will restart. DONE! A backup is now on your memory card.




    UnRooting

    1. Be sure HTC Sync is installed on your computer.
    (Link to download near top of first post)

    2. Download the sprint RUU
    Download

    3. Plug your phone in to your PC, select "charge only", then run the RUU File
    dnice208, lvpre, Kenneth196 and 7 others like this.
  3. burndog79

    burndog79 Active Member

    First of all, let me say that I really appreciate this post. You did a great job on it. That being said, lets get to work. LOL. I had a problem with the process. "installer_r09-windows.exe" didnt exist in that link, so i used _r10 instead. then the adb shell su process didnt go as planned, but I aint tryin to be a bi*chin betty. just reporting the problem. I am going to try a couple of different things and report my progress. I suspect that shortly after this post was written, the android developers forum possibly came out with an update that moved the files and locations in folders around in a bit. I'll let y'all know what I find !!!

    UPDATE: found that the adb exe file is in the platform-tools folder, but at the prompt, when i enter the command "adb shell" it just says "device not found". Any suggestions?

    yes it's an Evo shift.
  4. SHMaRiM

    SHMaRiM Well-Known Member

    I think it may have something to do with the driver. When you plug in the phone does it say "Found new hardware - ADB"?

    Also, before trying the adb shell command make sure your phone is temp rooted. If you have an emulator installed on the phone
    (free from market), open it up and type...
    Code:
    su
    you should recieve...
    Code:
    #
    then first type...
    Code:
    cd C:\AndroidSDK\platform-tools
    and then...
    Code:
    adb shell
    burndog79 likes this.
  5. burndog79

    burndog79 Active Member

    I am realizing that this might not be a problem with any of the info in this post, but that my shift is just not being recognized because the drivers will not update for it. Ive tried on two different computers, and i tried updating with the drivers located in the androidsdk\extras\google\usb driver folder. Why are the drivers not updating on either of my xp or vista PC's? I guess i need to start a new thread. LOL. Thanks for your help on this though.

    One quick question i do have though, are we really supposed to be turning the phone back to charge only before we run the "adb shell" command? just curious because im still learning this process.

    Thanks!!!
  6. burndog79

    burndog79 Active Member

    You were spot on as my previous post shows. LOL
  7. burndog79

    burndog79 Active Member

    it says windows needs to install driver software for you adb
  8. SHMaRiM

    SHMaRiM Well-Known Member

    Also, try open Visionary again and click "TempRoot Now"...

    Then try the adb shell command again...

    Another thing to try...

    Go to the start menu and right click on My Computer in XP Computer in Windows 7.
    Select properties, then select advanced/advanced system settings in Windows 7, then environment variables, now go to the lower box (system variables) and select path then edit.
    Paste the following as your path C:\AndroidSDK\platform-tools then select o.k.

    And put the phone is charge only when doing the "adb shell" cmd
    burndog79 likes this.
  9. burndog79

    burndog79 Active Member

    I keep trying that, but I think you are spot on about the driver. The thing that is strange, is that I have tried letting it search the net for the driver, as well as trying to manually install it on two different computers and it keeps telling me that windows can not locate the driver for the ADB. Weird. But yes, the debugging is on, the phone is temp rooted and plugged into usb.
  10. SHMaRiM

    SHMaRiM Well-Known Member

    Install this...HTCSync and let me know if it fixes the problem...

    read this...

    http://forum.xda-developers.com/showthread.php?t=928370
    burndog79 likes this.
  11. burndog79

    burndog79 Active Member

    Ok. For whatever reason, it finally recognized my phone. I know one thing i did wrong. I extracted both files to the root individually instead of just putting the file "shift" to the root as instructed. The re-vamped instructions helped a lot so thank you. Now to the new problem. All numbers match, I turn the phone off and back into bootloader, it says s off at the top, I reboot, and Put the phone into airplane mode, then i go to setting, applications, manage applications and uninstall superuser. then I, temp root with visionary. then I attempt to perm root with visionary. my phone reboots and I am still temp rooted with visionary on reboot, but once i uninstall visionary and super user and reboot again, I am no longer rooted which tells me the permroot didnt work. Any ideas? !!!
  12. burndog79

    burndog79 Active Member

    Ladies and Gentlemen, we have liftoff. LOL. Thanks for all your help on this.

    I finally broke down and used z4 instead. Same process, but you must remmber to add the word "busybox" (all one word) before each command (only when temp rooted with z4). then, at the end, once bootloader says s 0ff, rebooted, and temp rooted with z4. it hung on "rebooting" and i finally shut it off. then i turned it back on and I was rooted. I don't know how or why, but when I uninstalled z4 etc and did a factory reset I stayed rooted. I hope all of my shinnannigans helps the next person with the same problem. or maybe my brain is the problem IDK> LOL anyway, thanks again for all your help!
  13. SHMaRiM

    SHMaRiM Well-Known Member

    Yeah sorry about the first version. Yesterday I went through and simplified the process even further and combined steps that were very similar so that there were less steps to follow. I also revamped the instructions because certain information was fragmented throughout the OP.

    The current instructions should provide a painless and simplified way to Perm Root your HTC Evo Shift.

    If you have an questions or concerns regarding the questions, let me know. I'll be happy to modify the original post or add anything you guys feel is necessary.
    burndog79 likes this.
  14. crump

    crump Well-Known Member

    Thanks for the simplified instructions... I just made the move from BlackBerry, so I'm pretty new to rooting and Android altogether. I've been kind of riding the fence on rooting (scared to mess up my shiny new phone) but after reading this I feel a little bit more confident about giving it a try.
  15. SHMaRiM

    SHMaRiM Well-Known Member

    These simplified instructions were made just for people like you. People that have never used any of the programs involved with rooting a phone.
  16. trphg

    trphg Member

    i cant seem to find visionary at this point.. it's not in my application list. should i run it off my sd card? ill hang in airplane mode until someone replies.. lol

  17. 330D

    330D From My Cold Dead Hands VIP Member

  18. trphg

    trphg Member

  19. 330D

    330D From My Cold Dead Hands VIP Member

    If you have it on your phone, it should be in your app drawer... you have temp rooted using it? I don't understand how it would just disappear :confused:
  20. trphg

    trphg Member

    it's so strange, im currently temp rooted awaiting to finalize the perm root, but i dont see visonary anywhere under all apps.. when i try to load it off my sd card it says replace app, i click on ok and install, but then it says application not installed.

    maybe someone can shed light?

    everything else went flawlessly. the checksum matched, i have s-off, just cant do the last stages
  21. 330D

    330D From My Cold Dead Hands VIP Member

    I would say take it out of airplane mode, redownload the app, put it back into airplane mode and continue where you left off....
  22. trphg

    trphg Member

    i am basically up the the part where i unsinstalled superuser and temprooted on airplane mode... now i cant find visionary to perm root. when i reboot my phone it automatically temproots, but visionary is nowhere to be found.
  23. 330D

    330D From My Cold Dead Hands VIP Member

    I understand where you are... just try to redownload it like i said. If it isn't in your app drawer, or you cant find the .apk with a file manager on your sd card and install it again, you need to go to modaco and download it...
  24. trphg

    trphg Member

    when i hit install, it initializes the installation but then says application not installed.. can i finish off the permroot with z4?
  25. 330D

    330D From My Cold Dead Hands VIP Member

    sounds like you need to uninstall the version you have, then reinstall a newly downloaded version... I think something happened to the one you have on your phone... It happens sometimes with apps. Try that.
    trphg likes this.

Share This Page