Rooting Bell Atrix - Best And Latest Method?


  1. jared1234

    jared1234 Well-Known Member

    Ok so because this is such a new phone there seems to be some confusion in the "new Atrix owner" rooting community on what the best method is.
    I my self am confused.

    Is there a difference in rooting method between the AT&T and Bell Atrix?

    Just sort of looking for a definitive method for Bell user's when they come to this thread looking for the "Canadian way", especially considering the fact that we can't load Roms just yet because of something not being leaked and or hacked yet...kinda makes me think that we would have a different method than that of AT&T Atrix.

    With that said i just came from a Telus HTC Hero and i had to use a different method to root my hero back then versus even another GSM Hero from the UK!

    Seems Canadian Carrier's version's of phones are a little more tricky to root than other countries.

    That all being said.

    Can someone please post a link and or make a guide for Bell Atrix owners in order to prevent catastrophic failure ?:eek:

    cheers and look forward to rooting!;)

    Advertisement
    :
  2. weasel

    weasel Well-Known Member

    It's not trickier to root a Bell phone, its just different. I would imagine that it is due to the fact that the firmware is slightly different between Bell and AT&T. I used aRoot. It worked perfectly, the first time. Everything you need is over @ XDA. Look in the dev section of the Atrix forums and you'll find what you seek.
  3. jared1234

    jared1234 Well-Known Member

    cheers weasel.
    Ya i was over there and i found the gingerbreak.exe method.
    Just wanting to make sure this is an applicable method to the Bell Atrix so's not to brick it using a method meant for the AT&T method.
  4. jared1234

    jared1234 Well-Known Member

    Alright so, thanks to Roze who posted this link [SCRIPT] GladRoot v4.2 (Bell 0.37.4, AT&T 1.26/1.52/1.57 Supported - Now w/ UnRoot) - xda-developers i was able to root my bell atrix.

    If you have problems with your computer installing the atrix drivers, head on over to the motorola support site and you will eventually find your way to downloading a file called motohelper. This will install all the drivers you need like magic!


    the root process was very very easy!
    The hardest part i found was wondering why the drivers were not installing on my pc. But once i found the motohelper file it was a breeze.

    have fun and i hope this helped a few.
  5. h33t

    h33t Member

    Link is nolonger available. What's the new link?

    Thanks
  6. jared1234

    jared1234 Well-Known Member

    So since all the previous methods are not needed anymore a good place to start is here [PUDDING] International House of Pudding! BL Unlock/root thread (Updated 07/23/2011) - xda-developers

    AND i have actually created a YoutTube video guide to help get you from where ever to an unlocked bootloader with root and 2.3.4 GingerBread which can be found here ‪Motorola Atrix: Unlock and Upgrade to GB - Unlock P1‬‏ - YouTube

    just make sure you pay attention to the warnings and watch all videos before going back and starting the process =) hope this helps...

    p.s. To the mod's, you may post this in the sticky at the top of this section=)

    cheers
  7. AnguishedEnd

    AnguishedEnd Member

    I noticed in your description you used Gingerbreak to root the phone. I read on xda forums though the original gingerbreak thread that you cannot use this method for BELL OLYLA_U4_0.37.23. What's your take on this?

    edit: Now that I've watched most of your videos I see you dive straight into unlocking bootloader. Right now I don't want to mess around with RSDLite (yet Im sure I will later when I've read some more :p). What is a good method for someone who just wants to root their phone and that's all? "Preinstall method?"
  8. jared1234

    jared1234 Well-Known Member

  9. AnguishedEnd

    AnguishedEnd Member

  10. jared1234

    jared1234 Well-Known Member

    Well if you read the thread and some of the post's by other users you can find out for yourself pretty easily what works for AT&T and what works for Bell users (international users)

    As i say in almost all my video's if you need assistance then im just an email away...but it helps if your subscribed to my channel ;) thesmokingandroid@gmail.com
  11. h33t

    h33t Member

    Just to clarify, this will work for a Bell Atrix with the recent Gingerbread update from Bell (v2.3.4). The current build on my Atrix is (4.5.2A-51_OLL-17). Current System: (45.2.17.MB860.BellMobility.en.CA). Is it compatible?

    Thanks
  12. colemac

    colemac Member

    I would also like to clarify what method is best for my bell atrix with a telus sim to root.

    Build number is 4.5.2A-51_OLL-17

  13. colemac

    colemac Member

  14. h33t

    h33t Member

    That thread was posted on Feb 11, 2011, but the Gingerbread update for Bell Atrix didn't come out until Aug 29th. That usually means that the root is for the AT&T Atrix isnt it?
  15. colemac

    colemac Member

    This worked for me. I was wondering how to do on a mac from terminal?

    Does anyone have the correct commands?

    Thanks,

  16. colemac

    colemac Member

    I tried from a terminal emulator on phone and got the prompt for superuser. Looks like brief mobile guide works, unless I am missing something?
  17. Kulstad

    Kulstad Member

    Agreed. The BriefMobile method works perfectly. Read the comments section before you do it, tho.
  18. james27007

    james27007 Look into my Eye VIP Member

  19. h33t

    h33t Member

    Sorry to be redundant, but this should work for the latest Gingerbread update for the Bell Atrix am I right? I will be continuing after your confirmation. Thanks.
  20. PEPPISSED

    PEPPISSED Member

    I am also anxiously awaiting the verdict on weather Briefmobile works on Bell Atrix OTA 2.3.4. for root.

    Can someone explain, is the root.img tat is used a service flash, meaning all apps and settings are kept intact, or will the resultant rooted phone be completely reset?

    TIA
  21. PEPPISSED

    PEPPISSED Member

    I went ahead and tried the Brief Mobile link in post #19. This one uses an image file called root.img. I can confirm this worked for my Bell atrix at OTA 2.3.4. The other link which uses a file called preinstall.img may work as well but it is not the one I used, just to be clear.

    This is all done with a boot loader locked phone which lost root after the OTA update to 2.3.4.

    I have a clear screen shot of the cmd window as it all unfolded, just can't post yet.

    Things that were not clear in the link to me were entering Fastboot, the cable had to be unplugged for this, otherwise you entered rsd something or other. Once I entered fastboot, I plugged in the cable and proceeded to the command window in windows.

    Also, when it reboots after the reboot command, expect it to boot up completely. The phone will look like it is ready to use, you won't see anything on it when you issue the remaining commands. It is all done from the windows command window.

    Thanks for all the info, love the site!
    h33t and lloo like this.
  22. lloo

    lloo New Member

    I applied the briefmobile root procedure to my Bell Atrix 2.3.4 last night. Seems to have worked ok. I'm not sure if it was needed but I added "/preinstall/su" at the end of step 6.

    My questions for anyone who knows are.....

    1) Will applying the next eventual OTA update be safe to apply over the root?

    2) If I need to, how do I unroot?
  23. PEPPISSED

    PEPPISSED Member

    The following:

    It would be nice to have a little section in the OP for the recommended method to unroot in case the phone needs to go for warranty repair.

    Here you go:
    "su;mount -o rw,remount /system;rm /system/bin/su;mount -o ro,remount /system"

    Came from here:

    [HOWTO] Root any Atrix after .sbf flash - Page 18 - xda-developers

    Havn't tried it though.
    lloo likes this.
  24. h33t

    h33t Member

    After I've proceeded with the root, it looked like it worked, but after I restarted the phone it booted up fine, but my apps list is bugged out. All my icons are black except a selected few and half of the app list is overlapped with the homescreen.

    Also, the carrier signal is disconnected even when I have signal. What should I do?

    ----
    EDIT: After the second restart, the phone looks like it's running back to normal. Scared me for a second there. Will follow up for an update if anything else happens. Thanks again Pepissed for the confirmation.
  25. morvy

    morvy New Member

    Hi,

    I'd been reviewing the methods to re-root my Atrix (Bell, Toronto) after applying the [COLOR=#035c9f !important][FONT=inherit !important][COLOR=#035c9f !important][FONT=inherit !important]Gingerbread[/FONT][/FONT][/COLOR][/COLOR] update 2.3.4
    Quite frankly, I was overwhelmed, not an android expert by any means, and not real confident about typing out
    lines of script in a command prompt on a shaky vista pc, especially since last time I rooted on [COLOR=#035c9f !important][FONT=inherit !important][COLOR=#035c9f !important][FONT=inherit !important]Froyo[/FONT][/FONT][/COLOR][/COLOR] was so easy
    with Gingerbreak v1.2. Anywaaaaay, came across this method tonight:

    Pete's Motorola Root Tools

    and saw a sidebar on one forum that said "reportedly works on Atrix too, but I haven't tried it."

    For me it was roll the dice on a one click method, or tolerate Bell/[COLOR=#035c9f !important][FONT=inherit !important][COLOR=#035c9f !important][FONT=inherit !important]Moto[/FONT][/FONT][/COLOR][/COLOR] bloat, as I was afraid of xda/briefmobile methods...
    long story short, I was re-rooted in 10 min, reinstalled root checker, check!, root explorer, and titanium backup, and am in
    the process of freezing out bloat now.
    DragonJTS likes this.
Loading...

Share This Page