Rooting Galaxy S2 - Dummies Guide


Last Updated:

  1. marscon

    marscon Member

    Thx i'll try it

    Advertisement
  2. MrX1987

    MrX1987 Member

    Further to my previous post, I've had no luck in flashing a stock ICS with the following ODIN message log:

    <ID:0/051> Added!!
    <ID:0/051> Odin v.3 engine (ID:51)..
    <ID:0/051> File analysis..
    <ID:0/051> SetupConnection..
    <ID:0/051> Initialzation..
    <ID:0/051> Get PIT for mapping..
    <ID:0/051> Firmware update start..
    <ID:0/051> zImage
    <ID:0/051> NAND Write Start!!
    <ID:0/051> Complete(Write) operation failed.
    <ID:0/051> Added!!
    <OSM> All threads completed. (succeed 0 / failed 1)

    The other difficulty I have is, how do I determine my CSC without being able to boot my SGS2? I don't have a recovery section, only access to the Samsung Galaxy SII GT-I9100 splash screen or download mode (ODIN mode) as previously mentioned.

    My phone was purchased outright, unlocked so it's not linked to a carrier and the country may not even be based here in Australia. I'm thinking I recall XXLP7 however I could be wrong.

    Any recommendations? Could my phone have boot loader problems?
  3. ironass

    ironass Well-Known Member

    You can't find your CSC code if you cannot boot, other than into Download, which is why I suggested flashing the unbranded LPG firmware for Nordic Countries, (NEE), as this will flash to any GT-i9100 by using the Odin flashing method.

    Your phone is definitely a Samsung Galaxy S2, GT-i9100 and no other variant? Such as the GT-i9100T or the GT-i9100G that are sold in your part of the world. The T would not be a problem, as that is just a modem difference but the G firmware is totally different and incompatible with the i9100.

    The only LP7 firmware that I can recall that might be on your unbranded GT-i9100 is for the United Kingdom, CSC code XEU or there is an LP7 for the Indian GT-i9100G variant. Unfortunately, there have been reports that the G variant has been sold in packaging that is not marked as showing it as such. See, here.
  4. ShirazSuleman

    ShirazSuleman New Member

    Hi Guys,

    I am new the forum. This is a wonderful guide which helped me root my phone with no issues.

    I have one question though, after installing the CF-Root kernel that corresponds to my Firmware version, can I flash the latest CF-Root kernel without flashing a new ROM?

    In addition, when flashing a ROM, does it come with it's own kernel?

    Regards
    Shiraz
  5. MrX1987

    MrX1987 Member

    On the invoice I've got when I received my phone, it states Country of Manufacture: Hong Kong, if that helps. I'm trying to flash that unbranded LPG firmware as recommended without luck. In fact, ODIN has been hanging on NAND Write Start for the past 30mins as shown: ODIN-1.jpg download - 2shared

    My SGS2 is definitely not a variant of I9100 and the box looks exactly like this one pictured: [​IMG]

    My phone also came out with Gingerbread although I'm not sure which version :S perhaps 2.3.4 but it may have been 2.3.3, I can't remember.

    Would the IMEI no provide any assistance? Also, by trying to flash the stock LPG firmware, does it need to be the original firmware the phone came with? That is, Gingerbread rather than ICS firmware?

    Best regards.

  6. ironass

    ironass Well-Known Member

    Hello and welcome to Android Forums ShirazSuleman! :)

    No, the CF-Root kernel corresponds to the firmware and kernel your phone is running. There is no reason to flashing a later CF-Root kernel as this would conflict with your firmware.

    All ROM's come with their own kernel and, unless it is a stock Samsung ROM, you will stay rooted.
  7. ironass

    ironass Well-Known Member

    How odd! The LPG firmware I gave you was a generic, unbranded, stock, Samsung firmware that will flash to ant GT-i9100 phone.


    All SGSII models are released with Gingerbread firmware.

    You could try this site, here.

    No, as mentioned previously, the LPG firmware will flash to any GT-i9100 phone... except yours it seems!

    Looking at your original post from here, where you describe rooting your phone with the One-Click method from chromefans website and the phone is displaying GT-i9100 in Download mode, I'm guessing that it is a genuine GT-i9100.

    During your flashing of firmwares have you ever ticked/altered the .PIT file in Odin?
  8. Hawker

    Hawker Well-Known Member

    A few things you need to do:

    1. As you were experiencing difficulties with your charger functioning properly, first thing is to give your phone's usb port a good clean with an air duster and/or toothbrush.
    2. Whatever you are trying to flash, download it again.
    3. Make sure you do not have Kies running.
    4. Try a different USB port on your PC.
    ironass likes this.
  9. ironass

    ironass Well-Known Member

    Cheers old boy!

    I'm rapidly running out of ideas for why MrX1987 cannot flash a stock, generic, ROM. :dontknow:
  10. marscon

    marscon Member

    Hey, me again, does the LQ5 Firmware work also for LQB?
  11. ironass

    ironass Well-Known Member

    :confused:

    Firmware is the whole ROM... so you either install LQ5 or LQB firmware.
  12. marscon

    marscon Member

    Sorry, I meant CF-Root, so I have now the LQB Kernel-Version, does it work when i flash the LQ5 CF-Root on the LQB ?
  13. ironass

    ironass Well-Known Member

    Dunno! I'm guessing it should as it is still a 4.0.4 firmware. Give it a try and report back. :D
  14. marscon

    marscon Member

    Yes it worked
  15. ironass

    ironass Well-Known Member

  16. Danny II

    Danny II Member

    Help please!
    Just an a couple minutes ago i followed the rooting steps for dummies and was able to complete it with everything happening the way it was supposed to be however after finishing it i attempted to boot my phone by simply holding the power button and nothing seemed to be happening, i then held it for a minute or a bit less and it came up with the booting Samsung galaxy symbol and a yellow triangle under it. It then acts like it is powering up but then nothing happens, and the symbol disappears. I have tried taking the battery out and booting it in download mode and it still doesn't full boot. Any suggestions?
  17. ironass

    ironass Well-Known Member

    Boot into Recovery mode and wipe cache partition and dalvik cache, (under Advanced), and then re-boot.
  18. ironass

    ironass Well-Known Member

    Rooting Galaxy S2 - A Dummies Guide, posts #1 and #2 have been re-written to include the following:-

    Updated for Android 4.0.4.

    Updated some links for clarity and removed others.

    Explanation of how to get into Download and Recovery modes, with videos, in post #2.

    Added, in post #2, how to wipe cache partition and dalvik cache in case of problems re-booting after rooting.

    General tidy up for clarity.


    ironass motto... "Flash in haste... repent at leisure"
  19. ironass

    ironass Well-Known Member

    Chainfire has now released CF-Root kernels for Android 4.0.4, for:- LPO, LPT, LPU and LQB.

    I would still strongly recommend flashing the last Siyah S2 kernel .tar file via Odin, immediately afterwards, without a CWM wipe, to prevent the, "brick bug", that is present in Android 4.0.4, stock, kernels.
  20. MrX1987

    MrX1987 Member

    Sorry about the delay in replying...I just gave up in the end, took it to a phone repair place and after 3 weeks without my SGS2 and $160 later, I have a new motherboard. Unfortunately now, I'm back to version 2.3.3 on a I9100XWKF3 kernel that doesn't want to update :S Every time I click to check for updates on the phone, I receive "Connection failed" (both wi-fi and 3G). After the last episode with rooting the phone, I'm not too keen on that either.

    P.S. Thank you Hawker and Ironass for your previous assistance, I had actually used a wide range of different cables (including brand-new), different ports on my computer, cleaned the USB port on my phone and kill all processes of Kies. Sending it away seemed like the only way to get it repaired.

    P.P.S Ironass, perhaps the motherboard just gave up and became unresponsive to Odin altogether, I'm not sure but it certainly wasn't downloading that stock, generic firmware you sent me :S but anyways, is there any ideas how I can upgrade my firmware from version 2.3.3 to ICS 4.0.3?

    Thanks in advance.
  21. ironass

    ironass Well-Known Member

    That sounds as though you may have flashed an LQ5 or LQ6, Android 4.0.4 firmware, "Brick Bug", kernel in all your flashes. Fried motherboard is its trademark.

    See under, "My firmware is not eligible for ICS yet but I want it now!", in the first post, here.
  22. MrX1987

    MrX1987 Member

    Thank you very much everyone who assisted me in this thread. Your help and suggestions have been invaluable and I'm now a proud SGS2 user with ICS 4.0.3 with (following EXACTLY ironass's guide above) the correct firmware this time around. Once again, thank you :)
  23. 1981

    1981 Well-Known Member

    hey,
    i would like to clarify couple things before going ahead with my plan of flashing safely, the latest 4.0.4, LPX firmware. and then after that the latest siyah kernel, 4.1.4 version. please advise me.
    -while using the odin PC app to flash the LPX, a full wipe is needed? i am already rooted btw.
    -also, what is the procedure i should follow in Odin, to flash the 4.1.4 siyah, immediately after flashing LPX to avoid the brickbug.
    do i use need to extract the siyah 4.1.4 zip file which i downloaded, or do i use it as such with the odin during flashing.
    would it root the new flashed LPX, if i flash siyah 4.1.4 after that?
    thank you.
  24. Hawker

    Hawker Well-Known Member

    You don't have to do a full wipe but it is ALWAYS advisable. It will prevent problems popping up further down the line.

    1. full wipe
    2. start up odin and connect in download mode
    3. untick auto-reboot
    4. flash lpx
    5. if you are not going to do step 7, tick auto-reboot
    6. flash siyah (the .tar version)
    7. (optional) flash gb bootloader if you want your jig to work

    As Siyah auto-roots, this would be job done.
    1981 likes this.
  25. 1981

    1981 Well-Known Member


    thanks.
    -which method should be used best for doing the full wipe.
    by using the factory reset option in settings? should the usb storage also be cleared while doing this? or just left as it is.
    -the step 7 u have mentioned, is it best to be done too?

Share This Page