1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Rooting HTC desire Z , need help


  1. civanoz

    civanoz Member

    Hey everyone

    lately i'm rooting my desire Z , while i'm following the how to guide , at step 15 i get stuck with the next problem in my CMD.

    C:\androidsdk\tools>adb install AndroidTerm.apk
    1380 KB/s (49478 bytes in 0.035s)
    pkg: /data/local/tmp/AndroidTerm.apk
    Failure [INSTALL_FAILED_ALREADY_EXISTS]

    C:\androidsdk\tools>adb push busybox /data/local/tmp/
    1716 KB/s (1926944 bytes in 1.096s)

    C:\androidsdk\tools>adb push gfree /data/local/tmp/
    1874 KB/s (134401 bytes in 0.070s)

    C:\androidsdk\tools>adb push rage /data/local/tmp
    752 KB/s (5392 bytes in 0.007s)

    C:\androidsdk\tools>adb push root /data/local/tmp/
    112 KB/s (575 bytes in 0.005s)

    C:\androidsdk\tools>adb shell chmod 0755 /data/local/tmp/*
    Unable to chmod /data/local/tmp/misc_version: Operation not permitted

    C:\androidsdk\tools>adb push su /sdcard/
    failed to copy 'su' to '/sdcard//su': Permission denied

    C:\androidsdk\tools>adb push Superuser.apk /sdcard/
    failed to copy 'Superuser.apk' to '/sdcard//Superuser.apk': Permission denied


    anyone knows how to solve this?

    Advertisement
    :
  2. Slug

    Slug Check six! Moderator

    Which guide are you using?

    Fwiw, I recommend this one purely because the previous procedure worked for me, and it's been regularly updated by the very people who found the original root exploit.
  3. civanoz

    civanoz Member

  4. Slug

    Slug Check six! Moderator

    What is the current firmware build number installed? It's listed in Settings/About phone/Software information (iirc) and should be 1.34.x. If it's 1.72.x or 1.82.x then you'll need to downgrade as described in steps 1-12 of the guide. Once you've got 1.34.x installed follow the other guide I linked to in order to get perm-root.
  5. civanoz

    civanoz Member

    i fixed it tho , thanks

    the problem was in the dutch guide , it didn't said that i had to rename the pm10img file
  6. farizkhalid

    farizkhalid Member

    hi..
    im using this link as reference while doing rooting on my desire z..

    HTC Vision - XDA-Developers

    (under topic "How To Get R/W Access (Permanent Root / "Permaroot") using gfree v0.5 ")

    they ask me to downgrade the phone 1st before i can cont rooting the phone. so i went to this link for downgrade process as they told.

    [GUIDE] Downgrade your Desire-Z from 1.72 to 1.34 (and get root and S-OFF) - xda-developers

    when reach step 11, my phone cannot proceed the hboot process..it say "main version is older!
    update fail!"..

    my current info ~

    android ver : 2.2.1
    software no : 1.82.707.1

    anyone here can help me to fix this problem?
  7. Slug

    Slug Check six! Moderator

    Did you check which INFOCID applies to your handset, as explained at the top of the downgrading guide? Unless yours is one of those listed you'll need to make a goldcard in order to override the CID lock and flash the older firmware.
Loading...

Share This Page