Rooting of samsung mini


Last Updated: 2012-04-12 21:30:27
  1. Sargun

    Sargun Active Member

    Hello
    This is my first android phone
    I tried to root my phone with z4root but it fails.
    Then i tried with superoneclick and succeeded in first attempt.
    Now noobish question what are the advantges of rooting?

    Advertisement
  2. sobuze

    sobuze New Member

    Sargun and SreyashiG like this.
  3. griffin2

    griffin2 Active Member

    Hi! all. is it possible to root the Samsung Galaxy Mini S5570? Would appreciate links to tutorials & the tools required if it its possible to root. tnx
  4. rufsen

    rufsen Member


    How did you perform this rooting, any links?
  5. Sargun

    Sargun Active Member

    1.Install Samsung Kies on your pc(for drivers)
    2.Enable USB debugging on your phone (Go to Settings > Manage Applications > Development > USB debugging )
    3.Connect phone to pc via usb cable.
    4. Open SuperOneClick.exe
    5. Click "Root". Wait for rooting process to be finished.
    6. Reboot phone
    sigap kael likes this.
  6. mattm19

    mattm19 Member

    If the phone is rooted, does this unlock it for the use of other networks sims cards?
  7. alimooghashang

    alimooghashang New Member

    i have done the same
    and phone is rooted...
    but after reboot, every thing is back to the before...
    what to do?
  8. litheis

    litheis Member

    have you seen android in pirate icon, if you do then your phone is already rooted..
    btw the icon's name is superuser..
  9. Mir.

    Mir. Member

    I successfully rooted my Galaxy Mini! ..now what is the next thing after rooting that I need to do to save internal memory storage?pls reply
  10. aa1031

    aa1031 New Member

    guys, aside from sargun's theory of rooting the mini, anybody cant post another process or procedure of rooting it?
  11. linuxgnuru

    linuxgnuru New Member

    I've tried this myself and got an error message saying: "The system cannot find the file specified." I have installed Kies and setup my mini for USB debugging prior to starting superoneclick.exe
  12. tachlio

    tachlio New Member

    1. Install Lastest Kies for Samsung Galaxy ACES5830 from samsung website into your pc
    Here
    2.Download and install SuperOneClick 1.7 by ShortFuse
    Here
    3. Unmount your sd card under setting>sdcard and phone storage setting>Unmount SD card and then remove it from your phone

    4. Set your SGA into USB Debugging mode by ticking it USB debugging mode under Setting>Application>Developement>tick USB debugging mode

    5.Run Kies and connect your SGA to your pc using the cable (for safety reason don't use bluetooth or other connectivity)
    [​IMG]
    6.Once your Kies show that your SGA is connected to your pc, Extract SuperOneClick 1.70 into a folder using winrar.

    7.Run SuperOneClick.exe as administrator.
    [​IMG]
    8.Press Shell Root and the it will temporary root your phone and a small window will pop out
    it shown
    "Device has a temporary ADB root!
    Reboot your device to remove it"

    9 Click ok (don't need restart) and continue to press Root.

    10. After finished root, it will pop a another small window called Test? and it will shown
    Root files have been installed! Would you like to run a test? Press Yes

    11. another pop out window will pop out and show "a su. blah blah blah...." Just press ok

    12. and finally window will pop out title Rooted will shown

    "Your device has been rooted!"
    "Would you like to donate now?"
    Press yes if you want donate or else press no

    13. Unplugged and Reboot your SGA device.

    Congratulation, Your SGA Device has been Rooted!

    How to Check your device rooted or not?
    Ans : Notice there will be a SuperUser in your menu
    TaintedMaze, jarrid and techlearn like this.
  13. karandpr

    karandpr Well-Known Member

    If by chance you have Froyo 2.2 then z4root and UniversalANDroot work.
    If it is 2.2.1 or 2.2.2 then there is no other method than SOC :)
  14. faro

    faro New Member

    I have S5570 galaxy mini with Froyo 2.2.1 i trying rooting by SOC but it doesn't work.

    I got message - "waiting for device" :(

    Help me
  15. karandpr

    karandpr Well-Known Member

    Enable USB debugging
    Use the 1.9 ShortFuse withe drivers
  16. faro

    faro New Member

    I have Enabled USB debuging, 1.9 ShortFuse and Drivers form Samsung Kies

    what am I doing wrong?


    "waiting for device" ...still nothing after few seconds SOC is hangup - not responding. (i have Windows Vista on my laptop)
  17. calin05

    calin05 Member

    I have rooted my galaxy mini with that tutorial above, and now i want to un-root it, how to do ???
  18. manishgade

    manishgade Well-Known Member

    Superrrr champ... so very illustrative and perfect.... I did it with Galaxy pop GT S5570.... Thanks buddy.... A BIG Thanks
  19. manishgade

    manishgade Well-Known Member

    Superrrr champ... so very illustrative and perfect.... I did it with Galaxy pop GT S5570.... Thanks buddy.... A BIG Thanks
  20. :confused: I M still Confused





  21. What happens to Stock OS after root I M keenly interested in Apps to sd as internal memory is too low to enjoy great apps

    1) which version of SuperOneClick is best suitable for Galaxy Pop GT S5570 DDKA7 Indian Firmware

    2) What is SuperUser , BusyBox

    3) What does Odin do

    4) Do I need to make partition before root

    Help Please Android Lovers
  22. Fomelogo

    Fomelogo Member

    So i have the pirate icon in my menus. But i tap on it and opens a very poor application, if you will. Where is that whole superpower they promised? I mean yeah, you can certainly modify certain things, but.. what about deleting apps. that i just don't want?
    or things like that....

    if that's so, i think i want my money back!
  23. sopree

    sopree Active Member

    Helo guys!
    I have updated my Samsung Galaxy Mini into Gingerbread!
    When i try to root my phone with SuperOneClick it shows me that:

    Starting ADB Server..
    *daemon not running.starting it now on port 5034*
    *daemon started succesfully*

    OK

    Waiting for device...

    OK

    Getting OS Version...
    2.3.3
    OK

    2.3.3
    Pushing psneuter...
    1687 KB/s (585731 bytes in 0.339s)

    OK

    chmod psneuter...

    OK

    Running psneuter...



    After that nothing is happenig.What shall i do? ;S
  24. yagya

    yagya Well-Known Member

  25. dhruvbatra205

    dhruvbatra205 Well-Known Member

    and try reading other posts in the section cause they have all the info u need! :)

Share This Page