Rooting & Recovery procedure required for MicroMax A73

Last Updated:

  1. Neo Alius

    Neo Alius New Member

    Hi Experts

    I purchased Micromax A73 dual sim mobile. I want to install recovery & root it. Pls support.

    Neo Alius

    Phone details are as

    Model Number
    Micromax A73

    Android Version

    Baseband Version
    MAUI.11AMD.W11.37.SP.V2.P6, 2012/01/04 19:32

    Kernel Version Thu Feb 16 22:31:22 CST 2012

    Build Version

    Custom Build Version

    gta likes this.
  2. gta

    gta Well-Known Member

    try gingerbreak to root first .... go here - gingerbreak....
    please try to find your phone's manufacturer name . it will be easier to find rooting tutorials for this specific phone :)
    [manufacturer's name is written on phone's box on a sticker :p]
  3. Neo Alius

    Neo Alius New Member

    Thanks for help....

    installed usb driver for windows ADB is working. But when i connect the phone in power off mode (as i wanted to install recovery) is shoes MT65xx preloader but no driver is installed,

    Neo Alius
  4. ninadchaudhari

    ninadchaudhari What's up !

    OMG is that 2.3.5 :D
    Damn cool :D
  5. gta

    gta Well-Known Member

    no one replying ???? :p
  6. Neo Alius

    Neo Alius New Member

    Sorry for the delayed response...

    Yes ! it is 2.3.5...
  7. saivignesh

    saivignesh Well-Known Member

    I think it is also gionee (lookscreen)
  8. gta

    gta Well-Known Member

    nope its something like " huizoh " [It's not exatly like this ] , For confirmation please see the unboxing of a73 . its wrriten on the box . :p
  9. gta

    gta Well-Known Member

    @ neo alius
    try gingerbreak first & give results i.e rooted or not rooted .
  10. Neo Alius

    Neo Alius New Member


    Tried GingerBreak-v1.20.apk but not results...

    It tries to root device script finishes without notification and device never reboot

  11. ninadchaudhari

    ninadchaudhari What's up !

    guys its impossible with gingerbreak ...
    it does not even root 2.3.3 ... leave 2.3.5 !

    i am sure this won't work but try this :Unlock Root of Android
    msj003 likes this.
  12. msj003

    msj003 Member

    Hi Experts

    I purchased Micromax A73 dual sim mobile. I want to install recovery & root it

    Unlock root for Android doesn't work

    Plzzzzzzzzz help

  13. gta

    gta Well-Known Member

    super one click ?
    msj003 likes this.
  14. msj003

    msj003 Member

    It worked
    Tried Unlock root for Android again today...

    and my device is rooted

    Can anyone please tell me how to overclock this 650Mhz processor??????
    and the custom ROMs available for this device(a73)????
  15. kumar abhishek

    kumar abhishek Well-Known Member

    Can u pls provide screenshot!!
    msj003 likes this.
  16. msj003

    msj003 Member

    Here are the screenshots


  17. kumar abhishek

    kumar abhishek Well-Known Member

    Screenshot for superuser?
  18. ramjp000

    ramjp000 Member

    attach the rooting software and drivers
  19. msj003

    msj003 Member

    I am new to android
    i have rooted my a73
    installed superuser

    but which screen are you asking for
    Superuser app shows only Permissions for some apps and Log of permissions

  20. msj003

    msj003 Member

    Use unlock root

    Unlock Root for Android

    Install on ur pc
    and attach ur device
    remember to enable usb debugging mode.
    and it would be rooted.:)
  21. hba73

    hba73 Member

    unlockroot download is not working, plz help I also want to root my Micromax A73
  22. ramjp000

    ramjp000 Member

    i think micromax android phones are alone in this world who don't have rooting details. i din't know how people purchase this , its been more than 2 mnths since this phone has launched still no one can root.:D
  23. ggeorgestephen

    ggeorgestephen New Member

    Device : Celkon A88
    Android Version 2.3.5
    Baseband Version MT6573
    Kernel Version
    Build Number ALPS.GB.FDD2.MP.V3.9
    Custom Build Version 20120309.163742
    Im Trying to root the above device
    Anybody please help me
    I tried Gingerbreak, unlockroot v2.3.1 didnt work please help me
  24. ggeorgestephen

    ggeorgestephen New Member

    :musicus:Help me:stickyman:
  25. mishradd

    mishradd Member

    sometimes it just keeps looping on 'do you want try install driver' otherwise it fails 'failed to get root'

    Starting adb server...
    Get online devices
    chmod file 777 /data/local/tmp
    push file to device : rootutility
    push file to device : busybox
    push file to device : su
    chmod file 755 busybox
    Try to get shell root permission may take several minutes...
    chmod file 755 rootutility
    Try to get shell root permission may take several minutes...
    Waiting for debug mode...
    Failed to get shell root

    any sggestions??

Share This Page