Rooting Samsung Galaxy Rugby Pro (SGH-I547 / commanche)


Last Updated:

  1. kemonine96

    kemonine96 Well-Known Member

    This guide outlines how to gain root on the Samsung Galaxy Rugby Pro (SGH-I547 ATT / commanche). Please read through the full guide before attempting to root your device.

    You will need ODIN v3.04 in order to gain root on the Rugby Pro (comanche), I will not post a link due to the nature of the package. Google has plenty of links for it.

    BIG thanks to utkanos for all the help and making this a reality

    Install instructions
    • Install drivers from link below
    • Download necessary packages (clockwork recovery, root update) from the links below
    • Copy root update to your devices sdcard(s) -- Copy to both if external SD card is present
    • Charge phone to at least 80%
    • Power off the phone
    • Unplug from USB / Charger
    • Boot into download mode (Home + Volume Down + Power)
    • When asked if you want to continue, press Volume Up to enter download mode
    • Plugin phone and
    • Launch ODIN
    • Check the checkbox next to "PDA"
    • Click the PDA button
    • Select the comanche_cwr_6015_utkanos.tar.md5 file
    • Make sure only "Auto Reboot" and "F. Reset Time" are selected
    • Click start
    • Your phone will reboot one the flash is complete
    • You now have Clockwork Recovery, continue with the steps to get root
    • Power off your phone
    • Unplug from USB / Charger
    • Boot into Clockwork Recovery (Home + Volume Up + Power -- Release when Samsung logo appears)
    • Select "Install zip from sd card"
    • Select "Choose zip from sd card"
    • Navigate to zip
    • Select zip
    • Confirm
    • Reboot
    • You should now have root



    I am not responsible for anything bad that comes to your device when using the information posted in this thread. Everything here is dangerous, may cause a brick, will void a warranty and has the potential to just plain wreak havoc. Do not complain you followed my instructions and met with a dead device. Consider yourself warned


    I've tested to the best of my ability, but I am one person with one device, I cannot catch all potential failure modes. If you find a problem and a fix, or have information that should be added let me know and I will update the necessary information.




    Download Links
    Drivers: ATT_i547_Rugby_Pro_USB_Driver_for_Mobile_Phones_v1_4_7_0.exe

    CWM 6.0.1.9 Recovery Image (KemoNine): comanche_CWR_6019_KemoNine.img KemoNine sources
    CWM 6.0.1.5 Recovery Image (utkanos): comanche_cwr_6015_utkanos.tar.md5 Utkanos sources
    Stock Recovery Image (UCLI3): comanche_ucli3_stock_recovery.tar.md5
    CWR Root Update Zip: cwmr_root.zip

    Recovery sources: https://github.com/utkanos/android_device_samsung_comancheatt

    Advertisement
    rugbypro likes this.
  2. rugbypro

    rugbypro Member

    I am now rooted thanks to your through walk through. Not real sure what i can do with it but im just trying to get this package file invalid stuff to go away so i can download with google play. Can i change back to my 4.0.4 or would i even want to do that?

    Just realized how dumb that question was and i still have 4.0.4 lol
  3. kemonine96

    kemonine96 Well-Known Member

    It is mostly useful for things like backups, de-bloating (don't do this without a backup), ROM development and other fancier, lower level types of stuff. Also some apps require root to run which would be another reason to root a device.

    I'm not sure I follow this part...
    rugbypro likes this.
  4. rugbypro

    rugbypro Member

    The reason i rooted my phone in the first place was so i could download the root explorer app so i could delete the /system/bin/dalvikvm file and then go to google play app management, delete data and cache then boot into recovery mode and wipe cache and dalvik cache and reboot to try to be able to download apps from google play. After all of this i still havent figured it out. After i download anything it gives me an error message saying package file is invalid
  5. rugbypro

    rugbypro Member

    Now that i am rooted is there anyway i can at least sideload apps? I already checked the box so i can download from other sites but i try to install the apk and it will not work
  6. kemonine96

    kemonine96 Well-Known Member

    It should work so long as you enable the install of unknown applications. What is the error you are receiving when trying to install an app?

    Also, the package file is invalid error should not be happening. What carrier is your Pro and which carrier is your SIM?
  7. rugbypro

    rugbypro Member

    AT&T for both. After i transfer the files to my phone open them and press install my phone instantly says Application could not be installed
  8. kemonine96

    kemonine96 Well-Known Member

    That is very odd, I've not had any problems installing items from the market or side load applications.

    Can you try using adb to install an app? That might provide some insights.


    Also, is this a phone you bought from ATT outright? Or was it an employer provided phone?
  9. rugbypro

    rugbypro Member

    ADB? And i bought it when i just got my update a couple days ago. Fresh out of the box having the package file invalid message
  10. kemonine96

    kemonine96 Well-Known Member

    ADB is part of the android sdk.

    You may want to try contacting ATT and getting them to warranty the device.


    Is the problem when installing any app from the play store or just a specific app?
  11. rugbypro

    rugbypro Member

    It is with all apps from play store and unknown sources. I figured out something the other night and found it to be very weird. I connected to a different wifi network and the play store and everything worked great, and my girl has the samsung galaxy s 3 and she has no problems at the play store on my home network. I did open the ports to my router for google play store. IDK what to do maybe change my network setting or something i am stumped
  12. rugbypro

    rugbypro Member

    I tried to use the rom manager and it gives me a message that superuser can't be found at system/bin/su or at system/xbin/su. I just reflashed my rom and installed the new zip file then rebooted. Do i need to unboot and then reboot to get it to work?


    Got that problem fixed now it says i need to install clockwork recovery when i already have it installed. My phone is not listed to chose from to install it through clockwork
  13. kemonine96

    kemonine96 Well-Known Member

    You are correct: the clockwork recovery for the Rugby Pro hasn't been submitted an official recovery (yet). It is available for download on Android Forums and XDA (below root link includes a download for recovery).

    It sounds like root didn't go through for you. There is some good information on rooting the Rugby Pro over on xda at http://forum.xda-developers.com/showthread.php?t=1962575

    Also, a user filled in a couple potential gaps here: http://forum.xda-developers.com/showpost.php?p=34187557&postcount=70
  14. rugbypro

    rugbypro Member

    What about this ClockWorkMod Touch i downloaded it but have no idea how to install it, also i cant figure out how to get the new kernel i downloaded installed. I am currently trying to figure out more about getting rom manager to accept that my phone had been rooted. This ADB program is pretty intense but i am giving it my best shot.
  15. kemonine96

    kemonine96 Well-Known Member

    Where did you get a new kernel image from? Also, which link did you use for ClockWorkMod Touch?
  16. rugbypro

    rugbypro Member

  17. rugbypro

    rugbypro Member

    where did you input? i have the sdk and have been playing around with it but havent figured it out

    However, ROM Manager will still not accept that the phone has been rooted. I had to "adb shell", and then on the phone:
    Code:
    shell@android:/ $ /system/sbin/su (to become root) shell@android:/ # mount -o remount,rw /system shell@android:/system/sbin # cd /system/sbin/ shell@android:/system/sbin # busybox cp sh sqlite3 su /system/bin shell@android:/system/sbin # busybox cp sh sqlite3 su /system/xbin
  18. kemonine96

    kemonine96 Well-Known Member

    Looks like you have root properly setup on your phone for the most part. I think the trick is clockwork rom manager is just not liking the unsupported device.

    I'm not sure what you mean by "where did you input"?
  19. rugbypro

    rugbypro Member

    in the cmd i input each code as directed and it took them all. Is that all i need to do?
  20. rugbypro

    rugbypro Member

    i put in sdk\platform-tools then adb shell@android all that stuff and rom manager is still not recognizing that i have clockwork recovery.
  21. kemonine96

    kemonine96 Well-Known Member

    ROM Manager likely won't pickup on clockwork recovery unless you tell it "I've already installed it" or whatever the equivalent is. The Rugby Pro is unsupported in ROM Manager currently.
  22. smiley8

    smiley8 New Member

    Can someone provide me with a list of Apps that can be removed. The main reason I want to root is to get rid of all this stupid bloatware.
  23. kemonine96

    kemonine96 Well-Known Member

    Most / all of the apps carrying the ATT branding can be removed. I believe Kies and a few of the other Samsung / 3rd party apps can be removed as well. I chose to leave Kies in case an OTA comes through.

    I think the best course is to backup everything with CWR and Titanium or Ultimate backup and then start removing things one at a time. Do a few reboots along the way and see what does or does not work, restoring anything that is important to the underlying operation of the device.

    I recommend the CWR backup just in case you really mess something up you'll have the option to rollback to stock and start over.
  24. mccroan2

    mccroan2 New Member

    now that I am rooted, how can I unroot if needed?
  25. davidliles

    davidliles New Member

    I am attempting to follow the above instructions but the links to some of the files indicates they are no longer available. How can I obtain them?

Share This Page