Rooting The A100

Last Updated:

  1. fonewiz

    fonewiz Well-Known Member

    **** Do this as your own risk, you could potential damage your device beyond repair. If.....****
    **** the risk bothers you then don't move forward and do NOT attempt to root your device.****
    **** ..............I am not responsible for you turning your A100 into a paper weight.............****

    OK, just to get things going in this section, I want to offer my help with those trying to get there A100 devices rooted.

    Due to the VERY limited info on the A100's and my lack of knowledge on this device, it took me like 3 days to finally get root.

    There are 3 or 4 guides out there in other forums, all using essentially the same method with slightly modified instructions.

    I went through all these guides and it seemed I just kept missing something, somewhere because I just couldn't get the darn thing rooted.

    Finally, I came across this method which was just another variation of the same but there were some changes/modifications to the instructions that were helpful and finally got me rooted.

    As with each set of instructions I found, even this one had some things I would change a bit now that I understand how to do it. Hopefully, I will find some time to re-write some of this to make it a little simpler. I hope to make the instructions more detailed and easier to get through for those that don't have as much experience doing this sort of thing.

    Good Luck!

    There is no automated way to root the A100 that I am aware of at the time of this post. So, this is a manual method to get the A100 rooted. There are two programs out there, one called Gingerbreak and one called IconiaRoot, neither work on the A100 at this time.

    You will need a copy of the binary version of SuperUser, not the APK. This file is attached for your convenience.

    Step 1: Make sure you a file manager installed that will allow you to copy/move and unzip files. You can get various apps from the market to accomplish this I used ES File Explorer which is free from the Android Market.

    Step 2: If you don't have a terminal program on your A100, you will need one. This will allow you to run the commands below. I used Android Terminal Emulator from the Market. It works pretty good, except I can't seem to figure out how to exit the program when done.

    Step 3: Download the file to your A100. I can't remember where your browser will drop it but you will need to find it unzip it and copy just the "su" file to the root of the INTERNAL SD (mnt/sdcard, not external SD). This step is where ES File Explorer or a similar program comes in handy.

    Step 4: On your A100, open Android Terminal Emulator or your terminal program of choice and copy/paste the following commands. You will not receive any feedback after hitting enter, just another blank line with a $ sign. That's normal..

    Command Line 1: /system/bin/cmdclient ec_micswitch '`mount -o remount,rw /system`'

    Command Line 2: /system/bin/cmdclient ec_micswitch '`cat /mnt/sdcard/su >/system/xbin/su`'

    Command Line 3: /system/bin/cmdclient ec_micswitch '`chmod 6755 /system/xbin/su`'

    Step 5: Jump for joy, you should now be rooted. Move on to step 6 to make your rooting accomplishment worth while and to test it.

    Step 6: Install BusyBox from the Market

    Step 7: Install SuperUser from the market, this is the APK version this time. This is going to update the SU file and install the SuperUser app.

    Step 8: Reboot, not sure that this is needed but I think it's a good idea. If you have problems with step 9 then I would reboot for sure then retry step 9.

    Step 9: Install Titanium Backup from the market, when you run it, the app will error out if you are not rooted. If Titanium tells you that it can't gain root access then something went wrong, please follow the steps again carefully, then post here if you have no success. One thing to look out for is that you don't have any spaces before or after the commands when you are copying/pasting them into the terminal app.

    Credit goes to several folks @ XDA, particularly: abliss, brendan802 and guags99 and alphawave7 @ AcerTabletForum

    Attached Files:

      File size:
      6.5 KB

  2. das7771

    das7771 Member

    Thanks for this guide i easily rooted my a100 thanks to this. One problem I ran into though is I could not get superuser permissions until I enable debugging mode and then did the process again. You might want to consider adding that as I think it's required.

    JDGAFFLIN Member

    Thanks! Worked like a charm.
  4. Daniel0318

    Daniel0318 New Member

    I have been trying to correct this issue for over a week to no avail. Please advise.

    I've tried rooting my A100 by inputting the proper commands on the a100 itself in a terminal emulator, but have had no success. The
    commands cause no obvious response when entered into the terminal, but when I checked xbin for su, it's there. I've installed the superuser apk, but
    busybox installation fails due to lack of root. Repeating the process doesn't change anything.

    I've also tried rooting via the ADB method. The results are the same. su is in xbin folder; however, I cannot install busybox because I am not rooted.

    Every time I execute the aforementioned commands, the su file in my xbin folder gets modified. The size of the su file in my xbin folder is 0.00K, is
    this normal?

    The last bit of info I can provide about my situation is this. I have root checker installed on my A100. I do not get the same result each time I click "verify root". Sometimes it tells me that I'm rooted and sometimes it tells me that I'm not rooted????

    Please let me know if I can provide any additional information. I need some help please.
  5. Daniel0318

    Daniel0318 New Member

  6. gtaber

    gtaber Member

    Hi fellow Iconia A100 owners. I just got mine, to be a little brother to my thrive. The above method worked great for me, with a twist-I did it per the instructions above first, busybox and su.apk installed ok, but jkrim's root checker said NO! And so did root explorer. So, since I don't really trust my old eyes and small text and a virtual keyboard, and I had already checked, and could connect with ADB and knew the drivers worked, I did the exact same thing in ADB shell, but copied and pasted the commands instead of typing them. After that, typed "su" at the ADB shell $ prompt, the superuser app dialog popped up on the tablet(it was already installed in the previous attempt), clicked allow, and the ADB shell $ prompt turned to a # prompt on my PC...YAY...ROOT!
    I also had a problem with the quotation marks in the command lines- I guess I'm not familiar enough with linux/unix syntax- what exactly are those? I typed in regular quote marks, but upon examination in notepad, that wasn't what they were-I'm willing to bet that's why my first attempt in the term emu didn't work, and copy and paste into ADB shell did.
    Either way though, thanks to everybody who did something to make this available. This is the 7th android device I've rooted, and I can always find what I need on the various forums-and I got to argue that this one was a lot easier than some of the others I've done.
  7. vobguy

    vobguy Well-Known Member

    I am guessing you are talking about the backticks, which in a shell script basically says to execute that command first and take the output of that command as an argument to the other command. I do it so often I didn't even really notice it in there at first.
  8. LGCB

    LGCB New Member

    Hello I need some help here, I followed all isntruccions but when I copy/paste the comand lines and hit enter in the Terminal emulator It gives me the following message: /system/bin: permission denied.

    What can I do?

  9. Rogue65

    Rogue65 New Member

    Ok... I'm a newbie to android, and just can't figure out how to copy and paste the su file to to root. Also, I dont see a /mnt/sdcard.... just /sdcard/folder/file
  10. vobguy

    vobguy Well-Known Member

    Sounds like you most likely got a space after the word bin or possibly after the / after bin in the directory path.
  11. vobguy

    vobguy Well-Known Member

    So many possibilities as to your second problem because each file mangler (sic) has it's own quirks in my experience.

    So if you are in /sdcard try going up a directory level until you get to / , then under / you should see /mnt

    If you can't get to the / partition (called by some file managers "system" I believe, on my phone my file manager calls it "my phone" ) you may need to try a different file manager. It may warn you before you go to that partition because that is where the phone's OS lives.

    As to your first problem, that I believe is solved by putting it into the /mnt/sdcard .
  12. vobguy

    vobguy Well-Known Member

    Not sure if your next post is a double tap or you have it figured out, but perhaps there was some problem with the chmod step. That sets it as executable and makes it setuid root.
  13. lsmmello

    lsmmello Member

    Works Great!
    But I had to do this to work in my device:
    After install the superuser apk from market, open it and make a manual update.
    After all works fine!
    Thank you!
  14. silegnav

    silegnav Member

    I am having problems with your rooting method. The SU file is not present at the /system/xbin/su and cannot make a copy there because it won't let - it has to be rooted first.
  15. mrpnut

    mrpnut THE WORLD IS YOURS VIP Member

    I need help I cant get it to work. is there any way u can make a video on. how u did it I've been trying for thu last 2 hrs help......
  16. mrpnut

    mrpnut THE WORLD IS YOURS VIP Member

    i give up for some reason i cant get it, Any one can help me let me noe thx !!!!!!!!!!!!!!!!!
  17. mrpnut

    mrpnut THE WORLD IS YOURS VIP Member

    ay bro u think u could help me out I can't get done
  18. mrpnut

    mrpnut THE WORLD IS YOURS VIP Member

    I finally got to root my acer iconia a100 now just waiting for a custom rom
  19. japandroiduser

    japandroiduser New Member

    seconded! it works in debug mode!
  20. garza5

    garza5 New Member

    Busy box will not load. Says I'm not rooted. I don't really know where to copy the su file. And do you leave terminal running all the time after I copy all the commands?
  21. apollothethird

    apollothethird New Member

    Thanks, Fonewiz. It worked like a charm!

    -- L. James

    L. D. James
    <removed to prevent spam>
  22. splatoid

    splatoid Well-Known Member

    I had one question. Im I think I no the answer but I want to check before I do this.
    If I root the tablet it will still have the System intact wont it. I just want to root and flash a recovery for backup purposes. And I want the system to remain stock. Im thinking correctly on this aren't I. I tried the Script that is out there and it wont get root that way so Im going to try your way.
  23. mrpnut

    mrpnut THE WORLD IS YOURS VIP Member

    Yes your system is going to stay stock after root unless you put a custom rom.
  24. splatoid

    splatoid Well-Known Member

    Thanks for your Reply.
  25. TexAz

    TexAz New Member

    '`mount -o remount,rw /system (`') <-- what symbols are these???? Because it's NOT working here???

Share This Page