Rooting the Ally?


Last Updated:

  1. abencsss

    abencsss Active Member

    Im having a whole lot of trouble rooting my LG Ally. Gingerbreak, dosen't work to flash custom ROMs, so I unrooted and then I can't root with SuperOneClick Root method. Is their another easy method, I don't want to get to complicated with things so is their an easy way and I already tried Universal Androot. Please help me.

    Advertisement
  2. Biotic

    Biotic Well-Known Member Developer


    Waa? Install gingerbreak, format your sdcard. Run the app, wait for your phone to reboot. Should find a superuser app in your app drawer. That usually means your rooted.
    Sounds like you dont understand rooting yet...
    Anywho, continuing on... go to the market and install clockwork mod. Start it up and allow super user permissions and click on install recovery and choose ally. Safe side, install it again to make sure it went through. Then select the option to boot into recovery. If your in a different looking recovery, your golden. Download a rom of choice and place it on your sdcard, boot up into clockwork recovery and select wipe and wipe user data and cache and then choose install from sdcard. Select your rom and install. Wait for the process to complete and make sure you remember your gmail account.
  3. imnotmikal

    imnotmikal Well-Known Member Developer

    Whoa whoa whoa, don't format your SD card.
  4. ltdanno

    ltdanno New Member

    lol yea in setting under sdcard (it means it erases every thing
  5. Biotic

    Biotic Well-Known Member Developer


    Before backing up ofcourse _._
  6. abencsss

    abencsss Active Member

    Thx for the replies everyone. Everytime I try to flash a custom ROM I get an Android with a caution side then it just reboots.
  7. abencsss

    abencsss Active Member

    I'm sorry if you don't understand me, I am new to this because this is my first Android, and I used to have an iPhone so yeahh.. but this is how my screen looks like..



    [​IMG]
  8. Biotic

    Biotic Well-Known Member Developer

    Alrighty well that means the recovery didnt install or copy over correctly so what you need todo is run rom manager again and install the ally custom recovery again.
  9. abencsss

    abencsss Active Member

    Okay. So I am trying it out right now and... I STILL GET IT.
    1. I did the Clockworkrecovery again
    2. then i tried booting into recovery. :p And that android comes up
  10. Pieareround

    Pieareround Well-Known Member

    If you're still having trouble installing ClockworkMod Recovery, I've found that gnm's amonra style recovery tends to install correctly more often than CWMR. It takes using either adb or terminal emulator, so it's a bit less approachable. However, it's very worth it in my experience. Meaning it not only installs correctly more often, but also actually works better.

    Here is the link to the thread containing the recovery image and installation instructions. Make sure to pick the right recovery image for your phone (called recovery-ra-aloha on the download page). Then, use the "easy install via script" instructions in the linked thread. I did this using terminal emulator, though the thread mentions that adb is preferred. If you follow every step to the letter, you should have a very capable recovery image for your Ally, at which point many much custom ROM awesomeness can ensue.

Share This Page