1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Rooting the Atrix on a Mac?


Last Updated:

  1. silentecho13

    silentecho13 Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2011
    Messages:
    70
    Likes Received:
    1
    I don't really have a windows computer available...lol...

    I wanted to root my atrix on a mac. Anyone have any experience with this?

    Kind of new to android as well, but I love this phone already.
     

    Advertisement
  2. dsmoot

    dsmoot Active Member

    Joined:
    Feb 11, 2011
    Messages:
    39
    Likes Received:
    2
    In theory possible but surely you know someone with a windows or linux box? Worst case is download Knoppix.

    It takes about 5 minutes start to finish if you have the files downloaded.

    Probably possible on a Mac but you would be on your own... The big catch is if the USB drivers work as expected on a Mac.
     
    silentecho13 likes this.
  3. silentecho13

    silentecho13 Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2011
    Messages:
    70
    Likes Received:
    1
    I'll look into Knoppix. Thanks for the tip.

    I know people with a windows computer, maybe I'll just do it tomorrow on one.
     
  4. Droid_Genius

    Droid_Genius Well-Known Member

    Joined:
    Jun 1, 2010
    Messages:
    390
    Likes Received:
    18
    Um I am a Mac user, tried bootcamp? Load windows OS on that partition and use it just to root or whatever you need that is not available for Mac
     
  5. silentecho13

    silentecho13 Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2011
    Messages:
    70
    Likes Received:
    1
    I had a bootcamp partition installed, but for some reason my mac isn't recognizing it anymore. I can't seem to even boot into it.

    I do have a windows 7 disc to install from, but I don't have the time to sit and install it lol
     
  6. Droid_Genius

    Droid_Genius Well-Known Member

    Joined:
    Jun 1, 2010
    Messages:
    390
    Likes Received:
    18
    Oh well, I tried :(
     
    silentecho13 likes this.
  7. silentecho13

    silentecho13 Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2011
    Messages:
    70
    Likes Received:
    1
    Hey don't get me wrong, I really appreciate the help!

    Have you ever had an issue similar to what I'm having? OSX seems to not find your Windows partition anymore?
     
  8. Motofreaky!

    Motofreaky! Member

    Joined:
    Feb 2, 2011
    Messages:
    12
    Likes Received:
    3
    I'm a mac user & I rooted my Atrix no problems following the instructions.
     
  9. tical2k

    tical2k Well-Known Member

    Joined:
    Jul 24, 2010
    Messages:
    85
    Likes Received:
    8
    I got errors on recognizing the phone... maybe because i didn't install the moto sync (sorry moto media link?) crap or whatever. Just did it in ubuntu instead.
     
  10. silentecho13

    silentecho13 Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2011
    Messages:
    70
    Likes Received:
    1
    The same rooting instructions?

    Did you go into bootcamp?
     
  11. JSchu22

    JSchu22 Well-Known Member Contributor

    Joined:
    Dec 13, 2009
    Messages:
    483
    Likes Received:
    29
    Is rooting the Atrix on a Mac an easy process for someone that has never rooted before?
     
  12. Droid_Genius

    Droid_Genius Well-Known Member

    Joined:
    Jun 1, 2010
    Messages:
    390
    Likes Received:
    18
    Oh nope my bootcamp is fine and never had issues I only have like a 20GB partition for somethings that I must use Windows for
     
  13. silentecho13

    silentecho13 Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2011
    Messages:
    70
    Likes Received:
    1
    Are you running snow leopard?

    My partition disappeared once I upgraded to snow leopard.

    It would show up in disk utility and finder, but option-clicking wouldn't let me boot to it at all.
     
  14. dsjr2006

    dsjr2006 Well-Known Member

    Joined:
    Mar 25, 2009
    Messages:
    378
    Likes Received:
    14
    You can root using a Mac though I don't know what the directions are for the Atrix. No drivers needed :)
     
  15. silentecho13

    silentecho13 Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2011
    Messages:
    70
    Likes Received:
    1
    I'm not sure if there's a one click solution for mac as yet though, or its there?
     
  16. Droid_Genius

    Droid_Genius Well-Known Member

    Joined:
    Jun 1, 2010
    Messages:
    390
    Likes Received:
    18
    Yes I'm on 10.6.6, by option clicking you mean at the start up soon as you here the boot sound and gray screen pops up you holding option down? If so should have the two drives appear and let you select one
     
  17. silentecho13

    silentecho13 Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2011
    Messages:
    70
    Likes Received:
    1
    I'm really not sure what happened to my partition then :/
     
  18. Droid_Genius

    Droid_Genius Well-Known Member

    Joined:
    Jun 1, 2010
    Messages:
    390
    Likes Received:
    18
    Check disk utility and it should show Macintosh and another drive may say untitled if you didn't name it, I just named mines Windows 7
     
  19. silentecho13

    silentecho13 Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2011
    Messages:
    70
    Likes Received:
    1
    The name pops up, as well as the partition.

    OSX isn't recognizing it as a bootable partition though. I can't seem to get the selection screen when booting the computer. It just disappeared.

    I had it formatted in NTFS as well, which isn't directly readable/writeable through OSX. Maybe that had something to do with it?
     
  20. Droid_Genius

    Droid_Genius Well-Known Member

    Joined:
    Jun 1, 2010
    Messages:
    390
    Likes Received:
    18
    Well it's partitioned right could just be a bad install or glitch, may have to do reinstall :(
     
  21. silentecho13

    silentecho13 Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2011
    Messages:
    70
    Likes Received:
    1
    I'm guessing so.

    Looks like I'll reinstall :/


    Hoping to see an OSX solution to rooting though, can't wait!
     
  22. Komodo Rogue

    Komodo Rogue Well-Known Member

    Joined:
    Sep 5, 2010
    Messages:
    174
    Likes Received:
    19
    Hey OP, sorry you're having trouble! I haven't rooted my Atrix yet (and can't right now either, kinda busy but will tonight), but I think it will be much easier than you seem to be expecting... the rooting instructions for all other android devices I used had all these required drivers, programs, etc, but you should be good to go without having any of that stuff anyway.

    just plug in your atrix over usb, turn on usb debugging (settings > apps > development), pull down the notification bar (the white bar at top that has time, signal, battery, etc), and you should see something about the usb connected... press that, hit mount, and if the option pops up anywhere, select "mass storage"

    hope that helps - I'll give you a better rundown tonight, if you need it.
     
    qcom and silentecho13 like this.
  23. silentecho13

    silentecho13 Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2011
    Messages:
    70
    Likes Received:
    1

    What about running super 1-click?

    Thanks for the tip man
     
  24. Battleship

    Battleship Member

    Joined:
    Nov 30, 2010
    Messages:
    20
    Likes Received:
    10
    Have you looked at this? There is a line there relevant to Apple users (you'll need Mono v1.2.6, which I see is compatible with OSX). Good luck!
     
  25. silentecho13

    silentecho13 Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2011
    Messages:
    70
    Likes Received:
    1
    I've got Mono downloaded and installed, as well as Super One Click.

    I have no idea how to use mono.

    HALP NAO PLEES!
     

Share This Page

Loading...