Rooting the Droid without rsd lite up to and including FRG83D

Last Updated:

  1. OMJ

    OMJ Bazinga VIP Member

    flashing sbf files can cause more problems. Lots of people get stuck in bootloops after flashing sbfs and some can be hard to get out of. This method doesnt have that risk. If you follow the directions there is really no way to get stuck in a bootloop or have any other major problem.

  2. bilfdoffle

    bilfdoffle New Member

    Great guide. I'm all rooted now, only problem is I can't boot into recovery mode - It' gets stuck at the icon with the exclamation point. Normal boot works fine. I have superuser priveleges (checked by typing su into terminal).

    the ./rage command didnt' work the first time, but worked fine the second time. I also accidentally pushed the rage.bin to /data/local/tmp\ , so now theres a tmp\ directory (in addition to the normal tmp directory). Found a forum with a few other people having similar problems, but no solution that worked.

    I started with verizon froyo.

    Was hoping to load a custom rom - Any ideas?
  3. RDKamikaze

    RDKamikaze Well-Known Member

    Technically after installing the ADB and such, couldn't you just make a batch file to do the work for you?

    Example (has pauses and confirmations in noted places from original tut):

    Code (Text):
    1. @echo off
    2. echo If any part of this batch file fails or goes against comments listed, log where you are and exit the batch file immediately.
    3. pause
    4. cd C:\android-sdk-windows\tools
    5. adb devices
    6. echo This should list a device as a long number under list of devices. If it doesnt something is wrong.
    7. pause
    8. adb push c:\droidroot\rageagainstthecage-arm5.bin /data/local/tmp
    9. adb shell
    10. cd /data/local/tmp
    11. chmod 0755 rageagainstthecage-arm5.bin
    12. echo This next step can take a minute, just let it go until you are returned to your adb tools folder.
    13. pause
    14. ./rageagainstthecage-arm5.bin
    15. pause
    16. adb devices
    17. adb shell
    18. echo You should now see a # instead of a $
    19. pause
    20. mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    21. exit
    22. adb push c:\droidroot\Superuser.apk /system/app
    23. adb push c:\droidroot\su /system/bin
    24. adb push c:\droidroot\busybox /system/bin
    25. adb shell
    26. chmod 4755 /system/bin/su
    27. chmod 4755 /system/bin/busybox
    28. echo Note if you are on a build earlier than froyo this next step will fail. That is fine and expected.
    29. mv /system/recovery-from-boot.p /system/recovery-from-boot.p.disabled
    30. mount -o ro,remount -t yaffs2 /dev/block/mtdblock4 /system
    31. rm /data/local/tmp/rageagainstthecage-arm5.bin
    32. echo I would suggest rebooting your phone but its not required.
    33. pause
    34. exit

    EDIT: If you guys like this idea then I can make a command-based yes/no style batch file (prettier version) or even a VBscript that does all the work and just asks simple prompts (such as continue? Y/N, directory for ADB, etc.). What do you all think? Yeah? Rooting made a shade easier? ;)

    EDIT#2: Why is step #15 exit? Won't that just close cmd?
    OMJ likes this.
  4. OMJ

    OMJ Bazinga VIP Member

    you need to flash a custom recovery. Rom Manager will do it for you.

    a batch file would be great. would eliminate the possibility for mistyped commands.

    Step 15 is exit to get out of abd shell and back to the regular command prompt. You cant adb push when in shell.

    edit: The only possible issue I see with this would be step 5. If someone has adb in a different directory this wouldnt work.
    edit again: nm I noticed you covered that
  5. RDKamikaze

    RDKamikaze Well-Known Member

    Thanks for the info. Would you mind if I PM'd you with updates/questions/etc. on this batch file until we both deem it to be complete? For the input variant on where adb is, the only command I know is to use VBscript but I'll google to see if there's a batch variable option :)
  6. OMJ

    OMJ Bazinga VIP Member

    yea pm me and we can get it figured out.
    Smallcurd likes this.
  7. Smallcurd

    Smallcurd Member

    Thank you Sebastian Krahmer, karnovaran, and OMJ. Never rooted a phone before, followed directions step by step and copy and pasted all the commands and not a single problem (it gave an error or message on one of the commands, but it also said that same line fails for some but doesn't effect the process, which it didn't). Very good directions especially for someone who has never rooted a phone before.

    If you follow it EXACTLY you shouldn't have any problems like me.

    Thanks again and thanked.
  8. Lock-N-Load

    Lock-N-Load Well-Known Member

    OMJ -

    you should edit the title to include FRG22D since many needing this are FRG22D people and the title is kinda vague. doing that might steer them to it quicker.
  9. OMJ

    OMJ Bazinga VIP Member

    yea Ive changed the title of this thread a few times. Just did it again.
  10. patch

    patch Well-Known Member

    Batch file is good idea guys, but I don't think it work since after you use adb shell you're using that interpreter, not the windows commmand shell...

    Haven't used these tools, but you need to see how adb shell will allow you to pass scripts... for example, you might be able to do something like: adb shell < adbshellcommands.txt... or you might need multiple adb shell with commands afterwards, from what I found -- check this out Android Debug Bridge | Android Developers
    OMJ likes this.
  11. OMJ

    OMJ Bazinga VIP Member

    ugh...hopefully we can get something to work.

    I think this will still be workable just some more commands.
  12. RDKamikaze

    RDKamikaze Well-Known Member

    patch, how much do you know about cmd? Maybe we can bash our heads together here and see what solutions we can draw up.

    I have a batch file made and ready to test, I'm just passing it through OMJ first before posting. Maybe he will confirm whether adb shell will work or not.

    The way I look at it is if adb shell will work in normal cmd, why not in a batch file? It's the same thing, just automated parts. If not a batch file, what about VBScript?
  13. djembeman

    djembeman Well-Known Member

  14. LocoWTF

    LocoWTF New Member

    When I enter this command on line 14, this is what happens, is that normal?
    $ mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    mount: Operation not permitted

    Nevermind, i rebooted my phone and started from scratch. the adb shell didnt go to # like it was supposed to. It now works.
  15. djembeman

    djembeman Well-Known Member

    Step 12 tells me permission denied. What is wrong? Seem to be stuck at the $

    Has anything happened to my phone yet. Can I just stop now and forget about this for a while?

    Update: Oh... I just not have waited long enough. I have Norton installed and it scanned SuperUser succesfully after I did the push for that. Didn't expect it to be so real time.

    I rebooted my phone and my Launcher Force closed, but I read somewhere that when rooting it may take a few restarts for things to work perfectly. I have the Super User icon, but is there another way to confirm that I'm rooted?

    Great instructions by the way. I have been nervous to root and just decided to take the plunge. Thank you very much for this post. It wasn't nearly as bad as I thought it would be.
  16. cranky_dan

    cranky_dan Well-Known Member

    OMJ et all: THANKS for all the research and effort. It's greatly appreciated!

    Earlier this year (back in January) I jumped into rooting my droid without investigating safety nets (like nandroid backups) and ultimately borfed my phone with a mis-typed command. I'm not gonna make that mistake again. :) I'm ready to root again (isn't that a song title?) but do not want to rush in foolishly.

    In this pre-frg22 thread, you and your co-rooting-gurus advocate doing a backup. But in this thread you don't. Howcum?

  17. RDKamikaze

    RDKamikaze Well-Known Member

    @cranky-dan - I think he didn't mention to do a nandroid backup for one of the following two reasons:
    1. He just forgot to mention it because it's always a good idea!
    2. He might have thought because this method is 100% reversible and easy to start if you got into a hiccup spot (making it virtually impossible to brick your phone as long as it's charged) that there was no need to do the long process of a nandroid backup.

    If you want to know how to remove the root, feel free to mention it! I got the code to test mine from the OP :)
  18. cranky_dan

    cranky_dan Well-Known Member

    That makes sense. I had hoped that you were gonna say something like that. :)


    see you on the other side.
  19. OMJ

    OMJ Bazinga VIP Member

    the reason this thread says nothing about making a backup is because this method does not require or even explain how to get a custom recovery. A custom recovery is required for nandroid backups. If you want to make a backup just download rom manager flash clockworkmod recovery and make a backup. Rom Manager makes it all easy and painless.
    djembeman likes this.
  20. cranky_dan

    cranky_dan Well-Known Member

    Thanks, OMJ. I'm there, dude. I had a few weird things happen tho.

    Initially, at the second shell command, I had the '$' prompt. Things would not proceed from there. I had to start over a buncha times untill my prompt changed to '#'. From there it went much better until that last stretch in shell, 'cause shell would just bounce me out to cmd in the middle of entering (and double-checking) commands. I'd 'adb devices' to make sure the phone was still there and keep going.

    All in all, it took me about 45 minutes to an hour to work thru it.

    Thanks again to you and all the unseen helpers: Sebastian Krahmer, CRpercodani, UBRocked, and whoever else. This is a great board!

  21. Nuance

    Nuance Active Member

    The Rageagainstthecage download link doesn't work. Can you fix it?
  22. djembeman

    djembeman Well-Known Member

    Is this something recommended or essential? I'm new to rooting here, as of yesterday I have my first rooted phone (Droid 1). I would assume that using Rom Manager to flash clockworkmod recovery would allow me to go back to stock rooted 2.2 FRG22D if I tried to flash a custom ROM.

    I tried some things within' ROM manager: I flashed clockworkmod recovery and tried to do "Backup Current ROM" and it failed.

    Is there a guide that I can follow for the D1 that will explain Rom Manager and how to use it?

    Thanks for the help!
  23. djembeman

    djembeman Well-Known Member

    OK, so I tried again and noticed some of the other options while in the recovery menu. I noticed Nandroid listed... I selected Nandroid and it's doing the backup. I would guess that something is broke in the Rom Manager when it tries to initiate the backup with one click.

    Maybe there is just a setting I need to change? Anyways, I have my first Nandroid backup now, which I guess should be step 1 to flashing custom ROMs?
  24. cranky_dan

    cranky_dan Well-Known Member

    I had the same thing happen...backup failed. I can't remember what it said exactly, but it referred me to a url that was broken. Nice, huh?

    After googling, I found someone that had run into the same prob as me. In rom manager, they (at the recommendation of the broken link) repaired permissions and re-booted. That did nothing for me.

    But I also found another forum that said choose the 'reboot into recovery' option. I tried that. Got the recovery screen, exited recovery, and the phone started up. Then I chose backup current rom, and it worked.

    I feel sorta bulletproof now. :)

    But, be aware the backup you'll make is of a rooted phone. Same as mine. Just so ya know.

    Good luck.

    djembeman...r u in Idaho?
  25. cranky_dan

    cranky_dan Well-Known Member

    I just tried this link and it works for me.

Share This Page