Rooting the Droid without rsd lite up to and including FRG83D


Last Updated:

  1. Jcarmicha

    Jcarmicha Well-Known Member

    Joined:
    Jun 17, 2010
    Messages:
    118
    Likes Received:
    6
    Drivers unavailable for download.
     

    Advertisement
  2. OMJ

    OMJ Bazinga VIP Member This Topic's Starter

    Joined:
    Nov 27, 2009
    Messages:
    3,288
    Likes Received:
    825
  3. Adidas77

    Adidas77 New Member

    Joined:
    Sep 13, 2010
    Messages:
    1
    Likes Received:
    0
    For some reason I am still seeing a $ when it should be a #. I am working with a droid 1 and windows 7 on my mac under parallels, but I dont think that should matter bc I have already connected and done the beginning steps. I am currently restarting my phone a couple times as many people have said that helps somehow?
     
  4. OMJ

    OMJ Bazinga VIP Member This Topic's Starter

    Joined:
    Nov 27, 2009
    Messages:
    3,288
    Likes Received:
    825
    are you letting it run completely after step 11? It needs to completely return to the command prompt and not just the $. I have seen some say it takes 5 miutes or more. For me it never took more than a minute at most though.
     
  5. Jcarmicha

    Jcarmicha Well-Known Member

    Joined:
    Jun 17, 2010
    Messages:
    118
    Likes Received:
    6
    Okay I see Superuser Permissions on the phone :) Looking in good shape!


    Worried though:
    Wheenver I tried to make a back-up of the phone I was returned to the M and hadn't moved from there. The phone is back on but I'm not to sure what would cause it to stick as opposed to going in and making a back-up?

    On top of that we installed Rom Manager Premium and it says "Application is not installed..?"
     
  6. Nuance

    Nuance Active Member

    Joined:
    Aug 9, 2010
    Messages:
    40
    Likes Received:
    4
    Same here - they fixed it. Thanks!
     
  7. RDKamikaze

    RDKamikaze Well-Known Member

    Joined:
    Jul 3, 2010
    Messages:
    254
    Likes Received:
    57
    OMJ, I'm sorry the script wasn't working haha!! Check your PMs, I sent you the actual working one now. I forgot some code was just chilling there where it shouldn't be, d'oh!! XD

    Here's to hoping my makeshift script gets accepted!! :D
     
  8. Nuance

    Nuance Active Member

    Joined:
    Aug 9, 2010
    Messages:
    40
    Likes Received:
    4
    If I started this root method then stopped half way through will that hurt anything? I stopped after step 15.
     
  9. Jcarmicha

    Jcarmicha Well-Known Member

    Joined:
    Jun 17, 2010
    Messages:
    118
    Likes Received:
    6
    I stopped and had to restart at least two times - Everything panned out well for me! :)
     
    Nuance likes this.
  10. Nuance

    Nuance Active Member

    Joined:
    Aug 9, 2010
    Messages:
    40
    Likes Received:
    4
    Thank you sir!
     
  11. gixxalicious

    gixxalicious Active Member

    Joined:
    Aug 20, 2010
    Messages:
    31
    Likes Received:
    0
    this worked flawlessly. thank you thank you thank yoouuuu. now. quick question.... how do i install a custom rom with this? lol remember, i am not computer savvy, so dumb it down for me haha
     
  12. djembeman

    djembeman Well-Known Member

    Joined:
    Aug 7, 2010
    Messages:
    189
    Likes Received:
    23
    cranky_dan, I selected Nandroid backup from the clockwork recovery screen to initiate my first backup and now it works everytime initiating from Rom Manager. It might have needed a directory to point to first or something. I am not in Idaho.
     
  13. solidsnake

    solidsnake New Member

    Joined:
    Sep 14, 2010
    Messages:
    2
    Likes Received:
    0
    im stuck trying to root froyo. can anyone help?
     
  14. Grey1001

    Grey1001 Well-Known Member

    Joined:
    Apr 15, 2010
    Messages:
    538
    Likes Received:
    91
  15. OMJ

    OMJ Bazinga VIP Member This Topic's Starter

    Joined:
    Nov 27, 2009
    Messages:
    3,288
    Likes Received:
    825
    whats the problem?
     
  16. eddiehill

    eddiehill New Member

    Joined:
    Sep 3, 2010
    Messages:
    4
    Likes Received:
    0
  17. OMJ

    OMJ Bazinga VIP Member This Topic's Starter

    Joined:
    Nov 27, 2009
    Messages:
    3,288
    Likes Received:
    825
  18. lifewontwait

    lifewontwait New Member

    Joined:
    May 28, 2010
    Messages:
    4
    Likes Received:
    0
    I used these steps to root my droid and they worked great.
    Then, I used Rom Manager to install Bugless Beast and I lost root.
    So I re-ran these steps and I got root back.
    Then, I used Rom Manager to install Smoked Glass and I lost root again.
    I've re-run these steps multiple times and I can't get root back.
    I'm not sure what to do. Is there something in Smoked Glass that is screwing up my root? I don't get any errors when running the steps, but when I type su at on the terminal emulator, or run the SuperUser app, I get a force close message.

    Has anyone else seen this?
     
  19. OMJ

    OMJ Bazinga VIP Member This Topic's Starter

    Joined:
    Nov 27, 2009
    Messages:
    3,288
    Likes Received:
    825
    just flash this update.zip in recovery

    It should fix any problems you are having with superuser force closing
     
  20. lifewontwait

    lifewontwait New Member

    Joined:
    May 28, 2010
    Messages:
    4
    Likes Received:
    0
    Hmm, I downloaded the linked update.zip, installed it, then tried again, still no luck.

    When I type "su" in the terminal emulator, after about a 10 second pause, I get a "Permission Denied" message.
     
  21. OMJ

    OMJ Bazinga VIP Member This Topic's Starter

    Joined:
    Nov 27, 2009
    Messages:
    3,288
    Likes Received:
    825
    If you open the superuser app does it still fc? If not when you open it click on terminal emulator then forget. After that it should work
     
  22. lifewontwait

    lifewontwait New Member

    Joined:
    May 28, 2010
    Messages:
    4
    Likes Received:
    0
    Yeah, the superuser app still fc'ed. I flashed back to my original backup. Then I flashed the Smoked Glass (without flashing Bugless Beast first). Now I'm rooted, so it all seems ok.
     
  23. truesouthgirl

    truesouthgirl Member

    Joined:
    Sep 11, 2010
    Messages:
    12
    Likes Received:
    0
    ok, so I followed this guide, all good
    I have ROM Manager and made a backup with rom manager flash clockworkmod recovery
    found a ROM I want to try and have that on my SD Card
    when I use ROM manager to install, it gives the option to choose 'backup existing ROM' and 'wipe data and cache'

    selecting backup existing would not really be needed since I don't have any other ROM's yet? and what exactly does wipe data and cache mean and do? what's the benefit and what's the risk?
     
  24. Grey1001

    Grey1001 Well-Known Member

    Joined:
    Apr 15, 2010
    Messages:
    538
    Likes Received:
    91

    I just used this thread and it seems everything works, be a little patient, it'll save your nerves. :p

    http://androidforums.com/droid-roms/118513-how-install-custom-rom.html
     
  25. truesouthgirl

    truesouthgirl Member

    Joined:
    Sep 11, 2010
    Messages:
    12
    Likes Received:
    0
    oh fabulous, I just followed the instructions for clockworkmod and I got several 'force close' come up and I can't continue????
     

Share This Page

Loading...