Rooting the Droid without rsd lite up to and including FRG83D

Last Updated:

  1. StrifeJester

    StrifeJester Well-Known Member

    I have redone all of the steps and got an error about the file not found when moving the .p file which I expected. here is the output from the entire process.

    C:\tools>adb push c:\droidroot\rageagainstthecage-a
    rm5.bin /data/local/tmp
    338 KB/s (0 bytes in 5392.000s)

    C:\tools>adb shell
    $ cd /data/local/tmp
    cd /data/local/tmp
    $ chmod 0755 rageagainstthecage-arm5.bin
    chmod 0755 rageagainstthecage-arm5.bin
    $ ./rageagainstthecage-arm5.bin
    [*] CVE-2010-EASY Android local root exploit (C) 2010 by 743C

    [*] checking NPROC limit ...
    [+] RLIMIT_NPROC={1803, 1803}
    [*] Searching for adb ...
    [+] Found adb as PID 3942
    [*] Spawning children. Dont type anything and wait for reset!
    [*] If you like what we are doing you can send us PayPal money to
    [*] so we can compensate time, effort and HW costs.
    [*] If you are a company and feel like you profit from our work,
    [*] we also accept donations > 1000 USD!
    [*] adb connection will be reset. restart adb server on desktop and re-login.
    C:\tools>adb devices
    List of devices attached
    0403682802008009 device

    C:\tools>adb shell
    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    # exit

    C:\tools>adb push c:\droidroot\Superuser.apk /syste
    895 KB/s (0 bytes in 196521.000s)

    C:\tools>adb push c:\droidroot\su /system/bin
    838 KB/s (0 bytes in 26264.000s)

    C:\tools>adb push c:\droidroot\busybox /system/bin
    1921 KB/s (0 bytes in 1926944.000s)

    C:\tools>adb shell
    # chmod 4755 /system/bin/su
    chmod 4755 /system/bin/su
    # chmod 4755 /system/bin/busybox
    chmod 4755 /system/bin/busybox
    # mv /system/recovery-from-boot.p /system/recovery-from-boot.p.disabled
    mv /system/recovery-from-boot.p /system/recovery-from-boot.p.disabled
    failed on '/system/recovery-from-boot.p' - No such file or directory
    # mount -o ro,remount -t yaffs2 /dev/block/mtdblock4 /system
    mount -o ro,remount -t yaffs2 /dev/block/mtdblock4 /system
    # rm /data/local/tmp/rageagainstthecage-arm5.bin
    rm /data/local/tmp/rageagainstthecage-arm5.bin
    # exit


    DucksDroid likes this.
  2. StrifeJester

    StrifeJester Well-Known Member

    Ok not sure what changed but apparently the third time is the charm. Ran it all again and this time after reboot fired up drocap2 and as soon as i shook it to snap a screen it popped the super user permission dialog.


    I also have noticed my super user icon changed from a Ninja Icon to Andy and cross bones. In case anyone else comes across this and has the same setup as me, a former easy root user.
  3. dxc

    dxc Member

    I'm having a little problem... after doing the second adb shell instead of seeing the # i am getting the $ sign and none of the other steps work.

    What should I do?
  4. jgaeta

    jgaeta New Member

    i had this problem also and just ran the ./rageagainstthecage command again and it worked fine. try running the command again.
  5. jaydev70

    jaydev70 New Member

    how do i know if i have frg22d or not? i cant find anywhere on my fone that tells me,all i know is i am running 2.2. Want to root so bad but am a little confused still :confused:
  6. kratos

    kratos Back on my throne!!! VIP Member

    Go to Settings>About Phone and it is listed under build number.

  7. dr.diesel

    dr.diesel New Member

    This worked great on my Fedora 14 box. Directory paths are different but that is easy.

  8. asterix007

    asterix007 Active Member

    This worked great.
    However, I ended up accepting the FRG83D update last night on my phone. Now the phone is not rooted anymore.

    Can someone help to root it back again?
  9. mrjoeliec

    mrjoeliec New Member

    Anyone know if these same steps work on the latest OTA update? I have yet to accept it.... Kinda waiting for these steps to be updated...
  10. kratos

    kratos Back on my throne!!! VIP Member

    As of right now, this method is only GUARANTEED to work on builds up to and including FRG22D. However, I have not heard if anyone has tried this on FRG83D and therefore I cannot say if it will work or not.

    I'm sure we will know sooner or later.

    For the current time, try this: [APP]SuperOneClick v1.5.5 (Root, Unroot, Enable Non-Market App, Get UNLOCK code) - xda-developers as it has been tested and works.

  11. tnorris

    tnorris Active Member

    I used this method after my upgrade FRG83D and it worked fine and all my root apps work and I can su to a root console with terminal emulator.
  12. OMJ

    OMJ Bazinga VIP Member

    sweet thanks for confirming that I will edit the thread title appropriately
  13. tom777

    tom777 Member

    I've also successfully rooted fully stock OTA FRG83D with these instructions. Worked perfectly.
  14. kitcostantino

    kitcostantino Member

    Well, I had FRG22D. rooted using this method,which kicks a@@. Couldn't update to FRG83D over the air (got some kind of error (state or source i don't recall which) 7.. wiped, was still rooted. got a froyo 2.2, put it on sd, wiped, updated from .zip .... got the OTA update, then spent all night last night (till 4 am) doing the steps over and over again just to make sure. a note, cd'ing (the cd\ [enter] then [cd\ C:\....] didn't work consistantly on either computer i've been using (both Win XP, the one tonight with a fresh hard drive wipe a week ago) and so far tonight (1 am) trying to get this to work again. it all looks right. it reacts the same way, just no superuser and no root. i redid the droidroot and AndroidSDK folders numerous times to eliminate that doubt. I have
    tried the 07 and 08 versions of AndroidSDK (saw a note about tools being missing in 08 on 'theunlokr's page. i am baffled.
    I am fairly new to all of this, just bought my droid a month 1/2 ago, rooted on day one using these instructions!!! thanks for the info and any ideas
    on my current situation. also, if anyone knows how i can update my file using what i got on my phone right now, please let me know. thanks

    EDIT: okay, so i just figured it out. in the section of pushing files to the droid: 16.) adb push c:\droidroot\Superuser.apk /system/app
    17.) adb push c:\droidroot\su /system/bin
    18.) adb push c:\droidroot\busybox /system/bin
    the space before the / is imperative. apparrently doing this 20-30 times or so (literally) i didn't catch that one... yea!!!! back to my root
  15. Fratboy

    Fratboy New Member

    I followed the instructions and successfully rooted. Now I need to create a Nandroid backup. (Back button no longer works on my droid 1).

    Can anyone point me to a guide for setting up SPRecovery + Nandroid? I have not been able to find anything that includes both processes. Most of what I have found is about Nandroid saying to boot into SPRecovery and choose NAND Backup...

  16. Papadroid

    Papadroid VIP Member VIP Member

    Just go to the market and get ROM manager. Once ROM manager is installed on your phone open it up and click flash ClockworkMod recovery. Then go to backup current ROM. This will automatically boot you into recovery and create a nandroid backup.
  17. dhefke

    dhefke New Member

    A great and simply way to root....
    Awesome way to root the droid 1 phone.... however, it does not work after the phone updates.... I used this to root my droid with froyo 2.2, and then I had to re-root after the FROYO 2.2.1 update, and it works lika a champ!!!
  18. Fratboy

    Fratboy New Member

    @Papadroid - Thanks...that's exactly what I needed.

    To anyone else...has anyone done a Nandroid Backup...gone to Verizon...gotten a new Droid 1...put the old SD card in the new phone...then performed a Nandroid Recover?

    I am hoping this process will work as I plan to do it this afternoon...I just want to make sure I have my bases covered and there aren't any issues with serial numbers of phones or anything like that...
  19. Fratboy

    Fratboy New Member

    In case anyone cares or wants to know...

    Took Droid 1...rooted, installed ClockWorkMod..peformed a Nandroid backup. Wiped Droid 1 and took it back to the store. Got a working Droid replacement, rooted it, installed ClockWorkMod and restored the aforementioned backup. Within 20 minutes, my new Droid is back to having everything the broken one had and I am a happy camper.
  20. Chillinr1

    Chillinr1 New Member

    Hey guys have a problem with the steps metioned. I have a droid 1 phone and can't get my device to list when I do the adb device cmd..

    What am I doing wrong??
  21. Papadroid

    Papadroid VIP Member VIP Member

    If your typing adb devices and you don't get a serial number then most likely you don't have the proper drivers. If that is the case you can get the drivers directly from motorola.
  22. Chillinr1

    Chillinr1 New Member

    Thanks I got that to work but now when I run the ./rageagainstthecage-arm5.bin I can't get the little # sign I only get the $
  23. Papadroid

    Papadroid VIP Member VIP Member

    You may have to redo steps 11 -13 until you get the # sign.
  24. Landau93

    Landau93 New Member

    i am having issues with these instructions. to start off instead of typing rageagainstthecage-arm5.bin i have to type in order for it to work. 2nd issue im having is step 7
    it says
    2832 KB/s (o bytes in 1223661.000s)
    that doesnt seem right but anyways i continue following the steps
    when i get to step 11 and type in
    earlier it was saying syntax error, now its just saying permission denied. either way its not working for me. ive read that people are saying either step 7 or 9 were done wrong. step 7 does seem to be entered incorrectly... any suggestions?
    thank you
  25. kratos

    kratos Back on my throne!!! VIP Member

    I think that what your problem is, is that you did not extract the .zip. You MUST extract the .zip in order to have access to the .bin file.

    Landau93 likes this.

Share This Page