Rooting the Event


Last Updated:

  1. Sinner67

    Sinner67 Well-Known Member

    I picked up this phone on Thursday because the Rise I had started boot looping. I was able to root my phone by following the same steps as on the below link.

    Ok, so the link I posted here is now dead. So instead, I am posting a step by step tutorial. Keep in mind that I did not come up with this procedure. The thanks all go to other people. :)

    1) Make sure you have USB Debugging enabled by going to Settings>Developer options. USB debugging should be checked.

    2) Download Poot from the following link: http://db.tt/0HqxEURT. I downloaded this from my phone and my phone put it in the Download folder on my SD Card, but you can download it onto your computer and copy it to your SD Card.

    3) Download Ministro II from the Google Play store.

    4) Download Superuser from the Google Play store. There are several, but the one that works for me is the one created by CHAINDD.

    5) Run Poot-debug(W100).apk from your SD Card. Run the Poot application. There is a button at the top called "Press here to poot".

    6) Poot pushes su to xbin.

    7) Open Superuser application. Slide the screen to the right, going into the "info" tab. Under the "su binary" section, hit the "tap to check for updates" and update binary.

    8) If done right you now have root. You can check by installing an app such as Titanium Backup and opening it. It should request SU permissions.

    If you have any problems with this, restart your phone and run Poot and Superuser again.

    I did end up with one problem where applications were not requesting SU anymore. I just went into Superuser and updated the su binary again to the newest version.

    Advertisement
  2. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    How has that worked out for you? No issues so far?
    Keep us posted:)
  3. Sinner67

    Sinner67 Well-Known Member

    So far so good. I haven't had any issues with the root at all.
    Mikestony likes this.
  4. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Might have to add that guide to this device's root guide :)
  5. mr sprocket

    mr sprocket New Member

    Still trying to get this method to work on my Event. Any other methods to root an event?
    davidware likes this.
  6. Kritter888

    Kritter888 Well-Known Member

    Iam guessing iam no Android Pro but have a Rise that were gonna find eventually the Rise & Hydro & Event are gonna be basically the same phone with 1 special aspect about each the Rise a slider Keyboard, The Hydro Water Proof & The Event with more Internal Storage the Rise has 1gb avialable the Hydro i also believe has 1gb avialable Internal storage & the Event i believe has 4gb Internal Storage, so we should all help when One of us sides do Figure out how to bypass or unlock the Bootloader,So good Luck guys & let me know if my Theroy is Correct cause itll be good in some ways too have more help & bad cause ill have the bad news of telling you that they got both Hydro & Rise Bootloader locked down tight, and its the rom which I think I heard both rise & hydro actually have 2gb but we only have access to 1gb

    [​IMG]
  7. Sinner67

    Sinner67 Well-Known Member

    Well, per Titanium Backup, my Event shows Internal storage of 1.05 GB, and a Ext. SD card storage of 1.30 GB. My SD card does not have another partition on it. I have yet figured out how to access that 1.30 GB, other than plugging the phone into my computer. I don't seem to be able to use the space any other way.
  8. Sinner67

    Sinner67 Well-Known Member

    Ok, so I found out where I can access that 1.30 GB of space. I use Root Explorer, and the extra space is located within /sdcard/internalSD.
  9. yashmack

    yashmack New Member

    the link from OP is dead
    any ideas on how to root this phone?
  10. Sinner67

    Sinner67 Well-Known Member

    I have changed the original post to show the instructions.
  11. Prosophobia

    Prosophobia Well-Known Member

    Not working for me. :/ Said it got an error 69 or 68 or something like that. Tried restarting multiple times.
  12. AndyG1128

    AndyG1128 New Member

    This process worked like a champ for me. Easiest root I've ever done.
  13. DraeHD

    DraeHD Well-Known Member

    Poot failed during the run, error 68/69 - Daemon materialized, I believe. Asked me to restart.
  14. Prosophobia

    Prosophobia Well-Known Member

    Same here.
  15. DraeHD

    DraeHD Well-Known Member

    Generally poot works but I guess not for us lol. I have no experience in rooting aside from using tutorials so I can't find much out.
  16. PenguinSpy

    PenguinSpy New Member

    I got the Daemon error as well but I just hit retry and it works from there. It is rooted now after following the OP's instructions. Thanks man.
  17. DraeHD

    DraeHD Well-Known Member

    Well I might as well try again.
  18. deathneed

    deathneed Well-Known Member

    about to attempt, will post results in soon.


    edit: tried multiple times with no luck, going to attempt another root tut thats Ive seen lying around, If it works I'll make a thread for it.
  19. hippie1620

    hippie1620 New Member

    Worked for me on the second try. First time I restarted by holding the power button. Appeared that it didn't work. I ran poot again and this time shut down and restarted. All good so far. Bought my phone on the the 24th. First android and first root. Came from a 3g on 4.2.1. A little outdated. lol

    On edit: I too for an error. Think it was 64 about a daemon. If you Google it it leads to a thread here that says its OK do the restart.
  20. SonOfAnarchy

    SonOfAnarchy Member

    Just bought an Event this morning. Going to attempt this root method now. Wish me luck! Will be back with my results :)
  21. SonOfAnarchy

    SonOfAnarchy Member

    First try I got the 64 error and it told me I need to restart my device. Doing so now then I will try again!

    Edit: And again. lol

    Edit #2: Well I have tried 4-5 times now and just keeping getting the same error n restarting my device. Should I keep trying or should I just go to the other method?
  22. idbl_fanatic

    idbl_fanatic Well-Known Member

    Thanks!!! Worked perfect!
  23. nayrej

    nayrej Member

    Rooted the event after a few tries. I have no skill for development, so I am waiting patiently for any kernel/mods/custom roms to buffer developed. I like this phone.
  24. Bstressfree

    Bstressfree Well-Known Member

    Tried downloading POOT from the link supplied. Got error 404. Must I sign up for DropBox to access the download?

    Edit: DUH nevermind. I tried typing the link as shown into my phones browser. Didn't work. Yet when I actually just click the link it does work.

    TADAAAAA! worked, simple as pie. Now can anyone recommend a free wifi tethering app?
  25. UnhandyFir9

    UnhandyFir9 New Member

    After you get done with this process and if it is successful, is it safe to uninstall Ministro and Poot?

Share This Page