Rooting the Motorola Admiral


Last Updated: 2013-01-23 07:12:34
  1. zeda

    zeda Member

    Just wanted to mention that the button is NOT a mute button. It changes the speaker from the loudspeaker to the regular (phone) speaker. However, I know nothing about DC because I don't use that feature.

    I will try rooting the phone soon.

    Edit: Can anyone post the links from mydroidworld? I'm not a member (yet?) and can't see them.

    Advertisement
  2. zeda

    zeda Member

    EDIT2: I've managed to get up to the point where I'm at the OneClick rooting process, before everything stops working.

    As for the command prompts, Android SDK, and "ADB devices" thing, I figured that out with the help of:

    http://androidforums.com/admiral-all-things-root/447431-admiral-all-things-root-guide.html
    AND
    How to get your phone back on the upgrade path...

    Needed to research some things too.

    I am testing SuperOneClickRoot 2.3.3 by Shortfuse and Pete's Motorola Tools: Motorola Gingerbread 2.3.4 One-Click Root, but neither seem to be working (program freezes and other one gives me an adb permission error, respectively). I have tried rebooting my phone and running the programs through command prompt without avail. It would really help if I knew what OneClick program you are successfully using...

    Anyway, I really need to root this phone for various reasons. One of them is to delete the obnoxious camera shutter sound because it affects my work (as a photo rep).

    If anyone could give me any feedback about what to do that would be excellent! Thank you
  3. SurrealOne

    SurrealOne Well-Known Member

    When you go to a command prompt try it like this click the start button type in CMD when you see the cmd.exe right click and run as administrator. if you still have problems I will try to give you some screen shots tomorrow. good luck
  4. zeda

    zeda Member

    Hello SurrealOne, thanks for responding! I will try the administrator thing. My main question is what program are you using to root?

    Edit: I opened SuperOneClick v2.3.3 from Command Prompt as Administrator and still got the same error:
    "Shell rooting device... - Step #7 ShellCommand 2.07s" The program hangs and stops responding until I unplug the phone. Then I click "Root" again and the same problem occurs.

    I don't know how to open up Pete's Motorola Tools One Click Root through Command Prompt because its adb is in a separate folder from the file. When I try to go through the root process it works up until this message appears:

    ERROR: adb could not be granted root access via local.prop method

    Try again from the start, but if the problem continues, check your version
    of Gingerbread -- hopefully you don't have a version where this exploit
    was fixed.
  5. SurrealOne

    SurrealOne Well-Known Member

    It sounds like you might have a driver problem. But I'm not sure. I had problems too. But after a few try's I did get it. I used the directions in the first post in this thread. I think maybe if you start a new thread maybe somebody should be able to help more then I can.
  6. zeda

    zeda Member

    I tried it like 20 times, using the directions in the first post as well. I don't think it's a driver problem. I installed all of the Motorola drivers fine and the phone charges when the USB is set to "None". In another forum they said that in Device Manager, under ADB Interface, it should say Mot Composite ADB Interface, which it DOES. As for the adb.exe, in the command prompt the daemon starts and it lists my device as attached.

    The link in post#6 leads back to mydroidworld, where they haven't activated my account yet (can't see any links).

    So, from what I gathered from the post, I should MANUALLY root the phone through command prompt after downloading the exploit (exploit, su, Superuser) [I guess I'll have to look for something similar online; or can I use SuperOneClick's file contents?]

    I hope I don't brick my phone or end up in an endless bootloop.
  7. SurrealOne

    SurrealOne Well-Known Member

    maybe check your junk mail folder it does not take that long to get the activation request back. And if ADB can see the device then it sounds like you are on the right track.
    zeda likes this.
  8. zeda

    zeda Member

    Yes!! Thank you lol I never get spam or accidental spam so I never check. Registered now. :)

    I'll try the steps now and update you if it works.

    Edit: OK, went through the whole process. It was going great and I got up to "Killing ADB and restarting as root... Enjoy!" Then I started going through the second set of commands (step 5), however, it said "cannot create /system/app/Superuser.apk: read-only file system" and later "chmod /system/bin/su: No such file or directory". I rebooted, still no root.

    So if I'm going to retry should I restart the entire process or only after step 5? Everything seemed to work until that point.
  9. zeda

    zeda Member

    IT WORKED. I went through the entire process again twice. Second time I searched through the pages of that mydroidworld thread and was able to resolve any new errors. I now have Superuser installed.

    For anyone else trying to root the Admiral I advise you to read through the links and posts on this thread and follow the mydroidworld thread steps EXACTLY. Don't go through any programs (e.g. SuperOneClick) to root, instead type out the commands through command prompt to get this to work.

    Thank you SanDiegoStevo and SurrealOne for all your help and tireless efforts! :)
    SurrealOne likes this.
  10. SurrealOne

    SurrealOne Well-Known Member

    Glad you got it going.
  11. zeda

    zeda Member

    Open Garden Wifi Tether was mentioned before. After installing it I tried it out twice and both times it crashed before rebooting my phone. That didn't work, however, Wifi Tether works perfectly.

    Titanium Backup works fine.

    I was also able to rename the camera and camcorder shutter sounds through Terminal Emulator. After a few minutes my phone screen completely glitched and I thought I bricked my phone. It rebooted though, and now everything seems fine. No more startling camera sounds. :)
  12. SurrealOne

    SurrealOne Well-Known Member

    Can you share what ver of wifi tether you are useing? and where did you get it? Thanks
  13. zeda

    zeda Member

    SurrealOne likes this.
  14. SurrealOne

    SurrealOne Well-Known Member

    did you get anything connected to your phone yet? and if so are you using the WiFi or are you using USB tether?
  15. zeda

    zeda Member

    I used my phone's 3G Network as a Wifi hotspot. No USB needed. When I first connected "Mobile IP Registration Error" popped up but that didn't affect anything. I connected 2 different PCs to the network.
    SurrealOne likes this.
  16. SurrealOne

    SurrealOne Well-Known Member

    Nice work!!!!! I did not even try to connect when I saw the mobile reg error I just gave up. I just tried it and got it going. :D
  17. SurrealOne

    SurrealOne Well-Known Member

    did you change any other settings? and were you able to browse the web on your WiFi connected PC When I connect my Laptop to my Admiral via WiFi it says limited. And not able to browse the web
  18. zeda

    zeda Member

    I changed the SSID (I didn't care for the preset network name). Access-Control is enabled (I don't know what that is but it's on). Nothing's limited and I'm able to browse the web fully.

    If none of the above works for you, maybe you can try rebooting your phone or computer?

    EDIT: I tried the app just now and said it had a limited connection to my PC. Might've been because I've been messing around with my network settings trying to get RealVNC to work over 3G. Anyway, I resolved this through Network Diagnostics (Windows said DHCP was not enabled for "Wireless Network Connection" and it fixed it). In the app press Menu and go to Access Control (if it's enabled) and you can authorize the client (your PC) that should appear.
  19. SurrealOne

    SurrealOne Well-Known Member

    Can you do a Speedtest.net on the PC that is connected to the admiral and tell me what kind of speed it is getting from your 3g motorola admiral?
  20. zeda

    zeda Member

    Download speed: 1.80 Mbps, 1.96 Mbps
    Upload Speed: 0.54 Mbps, 0.34 Mbps

    Tested it twice, it's fast enough for me. Just tested a Youtube video and it buffered pretty quickly! Mine's probably affected by my Sprint Airave device though, which gives me full bars. I haven't tested out the app away from home yet either.

    Is it working on yours? What are your speeds?
  21. SurrealOne

    SurrealOne Well-Known Member

    it was working but I changed apps and it stopped working. If you look at the WiFi connection window on the PC does it say it is PEER to PEER? On my ROOTED Nexus S 4g phone that I also have WiFi tether it works just fine and it uses a PEER to PEER connection just like it should. But with my 3G motorola it does not use PEER to PEER like it should be it says connected but not able to browse the web. Take a look at the screen shot I have. I think you should try the WiFi tether outside in the wild.

    Attached Files:

  22. zeda

    zeda Member

    Doesn't say "Peer-to-Peer", it appears as a completely regular Wifi network. Like I said I have no idea if the Airave may be affecting it (that's connected to my router and modem).

    Outside in the wild, lol. How about I just turn off my modem and see if that changes anything?

    Edit: Well I unplugged everything for like 10 minutes and it still works like it did before, as a regular network. Download speed went down to 0.48Mbps though, upload is the same.

    Would you like screenshots?
  23. SurrealOne

    SurrealOne Well-Known Member

    or just turn off the modem :)
  24. zeda

    zeda Member

    Here are some screenshots, the network is called "mystery_network".

    mysterynetwork.png
    mysterynetwork2.png

Share This Page