Rooting the Spectrum 2


Last Updated:

  1. lazymangaka

    lazymangaka Member

    Apparently there's been some success in rooting the LG Spectrum 2 already. The Bootloader Pwnage Tool for the Spectrum evidently works just fine. I'm a little nervous to try it myself--hate to brick the phone so soon!--but at the same time, rooting is so tempting...

    Advertisement
  2. admiral ackpoux

    admiral ackpoux Well-Known Member

    just browsed through it but didn't see anyone say about it working on the spectrum2 I would personally wait, or pm someone who used it successfully and see how they went about doing it before going forward
  3. lazymangaka

    lazymangaka Member

    Well, the thread that said that root method works was this one. Apparently the root worked just fine, but the user attempted to flash a Spectrum 1 ROM and that bricked the phone.
  4. admiral ackpoux

    admiral ackpoux Well-Known Member

    to be honest I would still wait just off the fact all that you could do with root at this point really is delet bloat, but ICS allows you to disable bloat anyways, I'm super excited about this phone but patience is a virtue. Still waiting myself. Plus after reading the posts the rom probably did it but He's not sure if it was him installing CWM on his phone either.
  5. tgamblin

    tgamblin New Member

    subfloor and lazymangaka like this.
  6. hollywoods14

    hollywoods14 Well-Known Member

    Be careful with the pwnage tool, that is not just root. That roots, unlocks bootloader by installing a custom kernels for the spec 1 and installs CWM.
  7. lazymangaka

    lazymangaka Member

  8. tgamblin

    tgamblin New Member

    Although i managed to brick mine with the "Security Error" because i didnt know i could delete the stupid google play movies app -.- Its all good though. Went and played dumb to verizon and they are sending me a new one lol
  9. admiral ackpoux

    admiral ackpoux Well-Known Member

    Just got mine rooted as well but for some reason having issues with changing the boot animation. It's been changed and everything is correct but is just a black screen now. Any one else having this issue?
  10. lazymangaka

    lazymangaka Member

    I haven't tried changing the boot animation, but about an hour ago I started getting an issue with random shutdowns. I was using BaconReader to browse Reddit, and the screen went blank. I did a battery pull, but that didn't solve anything, still blank and wouldn't turn on. I had to pull the battery, plug it into the wall charger, then unplug it and put the battery in to get the phone to boot up. Then, when I was trying to research the issue using Dolphin Browser it happened again. Same arduous process to get it to reboot. Problem is, I can't seem to force it to do that. Downloaded Stability Test, and that didn't cause any issues. Opened 2 dozen tabs in Dolphin Browser, and it didn't do a thing. I even sat there pressing the power button rapidly for about a minute to try and get any sort of result to no avail.

    Frustrating!
  11. tgamblin

    tgamblin New Member

    Im got my replacement in... leaving it un-rooted this time to avoid creating a brick haha. didnt really do anything but free up some on board memory for me and since im happy with the stock UI i dont see a point lol
  12. pbmax

    pbmax New Member

    I rooted mine and have no problems with it.

    But you can't do anything else yet like intall CWM, unlock the bootloader or flash CM10. That type of activity is device specific.

    Hopefully someone will work on this soon. Unfortunately, the Spectrum 2 isn't that popular with developers especially with all the other new devices coming out like the Nexus 4 and HTC DNA.
  13. maimaitou

    maimaitou New Member

    Hi can you tell me what kind of root method you have used? I just got mine and i wish it could be stable after root.
    And it's weird why spectrum 2 is so unpopular.
  14. XXXGeek

    XXXGeek Member


    One thing you don't want to do.. [START REMOVING BLOATWARE] ....As Posted By, "MrB206" (First find out what you can and can't remove) that's what I didn't do, I removed some of the bloatware without checking any threads. Then after I rebooted....I got a screen with the LG logo that said "Security Error" now my phone is Soft bricked! Has any one been able to fix from this security error issue?

    UPDATE!! :party: BICKED PHONE FIXED! THANKS "Neph81" FOR ALL YOUR HARD WORK!

    ​Downloaded the KP500 Util Tool, click on->http://androidfiles....ls/LG_Tools.zip and unzipped it to your desktop.
    Next download firmware, click on->http://VS93011A_00.S11A_00.P58016.R5 wait for it to finish downloading. Next open and put the firmware in the "LG_Tools" folder on your desktop.

    Next Charge your battery to "FULL".

    Make sure you have the right driver package and LG Support Tool from http://www.lg.com/us/support-mobile/lg-LGVS930 and install.

    Next go into your Windows Device Manager and disable the device under Modems -> LGE AndroidNet for VZW USB Modem

    Remove your battery and remove your memory card.

    Reboot your phone in "Download Mode" (re-insert your battery and replace the back plate. Hold down vol up + vol down. Plug in usb cable while holding both buttons.) after the download screen come's up on your phone, you can let go of the vol controls. Now open the "LG_Tools" file on your desktop and follow bellow.

    1. Run your "KP500-Utils-EN.exe" as administrator
    2. Choose: I "Flash with assistance (file .cab)" and press enter.
    3. Next it will show: "Phone Model (KP500)" enter VS930, and press enter.
    4. Input the full path to your cab file including .CAB at the end (i.e. C:\Users\YOUR COMPUTERS NAME\Desktop\LG_Tools\VS93010E_05.S10E_05.P58015.R5.cab) and press enter.
    5. Now Input the full file name of your cab without the Cab (i.e. VS93010E_05.S10E_05.P58015.R5) and press enter.

    You will see the LG update tool pop up, and a indicator bar will start, then it will stop, and you will see a pop up that says "Click to Restart" click on, and It will go threw extracting the cab file and then extracting a .bin file. Wait for your phone to finish flashing and let it reboot on its own. "This Took Some Time For It To Complete" Now It's Working Again...Thanks To "Neph81"

    Click on this link for information to the-->LG Spectrum 2
  15. thejman1986

    thejman1986 New Member

    I tried that site with my IMEI and to no avail. I actually had my rooted and all went fine till I tried the beats audio driver install. Yeah it was all down hill after that, restarted phone and got the LG logo and the screen went blank. My question is the firmware you downloaded -VS93010E_05. is it compatible across devices. Will it work with my VS930 also I guess that's what i'm trying to say. Like I said the only firmware i can find is ICS for the VS920. Do you still have a copy of that firmware?
  16. thejman1986

    thejman1986 New Member

    nevermind, I found the firmware and downloading now thank you.
  17. thejman1986

    thejman1986 New Member

    The method u stated to fix phone worked for me thank you!!
  18. hroark13

    hroark13 Well-Known Member Developer

    can someone post a link to the cab file

    I do not have an IMEI to use, but I need to download this file
  19. hroark13

    hroark13 Well-Known Member Developer

  20. hroark13

    hroark13 Well-Known Member Developer

  21. w4rbytez

    w4rbytez New Member

  22. Jimi Mack

    Jimi Mack Member

    I have soft bricked my Spec 2 three times already, in an attempt to strip it down to the bare minimal. If anyone has had success I would love to hear what apps you were able to remove without bricking. I have been going trough it by trial and error and get a little tired of restoring. :)

Share This Page