1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Rooting UMX u670c android 2.3.6


  1. Adam A Farley

    Adam A Farley New Member

    Been searching for weeks, not been able to find a root that would work

    Phone is umx u670c

    Where I live, android phones are highly limited with what works and what don't.

    This was the only phone we could find that would work with a prepaid system like net 10.

    Took 2 hours on the phone with them to get it to even work. I live in a little rural town with 329 people lol. Country living and I love it.

    What I like to know is if there is a safe way to root this phone so I can loose some bloat.

    What I have tried

    Superoneclick

    Oneclickroot

    Gingerbreak

    Rooted

    Any help would be great, thanks.

    Advertisement
  2. mike9013x

    mike9013x New Member

    well i have the same problem bro, no solution yet. i thought ide at least let you know that ur not alone. my plan is to call the bastards at umx and inquire about a usb driver, thats all we need. i do have a general question....how do you go about making a usb driver for a phone like this with out manufacture support??!! is this possible???.....:confused:
  3. mikedt

    mikedt 你好 Guide

    For the benefit of anyone reading this thread:-
    http://androidforums.com/android-lounge/631594-off-brand-phones-tablets-worth-low-cost.html

    I don't think you'll be able to. Seems they're out of business.

    UMX was just an importer, the phone itself is Chinese and of unknown manufacture. Which basically means it's almost impossible to find rooting information for it. And if the suggested rooting tools and drivers don't work, that's pretty much it.
  4. sleco69

    sleco69 Member

    I had the UMX model MAX, from Public Mobile, small carrier only in Montr

    Attached Files:

    jpduarteunlock and mikedt like this.
  5. Adam A Farley

    Adam A Farley New Member

    Thanks for the drivers. So far no luck, curious if you pull it off.

    If you manage to root is successfully, please do share HOW you did it.

    Some detail on a safe way would be great , carrier is net10.

    Net 10

    strait talk

    Both are selling this phone like hot cakes. Good price when money is so tight.
  6. smartmanvartan

    smartmanvartan Well-Known Member Contributor

    hey guys... was just skimming through... i had a very similar phone with public mobile.. it was called the umx max and it was a piece of crap... it was manifactured by teleepoch in china and distributed by umx... the model numner from umx was the mxe 670

    SMART PHONE - UMX

    umx will offer no support what so ever i must have emailed them 20 timesand then the phone gave out on me for the second time and i switched to an other phone... is this your phone? you can get adb to work with pdanet, it has universal adb drivers and maybe from there you can try pulling your recovery img and build a clockwork recovery using the builder website:

    Recovery Builder

    and then once you have the cwm recovery you can try the "adb reboot bootloader" command and once in bootloader mode try the "fastboot flash recovery c:\recovery.img" (note that the cwm recovery you made has to be named recovery.img and place in the root of your c: drive).
    then type "fastboot reboot" and push and hold vol up immediately and cwm recovery should pop up... figure the keys out...

    then flash the superuser installer:

    http://downloads.noshufou.netdna-cdn.com/superuser/Superuser-3.1.3-arm-signed.zip

    if everything goes well you should be rooted....

    pm me if you have any questions because i don't thing i will be passing thru here again..... good luck :)

    I made a big mistake... i wont delete this because there is still very useful info in here but this wont work because you need root to pull your recovery with adb..... sorry guys..
  7. isaih

    isaih New Member

    hi, i was wondering if you know ho to root the andriod UMX u670c. i have already installed it's drivers using ADB.... any suggestions?
  8. toxinburn

    toxinburn Member

    I have tried several different xploits that exist myself with zero luck so far on this phone too, it really could use a root with such a low internal memory.
  9. toxinburn

    toxinburn Member

    I would like to point out that by installing ES file explorer apk from the market on this phone I am able to browse the internal memory now, and now possibly transfer the factory stuff over to my pc maybe it will be possible to get a ball rolling with that, if anyone out there has experience with creating a root method etc. lemme know if their is something I can extract from the internal storage that would help at least I can get into the root folder with es vs using adb in shell I cannot even enter the folder
  10. toxinburn

    toxinburn Member

    Okay I have found one file that seems to be interesting to me the platform.xml file and i am thinking this is what needs to be edited to give a root based off of what I am reading within however I am not sure how to set it manually from this point for instance...this is what is contained within and I can apparently read and write to this file.

    EDIT: Cannot save it once edited. :(



    <?xml version="1.0" encoding="UTF-8"?>
    @namespace html url(http://www.w3.org/1999/xhtml); :root { font:small Verdana; font-weight: bold; padding: 2em; padding-left:4em; } * { display: block; padding-left: 2em; } html|style { display: none; } html|span, html|a { display: inline; padding: 0; font-weight: normal; text-decoration: none; } html|span.block { display: block; } *[html|hidden], span.block[html|hidden] { display: none; } .expand { display: block; } .expand:before { content: '+'; color: red; position: absolute; left: -1em; } .collapse { display: block; } .collapse:before { content: '-'; color: red; position: absolute; left:-1em; } <!-- Copyright (C) 2008 The Android Open Source Project Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0 Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License. -->
    <!-- This file is used to define the mappings between lower-level system user and group IDs and the higher-level permission names managed by the platform. Be VERY careful when editing this file! Mistakes made here can open big security holes. -->
    <permissions><!-- ================================================================== -->
    <!-- ================================================================== -->
    <!-- ================================================================== -->
    <!-- The following tags are associating low-level group IDs with permission names. By specifying such a mapping, you are saying that any application process granted the given permission will also be running with the given group ID attached to its process, so it can perform any filesystem (read, write, execute) operations allowed for that group. -->
    <permission name="android.permission.BLUETOOTH_ADMIN"><group gid="net_bt_admin"/></permission><permission name="android.permission.BLUETOOTH"><group gid="net_bt"/></permission><permission name="android.permission.INTERNET"><group gid="inet"/></permission><permission name="android.permission.CAMERA"><group gid="camera"/></permission><permission name="android.permission.READ_LOGS"><group gid="log"/></permission><permission name="android.permission.WRITE_EXTERNAL_STORAGE"><group gid="sdcard_rw"/></permission><!-- The group that /cache belongs to, linked to the permission set on the applications that can access /cache -->
    <permission name="android.permission.ACCESS_CACHE_FILESYSTEM"><group gid="cache"/></permission><!-- RW permissions to any system resources owned by group 'diag'. This is for carrier and manufacture diagnostics tools that must be installable from the framework. Be careful. -->
    <permission name="android.permission.DIAGNOSTIC"><group gid="input"/><group gid="diag"/></permission><!-- ================================================================== -->
    <!-- ================================================================== -->
    <!-- ================================================================== -->
    <!-- The following tags are assigning high-level permissions to specific user IDs. These are used to allow specific core system users to perform the given operations with the higher-level framework. For example, we give a wide variety of permissions to the shell user since that is the user the adb shell runs under and developers and others should have a fairly open environment in which to interact with the system. -->
    <!-- Standard permissions granted to the shell. -->
    <assign-permission name="android.permission.WRITE_EXTERNAL_STORAGE" uid="shell"/><assign-permission name="android.permission.SEND_SMS" uid="shell"/><assign-permission name="android.permission.CALL_PHONE" uid="shell"/><assign-permission name="android.permission.READ_CONTACTS" uid="shell"/><assign-permission name="android.permission.WRITE_CONTACTS" uid="shell"/><assign-permission name="android.permission.READ_CALENDAR" uid="shell"/><assign-permission name="android.permission.WRITE_CALENDAR" uid="shell"/><assign-permission name="android.permission.READ_USER_DICTIONARY" uid="shell"/><assign-permission name="android.permission.WRITE_USER_DICTIONARY" uid="shell"/><assign-permission name="android.permission.ACCESS_FINE_LOCATION" uid="shell"/><assign-permission name="android.permission.ACCESS_COARSE_LOCATION" uid="shell"/><assign-permission name="android.permission.ACCESS_LOCATION_EXTRA_COMMANDS" uid="shell"/><assign-permission name="android.permission.ACCESS_NETWORK_STATE" uid="shell"/><assign-permission name="android.permission.ACCESS_WIFI_STATE" uid="shell"/><assign-permission name="android.permission.BLUETOOTH" uid="shell"/><!-- System tool permissions granted to the shell. -->
    <assign-permission name="android.permission.GET_TASKS" uid="shell"/><assign-permission name="android.permission.CHANGE_CONFIGURATION" uid="shell"/><assign-permission name="android.permission.REORDER_TASKS" uid="shell"/><assign-permission name="android.permission.SET_ANIMATION_SCALE" uid="shell"/><assign-permission name="android.permission.SET_PREFERRED_APPLICATIONS" uid="shell"/><assign-permission name="android.permission.WRITE_SETTINGS" uid="shell"/><assign-permission name="android.permission.WRITE_SECURE_SETTINGS" uid="shell"/><assign-permission name="android.permission.BROADCAST_STICKY" uid="shell"/><!-- Development tool permissions granted to the shell. -->
    <assign-permission name="android.permission.SET_DEBUG_APP" uid="shell"/><assign-permission name="android.permission.SET_PROCESS_LIMIT" uid="shell"/><assign-permission name="android.permission.SET_ALWAYS_FINISH" uid="shell"/><assign-permission name="android.permission.DUMP" uid="shell"/><assign-permission name="android.permission.SIGNAL_PERSISTENT_PROCESSES" uid="shell"/><!-- Internal permissions granted to the shell. -->
    <assign-permission name="android.permission.FORCE_BACK" uid="shell"/><assign-permission name="android.permission.BATTERY_STATS" uid="shell"/><assign-permission name="android.permission.INTERNAL_SYSTEM_WINDOW" uid="shell"/><assign-permission name="android.permission.INJECT_EVENTS" uid="shell"/><assign-permission name="android.permission.SET_ACTIVITY_WATCHER" uid="shell"/><assign-permission name="android.permission.READ_INPUT_STATE" uid="shell"/><assign-permission name="android.permission.SET_ORIENTATION" uid="shell"/><assign-permission name="android.permission.INSTALL_PACKAGES" uid="shell"/><assign-permission name="android.permission.CLEAR_APP_USER_DATA" uid="shell"/><assign-permission name="android.permission.DELETE_CACHE_FILES" uid="shell"/><assign-permission name="android.permission.DELETE_PACKAGES" uid="shell"/><assign-permission name="android.permission.ACCESS_SURFACE_FLINGER" uid="shell"/><assign-permission name="android.permission.READ_FRAME_BUFFER" uid="shell"/><assign-permission name="android.permission.DEVICE_POWER" uid="shell"/><assign-permission name="android.permission.INSTALL_LOCATION_PROVIDER" uid="shell"/><assign-permission name="android.permission.BACKUP" uid="shell"/><assign-permission name="android.permission.MODIFY_AUDIO_SETTINGS" uid="media"/><assign-permission name="android.permission.ACCESS_DRM" uid="media"/><assign-permission name="android.permission.ACCESS_SURFACE_FLINGER" uid="media"/><assign-permission name="android.permission.ACCESS_SURFACE_FLINGER" uid="graphics"/><!-- This is a list of all the libraries available for application code to link against. -->
    <library name="android.test.runner" file="/system/framework/android.test.runner.jar"/><library name="javax.obex" file="/system/framework/javax.obex.jar"/></permissions>
  11. toxinburn

    toxinburn Member

    Anyone out there got any ideas? Im willing to let my phone be the guinea pig here, afterall this phone was on sale for 62.00 Where are the linux geniuses when you need em? If you have ideas please submit here and I will try them out and let you know.
  12. keithhicks

    keithhicks New Member

    Looks like were S.O.L.

Share This Page