1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Rooting your event (pc required)


  1. deathneed

    deathneed Well-Known Member

    DISCLAIMER: I have only just rooted my device and have not thoroughly tested it,ROOT AT YOUR OWN RISK!

    THIS TUTORIAL IS FOR THOSE OF YOU WHO COULD NOT GET THE POOT ROOTING APP TO ROOT YOUR DEVICE.

    If you need any assistance with this tutorial please post below and I will get to you as soon as possible. I usually check her once a day or so.
    __________________________
    Items needed:
    Kyocera Event
    USB cable
    Windows PC
    _________________________________________________________________________________
    Downloads needed:
    First: head over to this thread to download "Root_with_Restore_by_Bin4ry_v27"
    link: http://forum.xda-developers.com/showthread.php?t=1886460

    Second: NOTE:Im not 100% sure you need the drive for this to work, however in my case it didnt work until after I installed the driver.
    Head here and download the driver for the Rise c5155, make sure you select the appropriate bit version (32 or 64, if youre not sure go with 32)
    link: Kyocera Wireless Support: Phone Drivers

    [​IMG]
    ___________________________________________________________________________________

    Step 0. Install the driver and unzip the files

    [​IMG] Step 1. After installing the driver and unziping the zip file plug your phone in

    Step 1.5 Enable Usb debugging in the development settings, if your device prompts you to select a usb connection type select "mass storage"
    Step 2. Give windows a minute to recognize the device
    Step 3. Run the "runme.bat" file
    step 4. Press 1 then hit enter
    [​IMG]
    Step 5. After the script has completed running a new screen should appear on your device, press "Restore my data"

    [​IMG]
    Step 6. After this is complete your device will reboot

    ___________________________________________________________________________________
    Congratulation if you followed this corretly, your device is now rooted!

    Proof:
    [​IMG]

    If you have any question please feel free to post them below

    Advertisement
    :
    miguelco01 likes this.
  2. dogboy322

    dogboy322 Member

    Have you had any issues since rooting? I'm interested in giving it a try, first timer here.
  3. dogboy322

    dogboy322 Member

    Ran steps exactly as they appear here. My pc is win7 64 bit, so installed 64 bit driver. Rebooted. Enabled USB debug on phone (kyo event), connected usb, mass storage, ran bat file, entered 1, dialog said successful, auto rebooted phone, came up w different wallpaper, and new "superuser" app in the drawer. But I got the root checker app and it says root access not configured properly. Did steps again from the top. Same result. Have superuser app, but apparently don't have root access. Do I need a device encryption password to make it work? I see "desktop backup password" in dev options... do I need to set that up? I run the bat file and it says "successful." But root checker says NO.

    Do I need to get my apps off, do factory reset, before it will work?
  4. dogboy322

    dogboy322 Member

    Do I need a device encryption password to make it work? I see "desktop backup password" in dev options... do I need to set that up? I run the bat file and it says "successful." But root checker says NO.
  5. dogboy322

    dogboy322 Member

    It's cool. I pooted it and I'm in... now what? I got some "root uninstall" tools and they have superuser level, but they don't seem to delete any more than the "unrooted" apps I have. What about custom rom's?... you've probably tried some already. Anything out there that will work on this phone, and make it run faster, smaller footprint, leave more HD space, etc?
  6. SonOfAnarchy

    SonOfAnarchy Member

    OK so I used this method, I ran the file and it told me it was a success. But root checker tells me no root?
  7. deathneed

    deathneed Well-Known Member

    there isnt a whole ton you can do with root since there arnt any custom roms made for this phone yet, however you can get tethering apps,change your boot animation, download any app (market enabler), undelete files you might have deleted and possibly fast reboot(havnt tested it on this phone, use at your own risk) just to name a few. Just go in the app store and search rooted if your interested in other apps that use root.
  8. deathneed

    deathneed Well-Known Member

    Im honestly not sure. Im not an android expert. If neither of those guides worked for you, I dont know what you can do. You could try searching around for another method of root, but be careful,not all rooting methods are compatible.
  9. SonOfAnarchy

    SonOfAnarchy Member

    Well this sucks :(
  10. SonOfAnarchy

    SonOfAnarchy Member

    Ok so I cleared cache or data (one of the 2) under manage apps and now I have root. I open Titanium Backup and superuser pops up asking for permission like it should. Only problem is that everytime I click 'grant' even with the 'remember this setting' box clicked, it just repeatedly pops back up instantly. No matter how many times I click it.

    EDIT: And yup, root checker says I have root access. Asked me to grant root permissions at only made me do it once. Titanium Backup repeatedly asks me though and it never lets me get to the app bc it just keeps asking for permission.
  11. dogboy322

    dogboy322 Member

    I tried CWM and Rom Manager last night and they said "non compatible device." But one sort of cool thing I figured out is that with mini tool partition mgr, I was able to partition my sd card (in my pc), main partition with all my pics, vids, etc, in fat32, and second partition in "ext2" format, which allows me to take advantage of "link2sd," a root app that allows you to "link" unmovable apps to the sd card, freeing up hd space. My free space went from 680 to 745 after linking.
    First, make backup of your sd card on the pc, then put micro/ adapter in sd slot. Make main partition first, fat 32, set as a "primary" partition. Run task. Then with remaining space, create another "primary" partition, ext2 format. Make sure you select "primary" from the dropdown when creating. Apply task. Both partitions should be the same color on the chart when done. Then put it back in the phone... (under the freakin battery)... boot up and open Link2SD. Hit settings button on phone, go to "settings" and "more" in app. Create mount scripts, create link, select checkboxes, then go to app list, select "internal" (not "system") and you can link all these apps. When linked, it will show "all app files successfully linked and MOVED to sd." Do this for all the internal apps, then look at your Android app settings at the used and free space.
    Another cool root app I found is "kernel tuner." Pretty easy presets in here (some options require a dual core phone, but some are useful on this one). You can set CPU, set RAM usage, make it run fast, or underclock ("conservative" and "powersave" presets make it run kind of laggy, but conserves battery life).
  12. dogboy322

    dogboy322 Member

    Been doing some reading on boot animations, even downloaded some zips. But one thing scares me from actually doing it. Several articles I've read say that ONLY custom ROMs support changing boot animation, basically that if you try to change boot anim on a stock ROM, you can brick it.
  13. dogboy322

    dogboy322 Member

    Ok, never mind that. I have a folder with about ten boot animation zips now, I'm just popping them in at will. Set res to 320 480, reset zipfile, copy, paste into root dir/data/local. Cool little trick!
  14. legendarylink

    legendarylink New Member

    Fun fact this phone does not like the newest su binary stick with 3.0.3 from poot only way you will get su to ask permissions su binary 3.1.1(17) does not work for this phone atleast from what i have seen
  15. dogboy322

    dogboy322 Member

    I got root access on May 8th. Haven't attempted to install any roms I'm not sure of. Just the animation changes, some root apps like link2sd, root app delete, titanium backup, but only in the last two days, my wifi has stopped working. Power bar wifi indicator, even my juice defender wifi indicator, says ON, but no icon at the top of the screen, and no connection... just keeps connecting, authenticating, getting ip address, repeat, ad infinitum. 3g still works. Tried wifi with the connections optimizer on and off... PRL update... made no difference, wifi won't connect.
  16. aryeh95

    aryeh95 New Member

    I did everything as described (drivers, backup, restore and a bunch of reboots) but when it said it was done and successful superuser wouldn't update the binary or popup when i tried using a root app... and the only thing that i can recall that might have been an error is it said could not find remote location 'system/bin/ric' ... i also tried with poot and it says invalid xt..... any advice?
  17. aryeh95

    aryeh95 New Member

    Someone please help ive rooted probably at least 30 android devices and this the 1st one im having so much trouble with...
Loading...

Share This Page