S Beam / NFC Not working S4Support


Last Updated:

  1. setser

    setser Member

    Hello,

    My S Beam and NFC are not working at all. Id tap the back of the phone with my girlfriends and nothing would happen. Both switches are turned on on hers and mine. I have no clue whats wrong. Shes running an S3 and I have an S4 but I think its my phone thats the problem. I just got it about a week ago from a guy i found on CL. It was originally an AT&T but he supposedly unlocked it and im now using it for Metro PCS. I have the SGH - 1337 model. Its unrooted.

    Any one know the answer??? :confused:

    Advertisement
  2. lotus49

    lotus49 Well-Known Member

    When I first started playing with NFC I seem to remember that the built-in apps didn't work. That may well have been my fault but I quickly gave up and started using the excellent NFC Task Launcher and Tasker with the Locale NFC plug-in. The latter is not for the faint of heart so I'd recommend starting with NFC Task Launcher. It's also free.

    If NFC Task Launcher doesn't work, I'd wonder about the battery. The antenna is built into the battery. I bought two spare batteries for my S4 and despite otherwise looking and behaving exactly like the original battery, they appear not to have NFC antennae in them.
  3. setser

    setser Member

    How would I know if the battery has an NFC tag in it? I see that it says Near Field Communications but I just want to make sure that its not just faked.
  4. lotus49

    lotus49 Well-Known Member

    Find an NFC tag (I bought some but you could use something else like a NFC enabled building pass or credit card for testing), install NFC Task Launcher and then hold the phone over the tag. It seems to have a very short range so I find that I have to hold the phone so that the middle is over the tag. If the tag is recognised, there will be a notification sound and a message.
  5. setser

    setser Member

    Is there any way to find out without scanning it. Because when I scanned it against my girlfriends phone it did not register at all.
  6. itsallgood

    itsallgood Well-Known Member

    Has NFC ever worked on your S4? I have found that when I send pictures using NFC, I have to use the stock gallery app and not a 3rd party one. (Which doesn't work.) Also, make sure you have both NFC and S-Beam turned on.)
  7. setser

    setser Member

    I've never been able to try it. I was first testing it with her phone to see if it would work and it didnt. I made sure the switches for NFC and S beam were all on the first time. So what I would do is go the picture and display it then tap the phones and nothing would happen.
  8. Crashumbc

    Crashumbc Well-Known Member

    have you tried other things? like a contact? a webpage?
  9. setser

    setser Member

    I've tried neither. A contact I will try soon. But what do you mean by a webapge?
  10. BigRedGonzo

    BigRedGonzo Well-Known Member

    My wife has a Note 2 and I have an S4. I have gotten the NFC to work several times trying to send pictures. I have even sent an entire album over the service. One issue that I see whenever I want to use it is that the phones have to be in exactly the right position in relation to each other to establish the connection. It is very difficult to get the two phones to talk, but they will if I am persistent. It certainly doesn't connect like the commercial would indicate. I have to take both phones and hold them back to back and slowly move them around until they connect. I have a Ballistic Maxx case on my phone and the wife has a generic aftermarket case. I believe the cases cause a bit of the problem, but haven't bothered to test that concept yet. Try placing the phones back to back and slowly moving one of them around until you get a beep. The best I can tell, the hotspot on the back of both phones is only about the size of a pencil eraser. Now that I have done it a few times, I can get them to connect pretty quickly.

    FWIW,
  11. setser

    setser Member

    So I tried making contact on a contactless pad at McDonalds... yes Mcdonalds... and it didnt register. I tried doing it three times in different positions and switching s beam on and off.

Share This Page