S2-i777 bricked or not. Please helpSupport


Last Updated: 2013-01-21 08:00:40
  1. Vayu12

    Vayu12 New Member

    Hi I'm from India. I got a s2 i777 as a gift. It was with my cousin n i think it had an ics shotock rom on it. but the problem was upon startup it displayed gti9100. the phone worked fine untill one day it stopped charging. i tried and tried but the battery died n now when i connect a wall charger or usb it displays a battery blinking icon for every 2-3 secs but doesnt charge. it won't turn on either. i showed it to the samsung guys here n they say they cant help me. now my phone is completely dead i read about the download mode to install firmware via odin but the download mode says low battery can't download. is there anything i can do to help myself.

    Advertisement
  2. BestInGalaxy

    BestInGalaxy Well-Known Member

    Are you using the OEM battery and not any aftermarket ones? I heard some devices are picky. Try plugging in your phone to your computer WITHOUT the battery. If that doesn't work, maybe your phones USB port is going bad.
  3. Vayu12

    Vayu12 New Member

    yes i am using the oem one. i read somewhere in the xda forum about the picky battery issue. n i have sent my phone to the samsung guys here, also asked to check with the battery. I guess its not hardbricked as while charging the screen shows a battery icon although phone never charges. I guess might have to use external charger or some other battery to get it started if the samsung guys fail. i tried doing the usb connection without battery but didnt work. I hope the samsung guys do something or else might have to do something myself. I am not able to understand how to use the download mode and odin. I am downloading the stock ics 4.0.4 for sgh-i777 from sammobile.com. if the mobile turns on i am going to try the download mode and odin myself to get it to stock ics for i777. but need help a detailed process might help.
  4. BestInGalaxy

    BestInGalaxy Well-Known Member

    Do you have access to another OEM battery? Maybe yours might be going bad. A USB jig could be a big help to you since it automatically puts you into download mode. If you want further help from more people,
    try posting this in the XDA forums under the Galaxy S II i777 section. You'll get more help there, I think this board is dead.
  5. tlopez1973

    tlopez1973 Well-Known Member

    I just fixed my phone because the same thing was happening the USB charger port started going and kept me a battery loop state.the good thing is that the USB flex port is a few dollars on eBay and every easy to exchange also here's a pic and just search for video on utube

    Attached Files:

Share This Page