S2 keeps rebootingSupport


Last Updated: 2013-03-07 07:58:50
  1. aggeyee

    aggeyee New Member

    How is the KE7 working for you? I live in Sweden and need it for the same reason and I really hope it will solve the rebooting problem. But as you understand the upgrade is not yet released here. Anyone heard when it will be available for everyone?:)
  2. Lol mahmood

    Lol mahmood Well-Known Member

    Had it on KE7 for several days now and only one random reboot, and that was when I was absolutely caning the processor, doing about 5 things at once (including downloading, online, moving a large file in My Files, etc.). Don't think battery life is any better, though.
  3. Lol mahmood

    Lol mahmood Well-Known Member

    Oh yeah, calendar has stopped working! All my appointments are still there online, and on my Galaxy Tab calendar, but the SGS2 calendar (for the same gmail account) is now empty!
  4. garment69

    garment69 Well-Known Member

    I have had the GS2 for about a week. I have not made it through a day without having to pull the battery becuase it froze. Today, I had my first random reboot.

    so torn, becuase I swear, this is the greatest phone I have ever used.
  5. stokesd3

    stokesd3 Member

    Would suggest a factory reset for this and check the firmware via Kies. I personally have the odd problem but it ain't that bad. Can you narrow it down to any particular app you may be running?
  6. stokesd3

    stokesd3 Member

    Have you tried clearing the calendar cache and then resyncing? Fixed previous issues I was having.
  7. ShreddedDiesel

    ShreddedDiesel New Member

  8. elektrobix

    elektrobix Well-Known Member

    I've also started having this problem. The phone was fine for the first two weeks and then out of nowhere it started restarting. I've made no changes to the phone for over a week, installed no new apps, it's running the latest firmware. No idea what is is?
  9. loony

    loony Well-Known Member

    according to the XDA forums, an SD card can sometimes be the issue, but otherwise it seems to be a ram issue i think. but dont take this as the answer.
  10. stokesd3

    stokesd3 Member

    Posted the issue here Issue 17365 - android - OS rebooting on Android 2.3.3 - Android - An Open Handset Alliance Project - Google Project Hosting and submitted my log file from the time. Response was

    too many local references in the USB native code:

    06-03 09:56:41.654 D/Usbhost (2692)usb_host_run :: new device /dev/bus/usb/001/001
    06-03 09:56:41.654 D/UsbServiceJNI(2692)usb_device_added ::
    06-03 09:56:41.654 D/Usbhost (2692)usb_device_open :: /dev/bus/usb/001/001
    06-03 09:56:41.654 D/Usbhost (2692)usb_device_new :: /dev/bus/usb/001/001 fd: 182
    06-03 09:56:41.654 D/Usbhost (2692)usb_device_new :: read returned 43 errno 4
    06-03 09:56:41.660 W/dalvikvm(2692)ReferenceTable overflow (max=1024)
    06-03 09:56:41.660 W/dalvikvm(2692)Last 10 entries in JNI local reference table:
    06-03 09:56:41.660 W/dalvikvm(2692)1014: 0x40a2d5c0 cls=Ljava/lang/String; (28 bytes)
    06-03 09:56:41.660 W/dalvikvm(2692)1015: 0x4097a170 cls=Ljava/lang/String; (36 bytes)
    06-03 09:56:41.660 W/dalvikvm(2692)1016: 0x408cf358 cls=[I (36 bytes)
    06-03 09:56:41.660 W/dalvikvm(2692)1017: 0x408cf380 cls=[I (36 bytes)
    06-03 09:56:41.660 W/dalvikvm(2692)1018: 0x408de270 cls=Ljava/lang/String; (28 bytes)
    06-03 09:56:41.660 W/dalvikvm(2692)1019: 0x409700f8 cls=[I (180 bytes)
    06-03 09:56:41.660 W/dalvikvm(2692)1020: 0x40bcad40 cls=[I (212 bytes)
    06-03 09:56:41.660 W/dalvikvm(2692)1021: 0x405a9388 cls=Ljava/lang/String; (36 bytes)
    06-03 09:56:41.660 W/dalvikvm(2692)1022: 0x40b4ff98 cls=Ljava/lang/String; (28 bytes)
    06-03 09:56:41.660 W/dalvikvm(2692)1023: 0x4099d2d0 cls=Ljava/lang/String; (36 bytes)
    06-03 09:56:41.670 W/dalvikvm(2692)JNI local reference table summary (1024 entries):
    06-03 09:56:41.670 W/dalvikvm(2692)461 of Ljava/lang/String; 28B (461 unique)
    06-03 09:56:41.670 W/dalvikvm(2692)51 of Ljava/lang/String; 36B (51 unique)
    06-03 09:56:41.670 W/dalvikvm(2692)248 of [I 36B (248 unique)
    06-03 09:56:41.670 W/dalvikvm(2692)8 of [I 44B (8 unique)
    06-03 09:56:41.670 W/dalvikvm(2692)61 of [I 60B (61 unique)
    06-03 09:56:41.670 W/dalvikvm(2692)57 of [I 68B (57 unique)
    06-03 09:56:41.670 W/dalvikvm(2692)10 of [I 76B (10 unique)
    06-03 09:56:41.670 W/dalvikvm(2692)63 of [I 180B (63 unique)
    06-03 09:56:41.670 W/dalvikvm(2692)1 of [I 188B
    06-03 09:56:41.670 W/dalvikvm(2692)64 of [I 212B (64 unique)
    06-03 09:56:41.670 W/dalvikvm(2692)Memory held directly by tracked refs is 57416 bytes
    06-03 09:56:41.670 E/dalvikvm(2692)Failed adding to JNI local ref table (has 1024 entries)
    06-03 09:56:41.670 I/dalvikvm(2692)"UsbService host thread" prio=5 tid=46 RUNNABLE
    06-03 09:56:41.670 I/dalvikvm(2692)| group="main" sCount=0 dsCount=0 obj=0x408e7ed0 self=0x212d10
    06-03 09:56:41.670 I/dalvikvm(2692)| sysTid=2813 nice=0 sched=0/0 cgrp=default handle=1917160
    06-03 09:56:41.670 I/dalvikvm(2692)| schedstat=( 865486887 29969830513 4579 )
    06-03 09:56:41.680 I/dalvikvm(2692)at com.android.server.UsbService.monitorUsbHostBus(Native Method)
    06-03 09:56:41.680 I/dalvikvm(2692)at com.android.server.UsbService.access$700(UsbService.java:63)
    06-03 09:56:41.680 I/dalvikvm(2692)at com.android.server.UsbService$2.run(UsbService.java:600)
    06-03 09:56:41.680 I/dalvikvm(2692)at java.lang.Thread.run(Thread.java:1019)
    06-03 09:56:41.680 I/dalvikvm(2692)
    06-03 09:56:41.680 E/dalvikvm(2692)VM aborting

    I have no idea what this means though! Note I have had the issue with and without the SD card inserted and my USB port was not being used at the time.
  11. loony

    loony Well-Known Member

    at com.android.server.UsbService.access$700

    wtf does that mean!! lol
  12. 0ryn

    0ryn New Member

    Hi people,
    I'm fairly sure I've figured this out and come up with an easy fix :)
    First the cause:
    Poor fitting battery, made worse by a badly designed micro-SD slot position.
    When you have an SD-card fitted this can push the battery away from its contacts. I found my battery had about 0.5 mm of movement up and down. Every time my phone reset it was when it was in my pocket and subject to movement.
    Riding my bike to or from work.

    The fix:
    Lovely and simple just place a bit of paper placed under the bottom of the battery to push it up towards the battery contacts.
    I used a UK lotto ticket (loosing one) it was just the right thickness to stop the movement. (Tesco till receipts work just as well.) Tear your lotto ticket in half then half again, wrap your quarter ticket over the bottom edge of the battery, push the battery into the phone and check for movement. You may have to double up, I found just one layer was enough to stop the vertical movement.
    fit the cover and turn on your phone.

    Enjoy.
  13. brad1601

    brad1601 Member

    How long has it been now since your last 'random reset' after using your method?

    I was thinking this was a software fault with android 2.3.3 because I know on my desire after flashing to 2.3.3 oxygen rom everyone was having random reset issues until someone fixed googles code up in the rom and now everything is fine.
  14. stokesd3

    stokesd3 Member

  15. 0ryn

    0ryn New Member

    I think you could be right, or it could be a proper hardware fault, my phone locked up again today despite my paper battery fix. A phone that runs cold for hours shouldn't suddenly lock up and get hot, mine gets hot in the top left corner. I wonder if its due to the camera firmware I flashed. No matter its getting sent back on Monday for a replacement. the online store have actually arranged for a courier to collect it :) at no charge to me.
  16. stokesd3

    stokesd3 Member

    Tried to get Samsung to look into this but they just kept coming back with the generic 'take back to the shop to have it reflashed'.

    This ain't gonna help since I had the issue with the original firmware and also the latest. The operator was also adamant that the reflash would fix the bug. Couldn't convince her of the difference between corrupt software and buggy software oh dear :rolleyes:

    Will just have to hope a future update sorts this I guess.
  17. stokesd3

    stokesd3 Member

    Have reflashed from xwke2 to xwke7 so hoping this makes a difference.

    One thing I have noticed is the speed increase on the phone now. Noticed it in particular when opening Copilot :D
  18. Ballverine

    Ballverine New Member

    I'm having the same problem. It turns itself off at least twice a day while in my pocket. If i shake it or tap it it doesn't turn off, the battery is very well fitted and secure.
    Does anyone have an answer for this I would really like to avoid taking back for repairs if possible
  19. jimmysgs2

    jimmysgs2 Member

    Hey folks, my S2 has done this as well. It seems to do it when i tap an app and it doesnt matter which one i dont think. Last time was when i went to open Twitter and the screen went black and i got the samsung start up screen followed by the 02 welcome message.

    I have tried taking battery out and putting back in to ensure its in firm, ive rebooted it myself every night in case its the RAM getting too clogged even though i clear the RAM regularly.

    I have an appointment with 02 tomorrow to get this sorted so will report back when i know whats what. Although them replacing it would be good, it would also mean i have to pay another
  20. nikko86

    nikko86 Member

    im having the same problem. i bought my fone last aug 1st and after 1 week it keeps on shutting down it doesn't restart though. what do you think is the problem?
  21. jimmysgs2

    jimmysgs2 Member

    I have been to 02 this morning who advised that it could be the following things or combination there of:

    • An app or two that conflict
    • An issue with the software
    • A problem with the RAM
    • Another hardware issue

    Up until today I have seen it suddenly reboot itself after tapping an app 4 times with a gap between each even varying from a couple of days to a week. But today I have 3 incidents. The first was 5 minutes before my appointment. The second was on the way home and the final one was a few hours later. I have now booked myself in for another appointment. Does anyone think if i request a replacement it will happen or will they force the issue to be looked at by sending it away?
  22. Ballverine

    Ballverine New Member

    I tried jamming a thin bit of underr the end of the battery as someone suggested, it has worked 100%!
    I did it about 3 weeks ago and it hasn't happened once since.
    No doubt there is multiple issues here, but that was definitely the solution for me, I would recommend trying it.
    jimmysgs2 likes this.
  23. loony

    loony Well-Known Member

    its great that fix works, but if mine was doing that, i'd be taking it back and demanding another one.
  24. dogsoldier

    dogsoldier New Member

    I've got the same problem. Usually happens when I have the phone in my pocket, and I suspect it has something to do with the battery connection
    ranadera likes this.
  25. LindaDe

    LindaDe New Member

    I came here because I have a very similar issue. Spontaneous reboots that happens when I listen to music. Although I usually do this while doing housework or walking or something so it's possible it's the battery shifting slightly but I figured it was something with the music and/or music player. Just using the standard Android music player.

    Will try the paper solution to see if it fixes it and will report back.

Share This Page