S2 wifi hotspotting


  1. Paximus

    Paximus Member

    Hi all, just got my S2 a week ago, rooted it, verified I have root access with root checker.. now, the only thing left that I want to be able to do is use my phone as a hotspot, but apparently the S2 doesnt support ad hoc mode. Anyone have any suggestions for what I can try? I dont want to have to go back to my LG marquee just because i cant hotspot this.

    thanks in advance,
    Pax

    Advertisement
    :
  2. SelfElevated2

    SelfElevated2 Well-Known Member

    You can hotspot... download the free app WiFi tether on the market... And.you'll have to uncheck something in settings for it to work... let me go check
    ZaynabCrouse likes this.
  3. Codegerm

    Codegerm Well-Known Member

    Can you not do it in infrastructure mode (like you do with most wireless routers)?
  4. SelfElevated2

    SelfElevated2 Well-Known Member

    Just download that app. I use it all the time. So I guarantee it works
  5. greg schmeg

    greg schmeg Guest

    WiFi tether worked perfectly for me, perfectly. I didn't have to uncheck anything.
  6. FLAWLESSVW

    FLAWLESSVW Well-Known Member

    It didn't work out of the box for me. I got an error in the log that it couldn't start ad-hoc mode.

    Settings>Change Device Profile>Samsung Epic Touch 4G (was set to "Auto")

    Works perfectly now :)
    ZaynabCrouse likes this.
  7. Shaun72

    Shaun72 Well-Known Member

    Will this work for my boost mobile s2?
  8. jacobbrandon19

    jacobbrandon19 Well-Known Member

    Yes. I just set mine up the other day and can verify that "wifi tether" works on a rooted s2 if you set it for the epic 4g touch.
  9. ZaynabCrouse

    ZaynabCrouse Member

    This is just amazing I tried and couldn't figure it out so I came here and seen to put my settings to Samsung Epic 4g (By the way what is the difference is the Galaxy s2 actually the Epic 4g or are they different?)

    back to the topic at hand, This is amazing because with my stock wifi tether (that I won't have to pay 10 dollars a month for) I could only use the internet on one device at a time, but with this I can use it on my phone and laptop simultaneously :)
  10. Codegerm

    Codegerm Well-Known Member

    the Epic 4g Touch is the same exact phone as our SGS2. Sprint/Samsung renamed it to the Galaxy S2
  11. Gadgeteering

    Gadgeteering New Member


    Thank you, I had the same problem and about to blow a gasket, then did what you said and presto. knock on wood this will be the long term fix. appreciate it.
    Doc likes this.
  12. NosTraDomus

    NosTraDomus Well-Known Member

    from stock rooted, i could NEVER get hotspot working...NEVER, tried every rooted app, the modded versions as well..nothing would work. either it would say and not do it or show it connect and no internet...

    i just gave up on the stock and used the TBS4 rom

    http://androidforums.com/galaxy-s2-...ched-s4-v2-1-updated-7-7-13-team-acheron.html

    easy install, great ui and features...oh and wifi, simple ONE click/slide of the sprint Hotspot app., which im using RIGHT now.
    Kasey Clark and Doc like this.
  13. VikingoV

    VikingoV Member

    By any chance where you running stock I'm rooted running stock I tried everything but no luck can u help (noobe)
  14. VikingoV

    VikingoV Member

    Need help with tethering running stock I'm rooted Samsung galaxy s2 4.1.2 (i would greatly appreciate some help (noobe)
  15. Codegerm

    Codegerm Well-Known Member

    If you are paying for tethering, just use the boost hotspot.

    Look in settings/security/device administrators and see if you have something like "Sprint phone info". If you do then get Titanium Backup (available on the play store) and remove that app. It is a restrictive control app and is not needed. It allows restrictions on function use to be enforced.
  16. systemofadown

    systemofadown Well-Known Member

    Code, I never could find the boost hotspot in Ti backup - could you point me to it (it seems hidden) Thanks :D
  17. Codegerm

    Codegerm Well-Known Member

    I don't believe it is an app itself as much as a setting for your WiFi. I never used Boost Hotspot. I do have the wireless tether app TrevE mod.
    systemofadown likes this.
  18. oamilcar

    oamilcar Well-Known Member Contributor

    Wifi hotspot is tied up to secsettings.apk, if a can remember right my last secsettings.apk decompile.
    systemofadown likes this.
  19. systemofadown

    systemofadown Well-Known Member

    Thanks guy's :D yeah I just want to clear it out or freeze it if possible.. I'm going to try the app from xda
  20. bilgerryan

    bilgerryan Well-Known Member

    Doc and Codegerm like this.
Loading...

Share This Page