S2E with Link2SD make new apps don't work until reboot


Last Updated:

  1. moustafaatchy

    moustafaatchy Well-Known Member

    I have Wildfire S rooted with CM7, and I installed S2E to move dalvik cache to sd-ext, then I installed Link2SD to have more control on which apps to be moved.
    After installing Link2SD s2e doesn't have control on any thing but dalvik cache (I think because Link2SD took control over the ext partition)
    Any way, now when I install a new app , it doesn't open (gives force close message) untilled I reboot my device.
    So is there a way to fix this problem ?
    Thanks.

    Advertisement
  2. wyelkins

    wyelkins Well-Known Member

    Others will have other opinions, but I would either:

    Use S2E by itself
    Use A2SD by itself
    moustafaatchy likes this.
  3. moustafaatchy

    moustafaatchy Well-Known Member

    I want to use Link2Sd to choose which apps to be moved, s2e moves all apps
    don't know about A2Sd, does it move dalvik cache and let me choose apps?
  4. moustafaatchy

    moustafaatchy Well-Known Member

    It's solved now
    I followed this guide, but skipped unwanted steps
    14. From root explorer:
    a) Navigate to /sdcard/cm7-a2ext/link2sd-config-scripts/ use multi-select on 11link2sd and 99complete then select Copy.
    [​IMG] Navigate to /etc/init.d/ and select mount r/w from the upper right corner of the screen.
    c) Paste the copied files.
    15. Long press 11link2sd and select Permissions. Ensure that the permissions are set to rwxr-x---. Repeat this step for 99complete.
    16. Reboot phone.
    17. From the market install Link2sd and S2E.
    18. [Optional] Open S2E and enable the dalvik cache and download cache options. Moving applications are not necessary. (you must enable 'Mount as ext4' before reboot)
    19. Open Link2sd (if you are prompted to select a partition type, see the link2sd note below. otherwise you should have working a2ext).
    20. Reboot to complete the S2E changes.
    21. Congratulations! You should now have a2ext with cm7 [​IMG]

    [MOD][HOW TO] apps2ext for cm7 [updated 03/31/2011] - CyanogenMod Forum
  5. moustafaatchy

    moustafaatchy Well-Known Member

    The problem is still there
    After installing a few apps and restoring apps with Titanium Backup it's there again.
  6. moustafaatchy

    moustafaatchy Well-Known Member

    I knew where the problem was and solved it.
    I used Link2SD with linking dalvik cache files which were moved by S2E
    So I edited Link2SD options not to link dalvik cache
    But S2E stops working after installing Link2SD
    So I moved the dalvik cache using this guide, then installed Link2SD which worked fine
    A2SD Darktremor for CM7 on Samsung GT-S5570 - Cool Android Gadget

Share This Page