S3 - not turning on etc.Support


  1. jonny

    jonny Member

    Hi there,

    Woke up this morning and noticed apps kept crashing oddly so I thought I'd restart the phone.... it just gets stuck and goes round and round on the 'Samsung Galaxy SIII GT-19300' and Orange splash screens... doing nothing. I tried to do a hard reset but that doesn't even get to that screen as that also keeps going round.

    Help would be appreciated. I'm not on Jelly Bean yet as I've still not had the notification to update. So I think I'm on 4.0.4? I'm on EE (Orange).

    Thanks.

    Advertisement
    :
  2. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Hmmm, that is odd! Have you tried pulling the battery out for a minute or so, then reinsert battery and turn it on?
  3. jonny

    jonny Member

    Yeah tried that, I even swapped it with my spare battery. Took out the SD card, I finally got to the hard reset menu... I chose the top option 'reboot system now'. The blue thing is just going round and round and not doing much... been doing it for about 10mins now :/
  4. sleeco

    sleeco Well-Known Member

    Hi, try a reset by pressing power button for 20/25 seconds
    Mikestony likes this.
  5. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    The last thing to try that I know of, and I am not sure about this as I am rooted, is to go into recovery to do a reset.
    Hold down the home button and the volume up button. While holding those down, push and hold the power button until a screen comes on, then let go.
    That should be your stock recovery screen. There may be an option to reset, or clear data, or something like that there.

    Before you do that, I would need confirmation from others that this will help as I am not 100% sure o.k.? But its worth a shot before taking it back to the shop. :)
  6. jonny

    jonny Member

    Tried holding for 20sec, nothing.

    I tried going in to that menu, i've chose the 'reboot system now' option and nothing.....
    I really don't want to wipe data/factory rest. How about wiping the cache patition?
  7. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Worth a try, sure...wont hurt anything:)
  8. jonny

    jonny Member

    Darn it, same. I'm just gonna have to wipe it. Have most thing's backed up except for apps which can be downloaded again.

    Fingers crossed this will work :)
  9. jonny

    jonny Member

    Yeah had to format the phone... which sucked. Random.

    Also, anyone know why I haven't got the Jelly Bean update yet? on EE (orange).

    Thanks.
  10. CrimsonPride

    CrimsonPride Well-Known Member

    your motherboard may have died, although i thought it wouldnt even make it to the recovery screen.
Loading...
Similar Threads
  1. mted558
    Replies:
    1
    Views:
    3,886

Share This Page