S3 Stuck on 4.0.4General


Last Updated:

  1. aknight123456

    aknight123456 New Member This Topic's Starter

    Joined:
    Dec 28, 2012
    Messages:
    3
    Likes Received:
    0
    Hi,

    I've had an S3 on T-Mobile for a couple of months now. It has never given me the option to update and I don't have the 'Software Update' or 'Developer ?Settings?' buttons which I have read is down to T-Mobile being a brilliant carrier and removing it. I have read that if you update via Kies it should allow you to update as soon as Samsung release an update. I installed Kies and connected my S3 and it said there was an update available (brilliant!) but all it ended up doing was updating the kernal. I am still stuck on 4.0.4 and Kies says I am up to date. Apart from rooting the phone is there anything I can do to actually get the current android version? I have tried searching the forums but I can't seem to find a conclusive answer, sorry if I have missed something.

    Cheers
     

    Advertisement
  2. GTWalling

    GTWalling Well-Known Member

    Joined:
    Sep 9, 2012
    Messages:
    1,277
    Likes Received:
    411
    That is not true. I have a T-Mobile S3 and have Software Update and Developer options. You may need to do a Factory Reset to get things right so you can get the update.
     
  3. aknight123456

    aknight123456 New Member This Topic's Starter

    Joined:
    Dec 28, 2012
    Messages:
    3
    Likes Received:
    0
    It is true. It does not affect all T-Mobile S3's but it is something which T-Mobile/Orange/EE have added to some handsets for unknown reasons. I highly doubt a factory reset will cure this issue as this is how it came from the factory. It is part of the bloatware which for some reason was added to some handsets but not all.

    Has anyone else got this problem and is anyone aware of a solution?

    Cheers
     
  4. funkylogik

    funkylogik share the love peeps ;) VIP Member

    Joined:
    Sep 15, 2011
    Messages:
    21,470
    Likes Received:
    7,242
    Mate find the correct rom for your carrier on sammobile, download it and flash it with odin if u know how.
     
  5. aknight123456

    aknight123456 New Member This Topic's Starter

    Joined:
    Dec 28, 2012
    Messages:
    3
    Likes Received:
    0
    OK thanks for the website but no I don't know how to do it. To flash a different version of android does your device have to be rooted? Could you link me to an instruction page for this?

    Thanks
     
  6. amado3

    amado3 Member

    Joined:
    Aug 14, 2012
    Messages:
    19
    Likes Received:
    2
    Also on T-mobile here and never got a notification to update from 4.0.4, but ICS has worked fine for me so I've left well enough alone.
     

Share This Page

Loading...