S4 not chargingSupport


  1. TheRichMan

    TheRichMan New Member

    My phone ran out of battery today and when i plugged it in, the phone is just not charging. Its not buzzing, it buzzed once the first time i plugged it in, and now after 4 hours its done absolutely nothing except sit there plugged in. There is just no juice getting to the battery it seems. I tried my parents chargers and they wouldn't work either. Should I try to get my battery replaced or does anyone else have a suggestion? Thanks for the help!

    Advertisement
    :
  2. GuitarG20

    GuitarG20 Clueless Senior Member Contributor

    Welcome to the forums!

    Sounds like you might have had a defective battery. Usually, if leaving it plugged in for a few hours doesn't jump start it, it's time to look at getting a new battery :( Sorry!
  3. jamjr74

    jamjr74 Well-Known Member

    Have u tried a different charger?
  4. TheRichMan

    TheRichMan New Member

    Thanks for the reply! I just tried it again and its working! Im not sure what that episode was about but it was just simply not charging and now it randomly is. I still might get a new battery as that was very annoying but it could also be the charging port I guess.
  5. GuitarG20

    GuitarG20 Clueless Senior Member Contributor

    Sometimes it's simply a function of leaving the phone plugged in long enough. Something weird happens with batteries when they almost fully discharge (I'm no electrical engineer so I don't know how it works) but more often then not leaving them plugged in for a long time will make them start to work again.
Loading...

Share This Page