S4 Phone Dialer broken/malfunctioningSupport


Last Updated: 2014-04-09 01:06:22
  1. Trillva

    Trillva New Member

    First off, hoping this is the right place to post this;
    More importantly, my phone is a Canadian GS4 Bell SGH-i337M.

    Just one or two days ago (before I flashed the 4.4 KitKat Beanstalk rom) my phone worked fine. Receive a call, make a call, no problems or hangtime.
    That was on CyanogenMod, and every rom before it. Now, I get a call and it pops up with the options to decline, decline with a message or answer. Neither of the buttons trigger anything, solely responding with animation. I try to call someone and as soon as I press the call button, the screen goes black for about 10 seconds. When the phone dialog finally pops up, the call works but nobody can hear me and I hear nothing either. None of the options, such as mute, hold, etc work except the End Call button.

    So, I realize my phone stopped working from the transfer Beanstalk (which might I add is flawless besides this issue).
    I went back to my restore of Cyanogen after using the Factory Reset on TWRP, still the phone has the exact same problems.

    So now I'm lost and my next idea is to keep switching roms, though I would really love to stick with Beanstalk 4.4.
    Can anyone suggest anything to me?

    UPDATE: Just tried making an outgoing call again, crashed my phone to boot screen, or it restarted or something.
    Any answers are welcome because I need to solve this ASAP, currently looking for a job and my phone needs to be able to answer incoming calls.

    Advertisement
  2. OnRunning

    OnRunning Member

    I had a similar issue when I updated to 4.3. But I didn't have ROMs. This is how I fixed it (no joke!)

    System settings > date and time > Then change the Date Format (i.e. Mm/dd/yyyy to dd/mm/yyyy). Exit out, then change it back to your desired format.

    It's the craziest thing. I don't know how it worked for me. Hope this helps!
  3. Trillva

    Trillva New Member

    Seriously? Well if that works, I overreacted:

    I simply went online, grabbed my i337M stock firmware, 4.4 KitKat, backed up my Beanstalk rom again, wiped, flashed the stock rom and boom.
    Phone works. Wi-Fi wouldn't turn on (I've had the problem before) but luckily after rooting it, the problem was fixed in the restart.
    After that all I did was restore my Beanstalk rom.

    Thanks anyway.
  4. OnRunning

    OnRunning Member

    Glad you got that fixed.

    Yeah, I had a third party dialer for months until I googled it, and found that fix. I thought it was a joke. But it worked.

    Probably different problems, same symptom.

    Cheers!

Share This Page