Samsung Admire (MetroPCS) charging problemsGeneral

Last Updated:

  1. samsungadmire3

    samsungadmire3 New Member

    Lately, I have been having charging problems with my Samsung Admire SCH-R720. When I plug it in, it makes the noise that indicates it's charging and when I charge my phone on vibrate, it vibrates to indicate it has begun charging. Now-a-day's, when my phone is charging it will all of a sudden stop charging YET the phone will still show that it is charging but the battery is actually dying. This is very inconvenient especially because I charge my phone at night so when I wake up, I could have a battery that's 100% charged and ready for the day.

    -This problem has been occurring since the beginning of February 2013.
    -Like every other person with a phone, I've dropped mine a couple of times, if that may be the cause of my problems.
    -Last month, my phone dropped into my sink with the water running. I quickly dried out the charging port and was having a couple of problems with the charging, but it went away and my phone charged normally until this month.
    -If the charger is touched (at the charging port at the bottom of the phone), it will stop charging. It seems even if it isn't touched, it will stop charging.
    -I've had my phone for about 5 months, purchased on Saturday, September 29th, 2012.
    -The charge is able to wiggle if you touch it, which is when it stops charging. Even when it doesn't wiggle it stops charging then i'll have to wiggle it to charge again.
    -If I take my charger out, it will say that the phone is charging, so I'll have to plug it back in then unplug for it to show that it is not charging.

    All answers are accepted. Thank you!

  2. KageBeast

    KageBeast Well-Known Member

    Well it's either a problem with your charging port or the charger itself. I know with my old admire it got to the point where I had to lift up the the part that went into the port and hold it like that just to get it to charge. I would suggest try changing chargers and see what happens. If it still happens than it's your port. If you know it isn't dirty or anything then there's not much you can do unless you replace the motherboard or the port itself. I saw some fixes people had after searching for a while but none worked for me so I don't know.
  3. enorrick

    enorrick Member

    I had the same problem and I took the battery out and used a toothpick to lift the little. Center piece and haven't had a problem since.
  4. iVsU

    iVsU Member

    I also have been experiencing this problem, when i got to look into it i knew it wasn't my battery nor my charging plus, i knew it had to be the port took an air compressor blew all the dust out it seemed to work but now it's back an i have to make sure the cord is pulling a bit on it so it works.. blah Good Luck

Share This Page