Samsung Admire won't show up when connected via USB cableSupport


  1. pengu1

    pengu1 New Member

    Can not connect pc to Samsung admire via USB. I have tried several cables, and when I try to connect to Removable disk :D, it tells me to insert disc.

    I have tried it with USB de-bugging turned on and off and nothing happens. I have searched the forums and have not found anything related to my phone. I have tried going to the SD card and going to the folder I want to browse and THEN connected to the compute, and again, Insert disc into drive :D.

    Any help would be appreciated.

    Advertisement
    :
  2. gbiggie

    gbiggie La patience et le pardon Guide

    Try installing the drivers for the phone:https://www.box.com/shared/03bbc43c9ec48c42320a
    And try it again..let me know:thumbup:
  3. JimOrozco

    JimOrozco New Member

    Hey Gbiggie!
    I've been having the same issue and tried your link but no change. Funny because it was working before and now its not. But I also see there is an actual admire update (not just drivers) and I'm afraid to do that until I get this taken care of.
    In your link, there are many folders (as I've seen from the download on Samsung as well) none of which are labelled Admire, each with a 'Setup" in them and not sure if I'm supposed to initiate those/one of those files to get the process started. When I try to manually update the drivers it asks me which folder to pull from and wont accept the main driver folder. Help please? If you're still around. Thanks
  4. gbiggie

    gbiggie La patience et le pardon Guide

    Welcome to AF Jim!
    This link from above when extracted/unzipped contains one folder to setup the drivers for the Admire-https://www.box.com/shared/03bbc43c9ec48c42320a
    The update that you are referring to would be diretly from Samsung and can be found through this link-Support - More Cell Phone Providers SCH-R720 | Samsung Cell Phones
    MH58 likes this.
  5. Dragonlady

    Dragonlady Well-Known Member

    gbiggie.....I am having the same problem. I downloaded and installed the drivers from your link and tried three different cords and I still get the "insert disc" message. Is there anything else I can try?
  6. qandres12

    qandres12 Well-Known Member

    try these, i got them from the rooting thread for the Admire, ive always used them and they have never given me any issues. you could also try to unistall and then resintall the drivers again and its best to use the cable that came with the phone when or a OEM cable bought specifically for the phone

    EDIT: sorry they didnt show up for some reason: http://k0nane.info/rom/indulge-drivers.exe
  7. Dragonlady

    Dragonlady Well-Known Member

    You said "try these". I don't see where/what "these" are. I am going to try uninstalling and reinstalling the drivers.
  8. First off if you are not using a samsung cord IT WILL NOT CONNECT!!!
    A samsung cord can be identified by the fact that it is very thin on the end and the wire feel very light.
    you will notice on the bottom of the cord that there may be a plus and minus sign on it...thats a good cord!!!

    when you connect it to the computer open up your device manager and check to see if there are any ( ! ) if so then uninstall those drivers and reboot your computer..and then reinstall any drivers or just wait for your auto detect to find it and install the drivers auto magically.

    let me know if this helps anyone!! :)
Loading...

Share This Page