Support Samsung Epic 4G problems

Discussion in 'Android Devices' started by tjy, Nov 16, 2010.

  1. tjy

    tjy New Member
    5

    Nov 16, 2010
    2
    0
    5
    Hey guys I am new to the forum and do not know where to post this question.

    I have had the Samsung Epic 4G a Galaxy S for a few months but I cannot get my PC to recognize it when I plug in the USB cable. i went onto the Sprint site for help but did not get much help at all.

    I would appreciate any sort of help thanks.

    TJY
     

    Advertisement
  2. Matty Mo

    Matty Mo Well-Known Member
    53

    Oct 16, 2010
    319
    37
    53
    State Slave
    Folsom
    When you hook up your phone through the usb cord wait a minute for it to load then pull down the notification bar were all the toggles are(wifi,4g,gps etc) there should be a usb notification tap it, then click connect then your comp should read it....
     
    tjy likes this.
  3. tjy

    tjy New Member
    5

    Nov 16, 2010
    2
    0
    5
    The phone recognizes that it is plugged in as a USB device I can select Mass Storage but PC just says that USB Device not recognized or has Malfunctioned.
     
  4. *king*

    *king* Active Member
    16

    Jul 16, 2010
    37
    2
    16
    DADE county
    Try and go to the device manager, locate the bad driver in the universal serial bus controller section, and uninstall/delete the bad driver(will have a explanation mark next to it) Then right click usb and scan for new hardware, and Windows should locate the approiate driver. If that doesn't work I think there are drivers on the Samsung site.
     
  5. Frisco

    Frisco =Luceat Lux Vestra=
    VIP Member
    1,323

    Moved to the Support area of Epic 4G for you, tjy.
     
  6. crashrat

    crashrat Active Member
    15

    Nov 8, 2010
    26
    0
    15
    I had to download the USB driver for the Epic so my PC would recognize it. Go to Samsung page and get the driver for USB.
     
  7. jmichaelsk

    jmichaelsk Active Member
    16

    Nov 16, 2010
    26
    3
    16
    Make sure it is plugged into a usb on the back of the computer. Mine did the same thing on all front usb ports on two computers as well as hubs. I plugged it into a back usb port and works perfectly.
     
  8. faith1310

    faith1310 Member
    15

    Nov 17, 2010
    17
    0
    15
    Waco , Texas
    Where do i go to the samsung page for the usb driver download?
     
  9. akmadxi

    akmadxi New Member
    5

    Sep 21, 2010
    1
    0
    5
    Phoenix, AZ
    I had the same problem, found this thread. Someone said try a different usb port. I have a new ThinkPad with one port on one side and three on the other. I just moved from the one side to the other and it worked.
     

Share This Page

Loading...