Samsung galaxy 5(i5503) major worries :(Support


  1. Yneth

    Yneth Member

    Hi guys,

    I bought a samsung galaxy 5 android phone about a month ago and i started facing this problem almost immediately after purchase, very often and randomly when i lock my phone, or put it to sleep, it doesn't wake up, meaning when i lock and try to unlock, the phone's display is not on or its just blank with the back light on, i know my phone is running cuz it receives calls but doesn't alert me, all this while I thought i had defective model and due to which i demanded a replacement of the phone and the replacement arrived yesterday, it was fine, but today after i connected to my computer to transfer some files and later when i unplugged it, it started behaving the same way. i mean the screen doesn't display anything when i try to unlock, i cant even switch off! the only option is to remove the battery and put it back in. This is kinda frustrating for me, any help is appreciated guys, thanks a lot and i apologize for the long post.

    P.s I also had a feeling it might be some bug/malware transfered from my computer and i ran a scan using antivirus by AVG, but didnt help :(

    Advertisement
    :
  2. cristi

    cristi Member

    i think it's a firmwire problem and it should be fixed with the update comming in december but you are the only one i've read about with this problem
  3. loop4444

    loop4444 Active Member

    +1
  4. Yneth

    Yneth Member

  5. abhishek355

    abhishek355 New Member

    Hey Guys...

    I face the same problem and the phone just sleeps off without responding to any button... Only way to bring it up is to disconnect the battery and then re-connect it... I am not sure if the phone is on or off in that duration.

    Also, I experienced the battery going down very rapidly and I found my phone switched off due to low battery - a thing which never happened ever with my earlier phones... are their any possible issues with the battery ?

    Though while the phone is awake.. I am reasonably happy with it.

    Abhishek...
  6. shirako617

    shirako617 New Member

    Hi all,

    I bought a new galaxy 5 phone before 15 days and recently i started facing the same problem as above... If i lock my mobile and try to unlock it will be dark screen and won't respond to any keys..finally i have to remove a battery and start again.. and i hardly have 5-6 apps installed..
    Now i'm worried did i make wrong choice ?
    or shall i try replacing my handset ? as i hardly used it, and i have 1 yr warranty as well..
  7. bagus

    bagus New Member

    I got the same problem, I'm using battery indicator to monitor the battery.
    My phone will hang once when the battery is between 80-90%, and the battery will drop to around 60%.

    Still waiting the fix in froyo.
  8. varun.k

    varun.k Active Member

    Not sure if it can be upgraded to froyo. Seen some reviews and they say its down side it cant be upgraded to froyo again i am not sure.
  9. aniket_1988

    aniket_1988 New Member

    Hi loop4444
    as ur User ID suggest r u using Loop / BPL connection on Samsumg Galaxy 5..
    Coz m using the same & m unable to connect the internet.
    I've asked for the settings thousand times..
    hvnt received even 1s..
    even tried manualy from Website..it dint worked either...
    Can you please suggest anything..??:(
  10. hirentrivedi

    hirentrivedi New Member

    I brought Samsung galaxy i5503 4 Days back and facing same kind problem but i have some more problems like it heating anonymously in standby mode it also show me simply refreshing popup and restart i have some prob with memory card too so i update to foryo but problems remain same does. Update to foryo affect my warranty?
  11. sai.suri1983

    sai.suri1983 New Member

    My problem is quite different to the above. I bought a samsung gt i5503 3days ago. Till yesterday my wall charger worked perfect. Today morning when i connected the wall charger my mobile was switched of with a warning " Android S.....! ( I can't even see the warning) and the battery icon gone red before it was switched off. I tried a few times but the problem is same. Then connected the USB data cable and it worked fine. But i have done a search in google and found a tip in a forum link. That is to switch of the mobile and remove the battery for few seconds and replace the battery. That's worked fine for once only. The second time the phone switched off again. Then i repeated previous step "removed and replaced the battery" and it worked again for once only. Now I have a doubt on the charger that from the first day some times it took too long to charge and some times while charging the battery level gone down quickly when i received a call. Suggest me if any other tips can help me..! or should i replace the charger.
  12. La Tour d'Arge

    La Tour d'Arge New Member

    I've got the same problem. I downloaded some stupid screen unlock app and now when I unlock the phone it just goes to a blank screen. The home button and settings menu no longer works however I can still make calls. Any advice?
  13. La Tour d'Arge

    La Tour d'Arge New Member

    I ended up doing a factory reset and all is fixed now, for the mean time. This is the reset code by the way: *#*#7780#*#*
    Just type it into the keypad and you will be prompted there after.
  14. spinorkit

    spinorkit New Member

    What size is your SD card?
    My Galaxy i5503 phone freezes several times a day if I use an SD card other than the 2GB one that came with it. I have tried 2 other cards, a Kingston 8GB and a Dick Smith 4GB. With both of these cards the phone seems to be working fine then fails to wake up after being locked and has to be reset, several times a day.
    It has never frozen with the original card, and has never crashed while I was using it. It simply fails to wake up after being left idle.
  15. sai.suri1983

    sai.suri1983 New Member

    I'm using the same sd card 2gb which came with the phone. But I have not tried to factory reset.
  16. spencers

    spencers New Member

    how do i disable the enable always on mobile option in mobile network ......it is not lettin me to disable .....thanks in advance
  17. sai.suri1983

    sai.suri1983 New Member

    Then do one thing spencers. Un-check the Enable always on mobile option. It will take few seconds. If it stuck in lite gray shade, then switch off the mobile and switch on. I have the problem some time while enabling the option.
  18. bhagyesh

    bhagyesh New Member

    Hi guys,

    I wanna check my balance after every call which is possible if i enable call duration . But i tried searching in my phone.

    Moreover i am not able to chk my bal using *123# which is for airtel. It show ussd code running and den MMI complete.

    Pls help me out asap:mad:
  19. grove407

    grove407 New Member

    U guys keeps talking about updates.... I am having the exact same problem as most of u (locking afone to later find out that its not responding) But wen i connected my fone to 'kies' it said that 'this version of device cannot be updated' :/..... on the dicksmith website it says that the update for this problem came out in jan 2011..... exactly how do i get this update???????
  20. europadroid

    europadroid Well-Known Member

    You need to make sure that you have the latest version of the Kies software, which is v2.xxxx . Using the original version I was not offered an updated, as soon as I updated to Kies v2, the update came through. However, from reading other posts in this forum whether this happens is inconsistent
  21. grove407

    grove407 New Member

    huh, but when i connect to kies it says that this version of device cannot be updated even though i hav the latest version of kies
  22. grove407

    grove407 New Member

    But does upgrading to 2.2 fix the original problem?
  23. d.t.android

    d.t.android Member

    grove407,

    yes it does, i have it, its a bug in 2.1 (eclair) i updated in like 5 minutes and then everything was fine.

    d.t.android

    (edit)

    Kies is made by chinese and the update software is bugged on everything so, you have to flash it on otherwise you would have to pay to get it ota'd (over the air) on your phone.
  24. d.t.android

    d.t.android Member

    if everything else doesn't work, use "factory Reset"

    1. turn your phone off
    2. hold vol up, center key, and power on.
    3. "factory reset" pops up, then your done!
    4. turn phone back on.
    (only works with phones that look like this)
    [​IMG]
Loading...

Share This Page