Samsung Galaxy 5 update firmware problems.Support


  1. iBobbeh

    iBobbeh New Member

    When updating my firmware to Froyo via Kies, everything works via the Kies end but my phon stays on the "Downloading" flash screen with the little android digger icon. I've tried it around five times now, and I think the maximum I've left it must have been around 6 hours, and no updates have been successful.

    When I turn it back onto keys it says firmware update unsuccessful/emergency recovery. I've not met anybody who have had these problems, my dad and my sister both have Galaxy S phones and theirs updated in the matter of minutes.

    Cheers for any help in advance.

    Advertisement
  2. iBobbeh

    iBobbeh New Member

    Oh, just realised the update isn't for Froyo at all, but the update is from O2 to fix the repeat text message problem (where it constantly sends you the same text from the same person over and over again). However, it doesn't really fix the problem as it's not successfully updating. Help?
  3. DusanT

    DusanT New Member

    And after trying 100 times on 6 different computers finaly made it... installed android 2.2 froyo through kies.. don't know what did it this time... all I did is unplugged usb cable right after it finished downloading firmware and then immediately plugged it back in and it upgraded... stupid KIES..
    GabyBR and philippa65 like this.
  4. lalamms

    lalamms Member

    does your galaxy 5 support multitouch after upgrading to froyo?
  5. Twisted-

    Twisted- Member

    Considering the hardware doesn't support multitouch, no Android update is ever going to add multitouch to the Galaxy i5500.
  6. Ernie_C

    Ernie_C Member

    Perhaps not everyone knows the hardware limitations of the device:)
  7. lalamms

    lalamms Member

    so samsung i5500 will never have multitouch?? ouh
  8. Ernie_C

    Ernie_C Member

    Correct. It's a hardware function.
  9. Twisted-

    Twisted- Member

    It's both actually. But 2.1 was already perfectly capable of multitouch with the right hardware.
  10. mikenzkr

    mikenzkr New Member

    Haha was having the same issues you had. My Galaxy 5 was just hanging on the download screen for ever. Stumbled on this post, pulled the battery out, reinserted, tried again, same thing. Then I tried what you did - unplugged my phone after the firmware download finished, replugged, and what do you know... updates in a matter of minutes... dunno what it is that makes it work but yeah, I'm not complaining ahaha my thanks sincerely for the post :D I guess I would have gone through several computers and several hundred attempts too if you hadn't put this up XP Stupid Kies hehe
    GabyBR and philippa65 like this.
  11. Darth_Krakatoa

    Darth_Krakatoa New Member

    Kies, does says to 'restart' the phone by removing and replacing the USB cable. Just wait for the que, AND READ WHAT IT SAYS ON THE SCREEN! :D.
  12. philippa65

    philippa65 New Member

    My thanks to DusanT and the confirmation from mikenzkr, you have saved me hours if not days wasted trying to get my europa firmware updated!!! I had already struggled for half a day trying several times with the yellow digger man just hanging around on my phone!!!!!
    Unplugging and plugging in the cable work just how you said.

    Now Darth_Krakatoa I can assure you THERE IS NO CUE FOR YOU TO UNPLUG THE CABLE AFTER DOWNLOAD!!!!!.... As I read your post before attempting the above suggestion I was looking for the cue that you mentioned..... IT'S NOT THERE.... there is one AFTER the UPDATE is COMPLETED.......but nothing between the download and the update and it only works if you disconnect between the download and the up date.
    Now I suggest you should not be so quick to treat others like idiots to try to make yourself feel superior!!! If it was not for those you accused of not READING WHAT IT SAID ON THE SCREEN :eek: I would not have the update and therefore got rid of those annoying repeating messages. So once again thanks DusanT and mikenzkr.:D

    PS I normally do not write in forums but Darth_Krakatoa's patronising statement encouraged me, so I suppose without him (or her) you would not know of my gratitude....of some use then ehh!
  13. marooo

    marooo New Member

    i got a galaxy 5 (gt-i5503) i'm tring to update it via samsung kies each time it tells me your device can't be updated any 1 got any help?????
  14. GalaxyEuropa

    GalaxyEuropa Well-Known Member

    i have never updated through kies sounds like you would have been better off flashing a new rom using odin? Galaxy 5 will never support multi-touch :(
  15. mary-barbara

    mary-barbara New Member

    I just did a firmware update on my i5500 via Kies - but I had to go back to my Windows XP machine to do it. The advice I was given by the authorised service centre was that Kies does not yet run correctly on W7 64 bit and my experience confirms that. Once I was on XP I had no problems - with the firmware upgrade, anyway!
  16. GabyBR

    GabyBR New Member

    Hi!


    I just came here to thank you for sharing your accomplishments. I was having trouble while upgrading firmware of my Galaxy 5 by Kies and did that:

    It worked perfectlly fine and now I have back my phone with all functions! After being through several minutes with yellow robot on screen and Kies frozen in 94%, I found this topic and try that. At first try it worked!

    Stupid Kies!!!

    Thanks DusanT , mikenzkr and philippa65 ! :D
  17. rhegie06

    rhegie06 New Member

    I am using GT-I5503 also . My problem is , when I installed the kies , it started to upgrade my firmware w/c was 2.1 . When my phone reboots , it does'nt open , it keeps restarting . Can somebody help me with this ? Thanks in advance
  18. rhegie06

    rhegie06 New Member

    I am using GT-I5503 also . My problem is , when I installed the kies , it started to upgrade my firmware w/c was 2.1 . When my phone reboots , it does'nt open , it keeps restarting . Can somebody help me with this ? Thanks a lot .

Share This Page