Samsung galaxy ace , can't download apps on my sd-card.Support


  1. EllenMalm1998

    EllenMalm1998 New Member

    Hi, I have a big problem with my mobile samsung galaxy ace :(. For about a week ago, I would download some new games that had come to Android market. When I downloaded it came up that I could not install it on either USB memory or SD card. What is strange is that I have over 6 GB left on my sd card so it should be no problem, but it does not work. I can not update my apps either.
    Please help me, I can't stand this any longer.
    Has anyone had this problem or know how to solve it?
    Thank you!:)

    Advertisement
    :
  2. Marcha

    Marcha Well-Known Member

    Hi,
    Some apps can't be downloaded to sd-card with stock rom on the phone. Sometimes you can find that info in the app-description in the market. Since the internal memory of the Galaxy Ace is small, there may be a problem there. Have you checked that out?
    EllenMalm1998 likes this.
  3. EllenMalm1998

    EllenMalm1998 New Member

    Yeah , I've checked that out. But the problem is that I've had many more apps then I have right now on my mobile. I took them away because I thaught they took the whole space on my mobile. So it's really strange... :confused:
  4. gandaran

    gandaran Active Member

    if your internal memory is full it wont let you install or update any apps
    do some data cleaning on the less important internal memory apps till you have about 150 MB of installed apps with the rest of 30 MB free space you should have no problem installing apps that go to SD card.
  5. xataka

    xataka New Member

    I had the same problem, the i rooted my galaxy ace and installed BlackMart, it is the only app that allows me to move apps from phone to SD card. I tried xxx2SD apps but they didn't work. :mad:
  6. Jimbobuk10

    Jimbobuk10 New Member

    I have had exactly the same problem with my Galaxy Ace and have been searching the internet for answers. I had loads more apps installed before and began to uninstalled ones I didn't use to free up internal memory. I then tried a factory reset and this didn't seem to help and free up memory. Now....when I re-install some of the apps I had before memory fills up after about 2 or 3 apps. If anyone can give me any pointers I would be very grateful. I don't really want to start rooting my phone
  7. ayush29k

    ayush29k Well-Known Member

    If you are facing the installation failure when downloading/updating from market, the reason can be that your card has been corrupted. It usually happens when you eject the card without unmounting it from the software(mobile or pc).

    To confirm this, try manually installing an app and tell me if installation is successful or not.
  8. jdgreat4

    jdgreat4 Well-Known Member

    Could you please post some screenshots of exactly what happens when you try to download the app. If u get an error like this app can't be downloaded as you dont have enough memory, i would advise you to first move your apps to the sd card using move 2 sd enabler(which requires root) and have at least more than 20mb of internal memory and then try to download apps and make sure to move all you downloaded apps 2 sd, so you have lots of internal memory.


    Press thanks if I helped you!
  9. jemajem

    jemajem New Member

    Hi all, I have only had my samsung galaxy ace 3 days and have been trying to get a few games and apps and also to switch some music from my lappy to my phone and I keep getting this too :( Error message when trying to download is.........Couldn't install on USB storage or SD card. Error message when trying to play music is.........Open file. No applications can perform this action.
    Pleeeease help, I'm new to this android stuff, lol :))
  10. Michael7313

    Michael7313 New Member

    Hi, I have similar problem. Since 3 days I can not download all apps. Sometimes smaller ones I can download, even I have completely cleaned up and cleared the memory (90BM internal and 1.1GB in SD) I receive errorr "Download not possible, to less memory. Clear elements (65286)". :confused:
    It would be very appreciate if I could get a hint what to do?
    Michael
  11. lemie

    lemie New Member

    i have the same problem. my SD card seems to be properly working and still have an internal memory for about 50MB and .96gb of SD memory available. how come it doesn't allow any new application installation nor application updates. is the a set up problem or it is my memory card
  12. rajrahul95

    rajrahul95 New Member

    Is there any option, so by default the apps will get installed in SD card??
  13. chrcol

    chrcol Well-Known Member

    yes sort of.

    first of all you guys need a proper apps2sd app the type that makes a symlink to the sdcard from /data/apps and dalvik-cache.

    I havent the time to find a guid eright now but in short you would need to be prepared to probably.

    root the phone
    install CWM
    repartition your sdcard so it has a sd-ext partition (this means wiping the data on it). most least intrusive way is backup sdcard to pc whilst still in CWM, repartition, copy data back to sdcard whilst still in CWM so when you boot phone again everything still works.
    install cf-root or a rom that supports ext partitions, cf-root is least intrusive way as its only a kernel and all data is kept.
    then install dt-apps2sd which will move all non system apps to the sd-ext partition on sdcard, its much better than the normal moving to sd methods, it even works for widget apps etc.
    optionally dt-apps2sd can also move the dalvik cache which if you do move then most internal space will be free.

    Now here is the glitch, when using something like dt-apps2sd then apps have to be stored to internal memory to be on sd-ext as the phone thinks sd-ext is internal memory. Gingerbread will by default install apps to external memory when they mark it as supported. So those apps will go on the sdcard fat partition instead of sd-ext, to get on sd-ext have to mvoe them ot internal memory. Roms like CM can be set to by default install to internal memory solving the problem.

    I attached a screenshot of my phone utilising sd-ext and at the moment it doesnt have that many apps installed but you can see hardly anything on data compared to sd-ext.

    Attached Files:

  14. adonider

    adonider New Member

    hey . i had exactly the same problem with my samsung galaxy ace s5830 . i couldn't install apps . I tried to change sd card with an old one i had from my old phone . I did that and afterwards the problem was gone ... So i recomend that u should try and change ur sd card .
    HOPE it works with u too
    (it was my brother's idea)
    please let me know .
  15. ayush29k

    ayush29k Well-Known Member

    I had the same problem and i figured out a solution, the problem is that the sd card has gotten corrupted. You must have umnounted the card at some time without clicking the unmount button in the phone.

    There is a very simple solution for this, access the sd card through the usb storage mode, now in the card there is a folder named .android_secure, it holds all you sa card apps data, and this is the file that is corrupted.
    You need to delete this folder, it'll solve your installation error problem, but you will have to reinstall all the sd card apps.
    Schuur likes this.
  16. cl2448

    cl2448 New Member

    Is it save?
    It doesn't "destroy" something to delete the folder?
  17. Hurghada

    Hurghada New Member

    Hi there, I had the same problemof not been able to download apps. The way I got round it was to unmount the sd card in settings then download app mount caed and then move app to sd card.

    Bit of a process but worked for me :)
  18. ayush29k

    ayush29k Well-Known Member

    Its one way to by-pass the situation, but what will you do when you run out of space on the internal memory, the only way is to clean up the sd card as i have said above.

    Its quite safe, the only thing you will loose are the applications installed on the phone, so i'd recommend you back them up before deleting the .android_secure folder.
    Use appmonster or any app to backup the applications.
  19. Schuur

    Schuur New Member

    That's it! That solved the problem. After uninstalling Google play updates, hard reset, disk checks on the SD card I still could not install any apps on my SD card. After I removed the .android_secure directory it is working fine again. Thanks again for this solution ahush29k!
  20. rahmannsw

    rahmannsw New Member

    same problem for me also.did u solve tat problem?thn plzz help meeee
  21. aditii

    aditii New Member

    same prob..help
  22. Dappledroid

    Dappledroid New Member

    I have the same problem - tried deleting the android secure folder but it doesn't work. Would buying a new sd card be likely to cure the problem? I think all this is a cunning ploy by Samsung to force you to upgrade to a phone with a lot more internal memory. I was getting on so happily with my Ace until now, the first smartphone I've ever owned......... ah well, I live in hope of finding an answer! I don't know what rooting is - what is it and how is it done?
  23. Chairadinda

    Chairadinda New Member

    I tried to delete that folder, but it failed. How to delete it?? please help me :(
  24. Jeffers

    Jeffers Active Member

Loading...

Share This Page