Samsung Galaxy Ace GT-S5830 Tethering issues


Last Updated: 2012-10-01 12:08:47
  1. walesrob

    walesrob New Member

    Hi all,

    Trying to tether this phone to a W7 laptop (in fact I tried 3 different W7 laptops & an XP machine just to make sure).

    Network is 3 UK

    Laptop sees the phone's AP.

    The phone can browse the internet by itself quite happily with 3 mobile network but wont allow internet to pass through for tethering. USB tethering does not work either.

    The Samsung KIES (sp?) software downloaded and installed, and quite happily syncs phone with laptop, but as far as I can see this software wont allow internet pass through?

    AP in settings is ticked and to enable troubleshooting, I've left the security to OPEN, but this is pointless as the laptop can happily see the Samsung.

    The phone is running Android 2.2.1, with a baseband ID of S5830NEKA3 and version of Froyo XWKAB (is this version of Android actually allowing wireless/wired tethering?)

    3 have been useless, passing me on to tech support, then laptop support, then phone support. They even suggested contacting Samsung UK! Every 3 support staff I talked to didn't have a clue, and I'm getting pretty fed up with the whole thing.

    I used to own a HTC Desire S and had zero problems tethering that to laptops, but this Samsung seems to be misbehaving in some way.

    Any suggestions on how to fix this, I would be grateful!

    Advertisement
  2. chanchan05

    chanchan05 The Doctor Guide

    Menu>Settings>Wireless and network>USB Settings>Set to Mass Storage. Phone can't tether using Kies or MTP mode connection.
    walesrob likes this.
  3. walesrob

    walesrob New Member

    Thank you for the reply. There is no option for Mass Storage under USB Settings in the Wireless and Networks on this GT-S5830. I can drill down to storage options in another part of the menu, but there is no option for mass storage.
  4. chanchan05

    chanchan05 The Doctor Guide

    Wait, what kind of Ace is that? Ace 2? Ace Plus? Anyway, does hotspot tethering work?
    I also forgot, check with your network if they allow tethering.some networks disable the function and only activates it with a premium.
  5. I was having HTC wildfire with 2.2.1 FROYO and USB tethering easily works with all the devices I have tried.
    Since chanchan is saying that network may be the culprit, you have option to check it out by making your phone a WiFi Hotspot (there is an app for that in your android OS). If your system does not connect with WiFi hotspot then definitely your network would have blocked you from sharing your mobile data.
  6. walesrob

    walesrob New Member

    Thank you guys for the replies.

    The laptop sees the phone as a WiFi hotspot (in this case the default SSID of ANDROID AP), but in the network and sharing centre, it shows a network but with no internet access, very much like if your home wireless router loses internet, it will still show a wireless network, but no routing to the internet (hope that makes sense!)

    The phone model is the Samsing Galaxy Ace.

    The client assures me she has a calling plan where she pays a premium for tethering.

    To be honest, I'm suspecting 3 are useless, as so far they've failed time after time to find a resolution - the client called 3 today and was told it might be a firewall issue, so they are just fobbing her off with excuse after excuse.

    I think I'll push the client to go for an early upgrade, she's only 1 month away from the min. term contract finishing. If anything, its time to get shirty with 3 network to get this resolved.

Share This Page