Support Samsung Galaxy Ace Pc connectivity


  1. TrisTan5267

    TrisTan5267 Well-Known Member

    Guys, can you help me with this? Please! I haven't plugged my phone on my pc yet. How and what to do.

    1. plug Galaxy Ace to pc using usb chord.

    2. now what?

    3. will it prompt which to use? as mass storage or use kies?

    4. or will it automatically run kies and look for its drivers then have the interface of kies?

    5. did you turned on the usb debugging thingy? don't know what it is.

    Advertisement
  2. Arol

    Arol New Member

    Hello,
    The way you're asking, I guess you don't intend to develop applications for your device or try to go under the surface of the Android OS, so you don't need the USB debugging.

    If you just want to exchange data between your PC and your phone, it depends on what OS you are using on the PC.
    - If you are using Linux, the chances are high that you don't need additional drivers.
    - If you're using Windows, than you will probably need additional drivers. When you install the Samsung Kies tool, then you get the drivers installed. If you don't like to install Kies, than you can also find the drivers only somewhere on the Samsung support pages.

    When prepared such way, than you can connect your phone and PC with the USB cable.
    On your phone you will see a screen, if USB debugging is activated, where you should uncheck the USB debugging.
    Next you get to a screen (with the green android character) where you are asked if you want to give the attached PC access to your phone's SD card. Here you should click on the white text box on the bottom, as it is also explained on the same screen.
    On the next screen the android character is now yellow.
    The PC now should show the external storage, as it would also show an USB memory stick.

    You can copy data either with help of Kies or as you would exchange data with an USB memory stick.

    Before unconnecting PC and phone physically you have to unconnect them on the software level. Therefore you first choose to unmount the device in the OS of your PC. Windows would call it something like 'remove safely'.
    Then you also have tell your phone, that you are done by clicking on the white disconnect box on the yellow character screen.
    You will get back on the green character screen and you can either disconnect the cable, or connect again to your PC if you forget to copy some files.
    (If you just want to charge your phone with help of a PC, e.g. at the office or a friend's home, then you don't have to give access to your SD card, since you may want to keep your SD card content private. In that case you also have to make sure, that USB debugging is deactivated on your phone, otherwise your phone is even more exposed.

    As far as I remember, the connecting procedure is also described quite good in the manual, that can be downloaded from the Samsung's web site. At least if you follow the proposed way by using Kies.

    ... as always -> Read the manual first! <-
    robinjnv likes this.
  3. hche

    hche New Member

    Hello,
    Can anyone help me with this issue? I recently bought an Ace and downloaded the PC Studio and tried to connect the phone to the PC, but got a message something like "can't connect an unregistered mobile". I don't know what is the problem.:confused:

    Regards,
    HCHE
  4. sumeetbais

    sumeetbais Active Member

  5. Lee1115

    Lee1115 New Member

    hi, can i know how to detect my phone to pc using USB cable?? i had plugged in the cable, but my pc seems did not appear anything while my phone is charging...so may i know what can i do to it?? :)
  6. hey everything will be fine just donwload new drivers. I had they same problem. New drivers solved the problem. Go to kies and install drivers again.:)
  7. shreyasvb

    shreyasvb Member

    When u connect it to PC,go to settings n disable USB debugging n then u can use phone in mass storage mode
    oldmantime likes this.
  8. dilipraj

    dilipraj Member

    i cant able to download any apps through pc can any one tell why
  9. Gohar

    Gohar New Member

    i have a question. I'm using Windows and I installed sumsung kies, but when I get to a screen where I am asked if I want to give the attached PC access to your phone's SD card, I click on the white text box,it shows that he needs some time, but the android character becomws yellow for a 0.5 seconds and I don't now why.. can you help me?
  10. Ipshita

    Ipshita New Member

    Hi,

    I am facing difficulty in connecting my phone with pc.
    As u hv mentioned in ur post, that once connected with USB cable, "On your phone you will see a screen, if USB debugging is activated, where you should uncheck the USB debugging.
    Next you get to a screen (with the green android character) where you are asked if you want to give the attached PC access to your phone's SD card. Here you should click on the white text box on the bottom, as it is also explained on the same screen.
    On the next screen the android character is now yellow."


    But i did not see any such option. Even after manually going to the Application Settings and unchecking "USB debugging" option, it didn't serve the purpose.

    PLEASE HELP ME OUT!!!!!

    Kindly let me know the default settings required before plugging in USB.
  11. Tinterweb Site

    Tinterweb Site New Member

    Hey all..

    I had the same issue big time, Galaxy Ace S5830 would not connect at all to my pc at all.. untill..

    I USED A NOKIA USB!!! OMG.. Trust me it works.. connected into Kies no worries and device (phone) was recognised, the USB Cable supplied with the Galaxy Ace S5830 did not work but an old Nokia USB cable sorted it. WHOOP WHOOP !

    Enjoy and hope this helps :)

    http://www.tinterwebsitedesign.com
  12. Tinterweb Site

    Tinterweb Site New Member

    Hey all..

    I had the same issue big time, Galaxy ace S5830 would not connect at all to my pc at all.. untill..

    I USED A NOKIA USB!!! OMG.. Trust me it works.. connected into Kies no worries, the USB Cable supplied with Galaxy Ace S530 did not work but an old nokia USB cable sorted it. (as long as the phone sockets match - dont force it!!) WHOOP WHOOP !

    Enjoy and hope this helps :)

    www.tinterwebsitedesign.com
  13. sjunell

    sjunell New Member

    I plugged my phone in to my computer using the USB cable and my computer found and installed the drivers all on its own. After that nothing happened. My phone was just charging off of my computer. I couldn't find anywhere on my computer that my phone was plugged in. Any suggestions?
  14. vordigan

    vordigan New Member

    Had this problem in my Ace, I went to the Device Manager and just scanned for Hardware Changes and it detected my Ace again.
  15. Gothic

    Gothic New Member

    I've been trying to get my phne set up so i can put music from my pc to my phone but its not showing up.... i've searched for device managers but could you tell me where it is pleas e??
  16. WelshGasman

    WelshGasman New Member

    I've had the same problem for days now, and have been searching all over for a remedy. It did occur once when I first got the phone, but then I did not know the phone, so did not know where the settings were.

    Anyway the phone would not connect Kies or no Kies, USB driver or no driver. I got a neighbour to check with his cable, still no luck. My cable with his phone fine, so it is the phone.

    Looked at resetting phone. Eventually took the battery out for about 2mins, put it back in, connected via USB, turned off debugging and then got USB connected message. Then you can use the notifications dropdown to connect.

    It still will not connect with Kies (that is one of the most bloated/slow pieces of software I have come across for a long while), but with the Samsung USB drivers at least I have it as a drive.

    THis is on XP SP3. Next to try is win 7, but the phone was at at fault all the time. If I could change it for something decent I would in a heartbeat.

    Hope this helps someone.?


  17. WelshGasman

    WelshGasman New Member

    Ok, on my Win7 laptop the following happens.

    Connect via USB, USB debugging is enabled by default. (What bright spark decided that was the 'normal' thing to do?).

    Switch it off, it immediately comes back on. Have to switch off 3 or 4 times for it to stay off.
    Then USB connectivity is available and it will connect with the Android going Orange.

    This is progress.???
  18. demented

    demented Member

    go to 'notifications' and select connect usb storage device
  19. Neuromunger

    Neuromunger New Member

    If like others you have problems getting your computer to recognize your phone you've probably got an Asus motherboard and need to plug the usb in the back of the computer and not the front.

  20. Neuromunger

    Neuromunger New Member

    To unlock the Samsung Galaxy Ace go here - [TUTORIAL] How to Network Unlock Samsung Galaxy Ace Via ADB - xda-developers every reply post is a thank you and it worked for me. The instructions may look complex but its a 15 minute job and its free.

    If like others you have problems getting your computer to recognize your phone you've probably got an Asus motherboard and need to plug the usb in the back of the computer and not the front.

    By the way avoid unlock codes direct they charge you for information that is already available on the moneysavingexpert.com site, offer unlock codes that are sometimes temporary and/or do not work.
  21. benjavalero

    benjavalero New Member

    I have the same problem on connecting with the USB of my car radio. I will try what you say, turning it off several times, but although it works, this would be really annoying :confused:
  22. pnkhakre

    pnkhakre New Member

    Hi,

    I've freshly installed Kies on my Windows 7 PC, At first the USB cable and mobile got recognized on PC and everything worked fine, For the second time after plugging the USB chord in the micro USB on mobile and PC USB the PC is not detecting the mobile as well as the mobile also shows no USB device connected in Settings>Wireless and Network Settings>Tethering and Portable Hotspots.
    I've tried
    1. Setting the Debug mode off (Uncheck) in Development
    2. Reinstalled the Drivers through Kies
    I'm unable to backup any data also unable to sync contacts with Outlook due to the USB problem

    Please help
  23. gandaran

    gandaran Active Member

    1 disconnect phone from PC (unmount usb storage if enabled)
    2 reboot PC (re-install USB drivers if the first reboot didn't work)
    3 USB debug mode must be enabled
    4 connect phone, use the usb storage mode or kies but not the two at the same time.
  24. wfeere

    wfeere Well-Known Member

    I had the very same problem on a different thread until "cyberwhip" help me.

    Originally Posted by cyberwhip [​IMG]
    if your still having issues connecting via usb, try this:
    1. go to "settings"
    2. applications
    3. development
    4. USB development mode enable

    location of this setting may vary, but should work, no guarantees though.

    I did this to the phone and now I turn on Kies then plug in the phone, all is good!!
  25. memonono

    memonono New Member

    Hii,I've samsung galaxy ace,the usb port doesn't work for charger or usb cable.

Share This Page