Samsung galaxy ace- turns on but android not working?Support

Last Updated:

  1. vendetta098

    vendetta098 New Member

    Whenever my galaxy ace turns on, it only shows the samsung logo and afterwards the vodafone logo. It repeats in this order and never reaches the android operating system

    Please Help if you know how to fix this


  2. alpha0990

    alpha0990 Well-Known Member

  3. vendetta098

    vendetta098 New Member

    Should i do a factory reset option
  4. alpha0990

    alpha0990 Well-Known Member

    I forgot lol. yes factory reset if you have saved your files to somewhere else or if you arent bothered about them
    vendetta098 likes this.
  5. vendetta098

    vendetta098 New Member

    Thanks,man for the help. I really Appreciate it
  6. alpha0990

    alpha0990 Well-Known Member

    No problemo lol. Thanks.
  7. insanegaurav

    insanegaurav New Member

    my ace is having the ame problem i have restored factory settings in recovery settings but it is still not starting plz help
  8. VfM4meplse

    VfM4meplse New Member

    Hi, a recent lurker to this forum and have found it really helpful as my Samsung Galaxy ACE seems to have one problem after the other. My handset seemed to have died even after charging for hours but this solution worked...a just wondering whether I'll have to reboot it every time it runs right down? :confused:

    Sorry to have started with a rant, but I have this handset for precisiely one month, barely use the functions and am sick of it already. Nor can I recommend talkmobile.

    I just wanted a reliable phone at a good contract price, not something that works when it feels like it...come back Nokia and O2, all is forgiven!

Share This Page