Samsung Galaxy drivers and NPS


Last Updated:

  1. Arrgoss

    Arrgoss Member

    Hey there,

    I'm having problems to get my new Samsung Galaxy detected by NPS. My final goal is updating to the last firmware but let me go step by step. I have been reading many forums and this wiki
    HTML:
    1. http://wiki.dandascalescu.com/reviews/gadgets/pda_phones/samsung_i7500_galaxy#PC_software_.28Windows_only.29
    but the system doesn't find some drivers for the Galaxy.

    1) I installed the last version of NPS
    2) I have unchecked the "Mass storage only" option in my phone
    3) I have enabled the "USB debugging" option in my phone
    4) When I connected my phone, some drivers were installed (I'm running windows XP 32 bits)
    5) One or more drivers were not found and I pointed the search to C:\Program Files\Samsung\Samsung New PC Studio\USB Drivers
    but the driver was still not found :confused:.

    I'm stuck there. There are several folders into ...\USB Drivers\ and I went one by one, but still the driver was not installed. Ignoring it doesn't help since NPS won't recognize my phone as a Samsung Galaxy.

    Any idea, hint? Have I missed some step?

    Some info:

    Model number: Galaxy
    Firmware version: 1.5
    Baseband version: I7500XXIG8
    Kernel version: 2.6.27
    Build number: 76XXCSDCBALUM6375

    I'm in France
    Using Windows XP Pro SP2 (because I cannot update my phone from my Ubuntu, or can I?)

    Any help will be much appreciate it!

    Advertisement
  2. Arrgoss

    Arrgoss Member

    Unusually, I'm going to reply to myself.
    I kept on playing around with the Galaxy connected and the NPS launched. Although the phone has some drivers missing and cannot surf the device, for example (device not supported, drivers missing) I could somehow click on the "Update" icon and this would run initially and recognize the phone.
    The update started and downloaded the last version of the firmware. At this point, an error message complaining about the drivers appeared but the phone seemed to be installing something, so I left it finish for a couple of minutes... And voil
  3. nunocordeiro

    nunocordeiro New Member

    AFAIK, noone can. That's a Samsung problem. I guess it is a unified app for most samsung smartphones and it's still not ready for Android.
  4. Arrgoss

    Arrgoss Member

    I see... shame on samsung.
    Nevertheless people are usually able to install the driver I'm missing.
  5. kam187

    kam187 Well-Known Member

  6. bergerc

    bergerc Member

    I installed this driver while trying to update the recovery image to v4.2 as part of the procedure to update to II5 and eventually the Galaxo ROM.

    However, I now want to uninstall it as it is playing havoc with my PC. I'm running Vista Ultimate 32 bit and since I installed this driver the system has become extremely unstable.

    When I connect my Galaxy (O2 UK IH6 firmware) all is ok initially and I am able to see the phone in NPS (IJ1) and the internal storage and SD Card in Windows Explorer.

    However, if I try to browse either drive using Windows Explorer it stops responding, my USB wireless keyboard and mouse stop working and I am basically unable to do anything. The system isn't hanging as I can plug in a second USB mouse and use it to browse, etc but no keyboard means I can't do much else. If I try to shut the machine down cleanly it usually hangs on the 'Logging Off...' screen and I have to hit the reset key to reboot.

    None of this happened before I installed the ADB driver, which I had to do in order to get fastboot to connect to the device so I could update the recovery image.

    I have uninstalled NPS and all the Samsung and other related USB drivers I can find, but I'd appreciate some pointers to ensure that I have uninstalled the ADB USB driver as well as it wasn't obvious in the Remove Programs and Features control panel app.

    Once I've done that I will reboot and reinstall NPS. Will I also need to reinstall the ADB USB driver so I can use Odin to flash to II5 and then the Galaxo ROM?
  7. Rastaman-FB

    Rastaman-FB Well-Known Member

    you dont need the adb driver for odin

    to uninstall the drivers for this device you will need to connect it
    right click my computer and go to manage
    click on device manager
    you should see ADB interface. right click and click uninstall
    anything samsung mobile related in the list also click uninstall
    reboot.


    i very much doubt that the modified inf is causing the problem and is likely to be a red herring.
    it could be something with reading the mass storage on the device that is causing the issues but i doubt its to do with the adb driver.
    coincidence maybe
  8. bergerc

    bergerc Member

    Did that but forgot to tick the option to delete the driver files.

    Reinstalled and it found all the devices including the ADB driver. Touch wood everything seems ok so far...
  9. jalipur123

    jalipur123 Active Member

    aaaarrrghhh

    im having the same issue.
    done everything like u have. debugging on, mass storage off.
    Installed the drivers that were in nps.

    connect the phone and i can see the phone to the right in nps.
    try to update says "phone not supported".

    and when i connect the phone windows identify it as a new "thingie", try to search for usb drivers on the nps cd. NOTHING.


    btw i downloaded the lates nps from samsung version 1.3.0. IJ1
    Phone says "baseband version I7500XXII8" in "about phone".
    goin crazy here...
  10. tegeltexas

    tegeltexas New Member

    I'm having the same issue myself, or rather what I thought was an issue. After some additional searching on the net I found this thread:

    Seems that NPS can't give a very bright error message if you have the latest version (or if the version is too new). Anyhow, how I can put this to rest and move on to more fun parts :)
  11. kofuukali

    kofuukali Well-Known Member

    I am about to leave for a whole month with only my netbook and its single-boot ubuntu on it...
    Any updates on updating firmware through linux anyone?
  12. meltemis

    meltemis New Member

    I go to Settings/About phone/USB Settings
    enabling Mass Storage

    Then I attach the cable and when the USB symbol appears, I slide
    through the USB symbol to enable USB connection


    KIES software must be checked for update but it does not relate
    to USB transfer.


  13. DaSchmarotzer

    DaSchmarotzer Blame it on me VIP Member

    This is a thread from 2009 about the Samsung Galaxy i7500, it was released way before the Galaxy S and it's not the same thing at all. ;)

    Welcome to the forums by the way!

Share This Page