samsung galaxy mini wifi issueSupport


  1. the_metal

    the_metal Member

    hey guys .
    I bought a Samsung galaxy mini ( gt-s5570 ) ,its good except the WiFi .
    It can work with my home network for only one time ,if i try to connect again it won't allow me .
    I've tried (N81-N82-Star-Star 2) and all of these phones works perfectly with my router ,so i think its the phone not the router .
    the router is a Linksys WAG54G2 with latest firmware update version : V1.00.19 ,I've tried all type of security and i even disabled it without any luck .
    I've been searching Google for over a month now without any success but I've noticed that this problem happens with many other handsets .
    to fix it i have only two options :
    1- restart the router ( which is inconvenient ) .
    2- factory reset the phone ( can't live with an empty phone 4ever ) .
    I tried everything on phone settings and on router settings with no success at all ,I even tried apps from android market to fix WiFi but it didn't work .
    any help will be appreciated ,thanks guys.
    Here is some pics stating the problem
    ------------------------------------
    this picture state my phone software
    [​IMG]
    -----------------------------------
    this is when it stop working ,it shows disconnected for 5 secs then it shows scanning for half a second then it goes back again showing disconnected (loop)
    [​IMG]
    then
    [​IMG]
    -----------------------------------
    if i click on my network name it shows three options (connect,forget,cancel)
    [​IMG]
    when i choose CONNECT it state that my network is not in range even though I'm sitting on the router :)
    [​IMG]
    -----------------------------------
    If i restart my router or i factory reset my phone the WiFi works again for a day or a few hours
    [​IMG]
    -----------------------------------
    please guys help me in this ,thanks so much .

    Advertisement
  2. gmp009

    gmp009 Member

    I think it is the problem of every user who have android 2.2.1 which u have too, even I was facing some kind of problems like that... when i upgrade my phone to android 2.3.4 i get rid of these.... thanks to samfirmware...
    the_metal likes this.
  3. the_metal

    the_metal Member

    I'm very very thankful for your reply , so i'll be waiting patiently for the upgrade and i really appreciate your care for answering me , thank you again :D
  4. yagya

    yagya Well-Known Member

    This might help you fix that problem.
    Go to the dailer and type *#*#232339#*#*
    When it finishes try to connect to the router again.

    Hope it will work!!! All the Best.:)
    Gobalot and the_metal like this.
  5. the_metal

    the_metal Member

    I'm thankful for your answer and your care and i do appreciate it. However, this method didn't work with the phone even though i tried it multiple times and it states "loading driver successful" but nevertheless it didn't work. Anyway thanks again for your help :)
  6. yagya

    yagya Well-Known Member

    Was this problem on your phone when you bought it or it happened later when you were using and tweaking your device. If it wasn't at the beginning (i.e. when you bought it), doing a factory reset from recovery might solve the problem. Backup you applications before wiping your data(factory reset).
    the_metal likes this.
  7. the_metal

    the_metal Member

    Thanks for your help. This problem was on my phone since the purchase, also i didn't tweak or change anything on the phone settings. I believe its a problem with Android OS itself rather than the hardware. Anyway i did state in my post that if i do a "factory reset" it will work again but for just once and after that i can't reconnect again to the same network. Again I'm thankful for your help.:)
  8. yagya

    yagya Well-Known Member

    I'm feeling sorry for not being able to help you.... I've never came across such problem in my galaxy pop, though sometime i need to load the drivers manually with *#*#232339#*#* because wifi just could not start. But, I don't have that problem now. :(
    the_metal likes this.
  9. yagya

    yagya Well-Known Member

    Which android version are you on?? If you have android 2.2 I suggest you flash android 2.3.4 from samfirmware.com (Both asian and european version works on galaxy pop) or flash cyanogenmod 7 from http://androidforums.com/samsung-ga...od-7-1-0-samsung-galaxy-pop-mini-gts5570.html
    the_metal likes this.
  10. yagya

    yagya Well-Known Member

    Which android version are you on?? If you have android 2.2 I suggest you flash android 2.3.4 from samfirmware.com (Both asian and european version works on galaxy pop) or flash cyanogenmod 7 from http://androidforums.com/samsung-ga...od-7-1-0-samsung-galaxy-pop-mini-gts5570.html

    It might fix your bug also. But, still if your bug is not fixed you will get a good rom on your galaxy pop so there is no harm in upgrading until you do it the right way.

    "Mistakenly did the same post twice coz of my slow connection. Does anyone know how to delete a post?"
  11. uchihaexean

    uchihaexean Member

    Try out a simple code
    *#*#526#*#*
    Try connecting the Wifi once the driver loading becomes successful...hope it'll work...it worked for me
  12. tharejaneha

    tharejaneha Member

    i have upgraded my galaxy pop to version 2.3.4...still it is unable to connect to the wifi....kindly help me....
    the_metal likes this.
  13. yagya

    yagya Well-Known Member

    What exact error do you get ?? Try dialing *#*#232339#*#* in your dialer and try to connect after it loads driver successfully...
  14. tharejaneha

    tharejaneha Member

    dialed nd gt msg..."driver loaded successfully.."
    but while connecting to the network it keeps on showing "obtaining IP address" nd disconnects after some time....when i try to open any site...it shows there was a problem with the network"
  15. yagya

    yagya Well-Known Member

    I think you are not permitted to connect to the network.... were you able to connect it before this??
    Also check to see if use static ip is check or unchecked in wireless settings. If it is checked uncheck it...

    When every other option fails it is wise to wipe the data(Settings>Privacy>Factory Reset OR wipe data in recovery) and cache OR try upgrading to cyanogenmod 7 here.
    (Please backup your data & apps before resetting or upgrading)
  16. tharejaneha

    tharejaneha Member

    I am unable to connect since the day i have purchased it.....
  17. b1gg

    b1gg New Member

    This is the way to connect your wifi in Samsung Galaxy Mini

    1. You have to root your phone first

    - Download Update.zip

    After download, move into your /SDcard folder, don't extract that file
    - Enter recovery Mode on your phone by pressing Home button (Middle) and Power Button ( Right side ) for few second until show recovery mode

    [​IMG]

    - Use your Volume Button +/- to ch
    oose option apply sdcard:update.zip then browse where you put the update.zip in the previous
    Use Home button to OK , after the process finished, choose reboot

    Done. .. your phone have been rooted

    Step-step make Galaxy Mini connect to wifi ( especially adhoc Mode)
    1. Download file wpa supplicant then extract
    2. Use Root explorer, then browse /system/bin/ find wpa_supplicant then replace with download file , don't forget to backup it first.
    3. after replace that file, reboot your phone

    then try to connect wifi again.. i hope will help you, sorry my english not good enough..
    the_metal likes this.
  18. uchihaexean

    uchihaexean Member

    before upgrading try out *#*#526#*#*.................i had been facing the same problem untill i did the same...now it works well everywhere....
  19. giri189

    giri189 Active Member

    I am getting Wifi Disconnection Issue in CM7, how to solve it?
  20. tharejaneha

    tharejaneha Member

    unable to switch on my phone after the first part of reboot......help
  21. yagya

    yagya Well-Known Member

    I think you flashed it on wrong device. THis is only for gts5570 running gingerbread os. If you have froyo os try using super one click... from shortfuse.org

    If you can go to download mode try flashing your orginal rom from Login - www.SamFirmware.com here using odin.
  22. tharejaneha

    tharejaneha Member

    yeah...me doing on gts5570 only...with gingerbread os......i have done every damn thing...still unable to use wifi....
  23. yagya

    yagya Well-Known Member

    Did your phone rebooted? I was not having such problems with wifi (now i'm on cm7).. and my wifi is working well. I think you flashed wrong gb from asmfirmware (if your phone came with carrier, use samsung providers firmwares from samfirmware or try flashing to latest asian region rom, it might help you )
  24. armanke13

    armanke13 Member

    what is root explorer? *sorry I'm very newbie
  25. armanke13

    armanke13 Member

    what is root exporer..? *sorry a perfect newbie..
Loading...

Share This Page