Samsung Galaxy S Wi-Fi Issue - Lets get this sorted!!Support


Last Updated:

  1. yochankr

    yochankr New Member

    Now before I start talking about this issue, I would like to say that I love my new phone. Had it for 3 days, and I love it.

    BUT.

    This $%*ing wifi issue that's continuing to annoy the crap out of me has got to stop before I bomb Samsung.

    I know for a fact that I am not the only one with this issue as I have seen other users writing about this issue.

    Now.

    I know I am just complaining about the same wifi issue, but previous people didnt really write what was specifically wrong.

    Now the issue is :

    I was able to connect to my wireless modem at work with no issues, same goes for last night as I was able to use the internet and the Android Market at home.

    Howeve for some strange reason, I cannot connect to wifi at all. Unlike other previous users, I can detect the wifi network. However after entering the security key I press connect and the phone is obtaining the ip address but it fails to connect with the message : failed to connect.

    Now I have noticed some strange things when it stopped working.

    1. The wifi dropped as soon as the battery went to 100%.
    2. I had downloaded about 10 applications.

    I don't think its to do with the applications because I have an antivirus running for all downloads.

    Also as you may know, 3G indicator disappears when the phone detects wifi, but now it doesn't.

    So please please help me out please!

    Advertisement
  2. andy-roid

    andy-roid Well-Known Member

    Did this wifi problem start after you installed them apps if it did this then one of the apps is causing the problem
  3. snapper.fishes

    snapper.fishes Well-Known Member

    What's the model of the router?

    Which wifi band are you using? b, g or n?
  4. karnka

    karnka Well-Known Member

    My wifi was quite iffy for a while at home but not at work.

    In the end dropped my home router down from n to g. Now works much better.
  5. biskitbeetle

    biskitbeetle New Member

    Hi all,
    I had loads of problems with my wifi, I could connect to a Neighbours Wifi but not my own..I searched loads of forums trying to find a solution, in the end after a little trial and error I managed to fix it.
    I went ito my belkin Router config and changed the security mode from WEP to WPA/WPA2-personal and now i have no problems..I had to change my laptops to match the connection ...but now all is well ..My phone connects automatically as soon as my wifi is in range..... might be worth a look at your settings
  6. karnka

    karnka Well-Known Member

    You shouldn't be using WEP anyway. It's not secure.
    THE ANDROID likes this.
  7. lajapathy

    lajapathy New Member

    Initially wi fi was working fine ..
    after a week, wi fi detected networks but dint connect
    now wifi is not detecting any network ..
    wifi gets turned off by itself ..
  8. lajapathy

    lajapathy New Member

    Hi guys,
    there s a simple solution . but installed apps will be uninstalled.
    settings->privacy->factory reset ..

    I did this and wi fi worked again ..
    HAO likes this.
  9. Halk

    Halk Active Member

    My wifi was dodgy at home when I switched from a router running tomato to a Netgear using standard firmware. I ended up switching back to the tomato router and using the netgear as a gigabit switch. I'm quite sure if I'd fiddled with the settings enough I could have gotten round it.

    To compound things I found that when I was struggling to get wifi to work and trying to change settings etc, my phone would often need to be rebooted as the wifi on it had stopped working.
  10. SaunaNils

    SaunaNils New Member

    i also have a wifi issue. im trying to connect to t-mobile hotspots. the first time after factory reset of my galaxy s, it works. when i try to connect again it doesnt. i figured out why it doesnt work but i dont know how to solve this problem:
    when my device connects the first time, it receives an ip adress and KEEPS it. so next time i try to connect i still have the old ip adress so the router cant give me access, because the ip adress is not mapped to a mac adress on the router.
    does anyone have an idea how to solve this issue?
  11. seepage

    seepage Well-Known Member

    In what way is it not secure? Thats what I use.
  12. Beards

    Beards Well-Known Member

    Karnka was correctly informing you WEP can very easily be unencrypted thus making it not secure.
  13. HAO

    HAO New Member

    This was a day saver, my wifi is back agan. And appbrain gets me up and running with all my apps.
  14. Davian

    Davian Member

    I had similar issues. Opened the box, fired it up, synced it to my email server, had mail/contacts/calenadar working right away. Then I called up, had the sim card activated, all was good.

    A few days later, no wifi connection. It worked on campus (UBC) where I work as a consultant, but not at my house. Changing to my other access point had spotty results.

    I then downloaded Wifi Analyzer and found that both of my access points were on very crowded channels. So I moved one of them, switched the phone to it, problem went away.

    This may also explain why the wife's laptop and our ipod Touches were also having wifi issues. Not as bad, but maybe the S is fussier. I run all the other computers in the house wired.

    It may depend where you are in the house - because it depends how your neighbors have their access points. And at what time. And they may be moving their channels around to fix the same issue you are having.

    That would also explain how some of you 'fixed' the problem by changing routers or access points. Changing security types may change timing issues.

    I use WPA with MAC address filtering on both access points.

    Try it out and post back here.
    Miakatt likes this.
  15. sye

    sye New Member

    i faced the same issue and resolved....in my case the battery is 10% when trying to connect wi fi ,after all when the battery charges fully it connected.
    check your battery status before factory reset ;)
  16. pfinnegan

    pfinnegan Member

    This is a good solution. I had a similar problem but the Galaxy detected my wireless network after I changed the wifi channel.
  17. blessonje

    blessonje New Member

    That will always work ..but real problem everyone is facing is after couple of day it wont again connect and has to reset which makes this not a practical solution.

    From XDA the sol is to connect using AllShare App in the Galaxy S.
  18. antoeknee

    antoeknee Well-Known Member

    The post Davian is a good point to start. With expolsion in people having wireless at home some of the channels are very crowded.

    I have a few laptops and a nettop connecting to my home network. The laptops would connect OK but the nettop was hit and miss. Found that the channel my router was using was very congested. Changed the channel to one that was not being used much (WiFi Analyser used) in my area and nettop connects fine.

    Wether related or not I've never had issues with wireless and my SGS.
  19. prashant:@

    prashant:@ New Member

    No joy ! LG optimus ! android 2.1 . i have the wifi symbol in the upper right hand corner of my screen -AND- in my settings/wifi and networks it shows connected to ...."your network name") but it is not opening any website !
  20. snapper.fishes

    snapper.fishes Well-Known Member

    A simple Google search will give you a dozen website that tells you how to crack a WEP password. It's easy. All you need is the hacking program on you laptop and you are good to go. The entire process usually takes less than 20 minutes.

    WPA on the other hand takes forever to crack. At least long enough that you should notice the strange guy sitting across the street with his laptop.
  21. shalz75

    shalz75 New Member

    My problem with the WIFI is that it keeps turning on the whole day. I have tried to put it off ; I put the sleep settings for when screen is off.... nothing is working. It switches on every 5-10 secs and my phn emits a notification sound when that happens - its driving me insane.

    can anyone clue me onto what is that I need to do to change this. I dont want the WI-FI on the whole time as its eating into the battery... my battery drained off after first 4-5 hours of use; I had charged it till full before first use.

    Now its on charge for the past 90 mts or so; and I dont think charging is happening...

    My happiness over the new phn is fast diminishing. Please help.
    :(
  22. tripplec

    tripplec Well-Known Member

    How are you turning it off? What model do you have and version of Android.

    All controls can be set in SETTINGS even though there are other ways to do it go there since there is not info provided.
  23. Miakatt

    Miakatt New Member

    THANK YOU! I've been looking for a solution to this problem for ages. Setting a static IP address isn't really a solution if you want to connect to several different networks (home, work, hotels etc). I set my home router's channel to 13 (the one most likely not to be used neighbouring networks, I guess) and the Samsung connected immediately with no need for static IP or using AllShare. Simple!!! Once again, Thank You, Pfinnegan!
  24. mahakpassi

    mahakpassi New Member

    hi all
    i have purchased samsung galaxy s but i having issues in home wifi.
    whenever i connects through wi fi, signal appears on mobile and it shows connected but i am not able to open website as it shows server unavailable.

    I have asked to samsung service centre and they have formatted my phone but the same problem exists. I have laptop and nokia E5 that connects on first attempt on home wi fi.

    So pls suggest what to do.
    IS there is problem in my mobile or in wi fi router.

    regards
    mahak passi

Share This Page