Samsung Galaxy S2 Battery Drain Fix / Work-AroundTips


  1. alre101

    alre101 New Member

    I have found a work around for the battery drain issues after the 2.3.6 update to my GS2. I consider this to be a work-around, because an actual fix would involve someone at Google or Samsung actually correcting the buggy code. I am dividing this up into several sections that describe the work around and the rationale behind it. I'll start with the fix and save the details for later. ************ The Problem After the 2.3.6 update I noticed a sharp decrease in battery life. I went from being at more than 70% battery at the end of the day at work to being at 50% or less. I tend to keep WiFi on all the time because I connect to the network at my house, the AT&T store that is next to the place where I stop for a bagel in the morning, and at the office. I noticed that instead of "Display" being the biggest battery hog (as I was used to), it was now "Android OS". I was quite concerned because I was about to go on a business trip, and would need my phone for checking email, returning phone calls, etc. While on the trip I kept WiFi off, and I noticed a significant improvement in battery life, even though I was checking email regularly via the 4G connection. That was the first piece of evidence that the root cause f the problem was related to WiFi. ************ The Work Around The following worked for me, and I think will work for others. 1. Go to Settings -> Wireless and Network -> Wi-Fi Settings. Tap the menu key and then Advanced -> Wi-Fi Sleep Policy. Select Never. (This is counter intuitive, but I will explain the reason for this below.) 2. Download a 3rd party battery manager that can control WiFi. I am using Battery Defender, which is free. Juice Defender Plus and Ultimate should also work. (I don't think that the free version of Juice Defender controls WiFi.) If the market tells you that Juice Defender is not compatible with your device, I think it is because AT&T doesn't want you to use it. You can probably side load it, or pop out your SIM card and download it over a WiFi connection. 3. Set up the battery manager of your choice to control your WiFi connection by turning it off when the screen is off. Battery Defender is a bit of a blunt instrument in the sense that when your screen is off, WiFi is off. Juice Defender is a little more sophisticated because it turns WiFi on periodically (every 15 minutes) and allows background applications to connect briefly. If you rely on push e-mail and/or social network updates, you will probably prefer Juice Defender. 4. Enjoy improved battery life where your Display now is the biggest consumer of power. ************* Why This Works Based on reading a number of posts in this forum and others, there is good evidence that there is a bug in the operating system's Suspend process. Normally you would let the operating system manage the WiFi connection, and it can be set up to turn the WiFi off when the screen is off (that is one of the options in the WiFi Sleep policy settings). What appears to be happening is that the Suspend process has a bug and when it shuts off the WiFi radio it goes into an infinite loop of some sort that burns processor cycles and uses a lot of power. This shows up on the battery usage screen as "Android OS". By telling the operating system to never put the WiFi to sleep, the buggy Suspend process never runs. By itself, this would involve a trade-off between the power consumed by the WiFi radio and the buggy suspend (I actually think that leaving WiFi on all the time would use less power). By installing the 3rd party battery manager you are having another program sneak in and turn the WiFi off at the hardware level. The operating system is not involved, and the Suspend process does not start. ************** I hope this help those of you who are having problems. Al

    Advertisement
    :
    Leah M, EricH4753, nsandymary and 5 others like this.
  2. vic007

    vic007 New Member

    Al, there is another similar workaround. ATT has placed an app in the Android Market called AT&T Smart Wi-Fi which connects the Wi-Fi only when near previously accepted connections. I believe it checks when screen is on and sleeps the Wi-Fi otherwise.
    rayturner and werds like this.
  3. docjeep

    docjeep Member

    This could be why I haven't had battery issues after upgrading to 2.3.6. I've been running Juice Defender since day two. It's really helped with my battery life.
  4. rmreid

    rmreid Well-Known Member

    Some good information here thanks!

    Note: I am going to try out the AT&T Smart WiFi app posted above by vic007 and see if it helps
  5. jdCaptivate

    jdCaptivate Well-Known Member

    I don't use Juice Defender (that was about the only thing I could make out).

    Could someone please break that down into paragraphs? I don't have the patience, nor the desire to strain my old @$$ eyes on reading it.
  6. wolfyboy359

    wolfyboy359 Well-Known Member

    it says use juice defender.

    edit: sorry that was a little snarky. It says that the wifi sleep gets caught in an infinite loop that drains battery power and shows up as android os. The way to get around it is to use a third party wifi manager, such as juice defender to get around the problem. Hope that helps!
    werds and jdCaptivate like this.
  7. jdCaptivate

    jdCaptivate Well-Known Member

    Oh, I didn't take it snarky. I wasn't trying to be an ass myself. A) I'm dyslexic and B) I'm an old 40-something fart. Trying to read that, would lead to a migraine the size of texas.

    That you much for breaking it down!
  8. wolfyboy359

    wolfyboy359 Well-Known Member

    you're welcome. I just don't know if juice defender is the one to use. Since it is beta only, I am reluctant to use it. Any other ideas for a good manager? and will they conflict with att wifi manager which I just installed for some reason?
  9. jdCaptivate

    jdCaptivate Well-Known Member

    Don't take my word for it, because I honestly haven't investigated either app. However, I installed the AT&T app also and my perception, is that it should basically take care of the issue. Juice Defender seems like overkill to me, for this particular problem.

    Though, again... I don't know enough about Juice Defender. I always thought its basically a task manager and Android does not need task managers.
  10. Pepe7698

    Pepe7698 Well-Known Member

    I played with the AT&T Smart Wi-Fi app a while back. Looks like it is getting a second chance on my phone.
  11. werds

    werds Active Member

    Thank you both for this information, will try it out and see what the happs is. I too barely skimmed through that stuff at the top heh - your posts helped explain it more succinctly. (Sorry OP :( )
  12. tigerck127

    tigerck127 Member

    Ok, so do I just download the app and it does what it's supposed to do on its own? or do I need to set it up or something?

    I downloaded, but I'm just not sure how to use it.

    Thanks!
  13. tigerck127

    tigerck127 Member

    Ok, so do I just download the app and it does what it's supposed to do on its own? or do I need to set it up or something?

    I downloaded, but I'm just not sure how to use it.

    Thanks!
  14. (G)

    (G) Well-Known Member

    I'm not getting something:

    Why not just go into Settings/Wireless and Network/Wi-Fi settings/ then Menu/Advanced and go to Wi-Fi sleep policy and select:

    "When screen turns off".

    Isn't that the same thing you guys are trying to do without needing a 3rd party app?
    DeniseJ likes this.
  15. jackal2001

    jackal2001 Member

    OK so even with the ATT wifi app and juicedefender installed, I only got 14hrs out of my battery and it wasn't used for web surfing at all.
    This seems like some sort of memory/cpu leak because even though juicedefender is shutting down the wireless, but enabling it every half hour to update apps, it isn't lowering the OS. My OS was still running at over 90%.

    I'm doing a test today. I disabled syncing to gmail, uninstalled juicedefender and att wifi app, turned off wifi, and then power cycled my phone. Will see how long it lasts.
  16. vic007

    vic007 New Member

    Tiger, I just installed the AT&T app and let it do its thing (no setup). Just run it when you reboot or start the phone to make sure it is running.

    G, I think your suggestion would still let the WiFi run (scan) if you're not in one of your previously accepted WiFi access points / routers / places. If I understand the AT&T app, - screen on check - not a favorite WiFi location, then sleep WiFi - Favorite: -> wake up WiFi & connect.
  17. DeniseJ

    DeniseJ Active Member

    Thanks!!! I'm going to try this method first to see if it helps.:)
  18. wolfyboy359

    wolfyboy359 Well-Known Member

    ok I wouldn't recommend smart wifi as a solution to this problem on it's own. I tested it out last night and my battery didn't last. All this app seems to do is reconnect to my wifi at home when I disconnect it. Keeping it on.

    edit: I am trying Battery Defender (no affiliation) to see what that does.
  19. wolfyboy359

    wolfyboy359 Well-Known Member


    Did you read the OP???
  20. blau808

    blau808 Active Member

    It IS a little hard to read, can you please summarize?
  21. docjeep

    docjeep Member

    Not sure where you got Juice Defender is beta only. I'm running version 3.9.4. I downloaded it from the market in Nov. and just kept updating as they came available. I'm running the free version not the plus version.
  22. jdCaptivate

    jdCaptivate Well-Known Member

    Because all of us, already have it setup like that. There is a wifi bug in 2.3.6
  23. jdCaptivate

    jdCaptivate Well-Known Member

    If you check the market on your phone and try to upgrade to the pro version, it says its not available for our phones, which is horse crap, because all it does, is unlock the features.
  24. dksmoove

    dksmoove Member

    For the tl;dr people,

    OP says to use JuiceDefender, but you will need PLUS or ULTIMATE version to ctrl Wifi.
    Or to use Battery Defender.

    He also said to try out the AT&T WIFI app, but one person said it is has not solved the issue.

    Issue lies with Wifi eating up the battery life. Get JuiceDefender PLUS or Battery Defender.
  25. jackal2001

    jackal2001 Member

    I tried the advanced settings for wifi and put it on sleep when display is not on. This actually did help. I left wifi on and the phone on overnight for 9hrs and the battery only drained 10%.
Loading...

Share This Page