Samsung Galaxy S2 Firmware updateSupport


Last Updated:

  1. Mpstewar

    Mpstewar New Member

    Dear All,
    *
    I am tearing my hair out with frustration here.
    *
    I am trying to upgrade the firmware on my Samsung Galaxy S2, I have not had the phone for long and I only downloaded Kies last week.
    *
    Once I opened Kies and connected the phone, I got a prompt telling me there was a firmware update available, so I clicked on

    Advertisement
  2. Vic Rattlehead

    Vic Rattlehead New Member

    Go to menu-settings-about phone. You can upgrade your phone from there. Use wi-fi it is a large file to download.
  3. Crayonmuncher

    Crayonmuncher Member

    the ics update is not available ota, to be fair no-one can seem to get it.

    Im sure this has already been suggested but have you tried factory reset the phone and then start the update process?

    Failing that have you tried using a different usb cable?

    Is USB debugging mode off on the handset or on? I believe it needs to be off.

    Try here for more help:

    http://androidforums.com/samsung-ga...lp-samsung-galaxy-s2-wont-connect-kies-3.html
  4. caramelly

    caramelly New Member

  5. Randomname

    Randomname Member

    hi everyone how are u?

    I need help urgently!

    About 2 months ago i flashed my S2 up to ICS 4.0.3 and it has become increasingly hopeless. Around 3 weeks back my charger seemingly gave up the ghost and so I bought a new one which when charging kept informing me that it was Voltage too high and charging paused etc... a complete pain!

    Since then recently I have found that it eats the battery like never before, in desperation two days ago i performed the factory reset in the mistaken belief that it would return my fone to gingerbread 2.3.4 but instead it just wiped lots of apps and left me with the crappy ICS. I took my fone of charge last night at 9.30pm put it in airplane mode EVERYTHING turned of and by 10am despite not having touched the damn thing it urgently required charging again!! 98% of its power usage had been used up with the OS and to be frank i just want a useable fone again!

    Herein lies the problem, I no longer have my laptop and having installed kies on another computer it took HOURS of faffing and fannying around to get it to recognise my fone. I searched desperately for an official ICS for S2 update and seemingly there is non not only that but i cannot connect my fone using my USB cable only using the wifi in my house.... Im really at a loss what to do folks and need help. I would be delighted if i could just get back my old gingerbread 2.3.4 on it but have no clue how to do it. I tried to use kies to find updates which i could flash onto the fone but no joy whatsoever.... Im at a complete loss and feel like throwing the thing out the window, after slapping the guy who wrote the dodgy ICS flash and then Mr.Samsung for not doing a proper version himself.

    If anyone knows any links to official samsung WORKING S2 ICS the please link me up kids.... or indeed a decent stock gingerbread 2.3.4 would be a step up from the current nightmare. I just want my fone back ... sniffle...

    Many thanks in advance for those who can help.

    ps. WHY DONT SAMSUNG DO UPGRADES LIKE A NORMAL COMPANY!!! AHHHH!!!
  6. Russell Ng

    Russell Ng Well-Known Member

    Randomname

    I don't think you can blame Samsung for this. You did mentioned you flashed the ICS and assuming you did that via Odin. Kies won't recognize your phone if you did not use an official firmware update. And if you flashed an unstable ICS version, what you experience could happen.

    Since you flashed once, you should just flash again. This time choose a little carefully. Some of those expert flashers here would be able to direct you to a good version of GB or ICS, whichever you prefer.

    I did mine through Kies officially so sorry can't be of further help. Did have the option of OTA as well, but didn't do that since data line can be somewhat unstable.
  7. Russell Ng

    Russell Ng Well-Known Member

Share This Page