Samsung Galaxy S2 not connecting via USB to Windows PC or Windows laptopSupport


  1. CarlosRexx

    CarlosRexx Member

    Not quite sure why? I have the correct drivers and the computer will charge the phone but Kies wont recognise is. :|

    Advertisement
    :
  2. SCPadgeebar

    SCPadgeebar Well-Known Member

    If you want to access internal storage, go to Settings > More Settings > USB Utilities > Connect Storage to PC and then plug your USB Cable.
  3. Ijaz Ahmed

    Ijaz Ahmed Well-Known Member

    This happens 50% of the time with me as well, I am on Windows 7.

    Leave your phone connected to PC

    Goto Device Manager and look for yellow marks in the "Universal Serial Bus Controllers"

    Right click on the yellow items and select "Un-install". In my case, I get two items with yellow mark.

    After un-installaing, click the button "Scan for hardware changes". Windows will find you phone again and install drivers.

    It should be working and no yellow marks should be in the Device Manager.
  4. SCPadgeebar

    SCPadgeebar Well-Known Member

  5. Ijaz Ahmed

    Ijaz Ahmed Well-Known Member

    ^ Is it 32-Bit or 64-bit driver ?
  6. SCPadgeebar

    SCPadgeebar Well-Known Member

    Worked on both(My 32-bit Windows 7 Home Premium and 2 64-bit Windows 7 Ultimate).
  7. CarlosRexx

    CarlosRexx Member

    ive sorted it now, had to reinstall windows so it's fixed everything.
  8. Throwaway041

    Throwaway041 New Member

    I just made an account to say thank you SCPadgeebar. I've installed a dozen different usb drivers and reformatted my computer and everything. This finally fixed my issue with my Samsung Galaxy SII.
  9. astav88

    astav88 New Member

    nothing works not even the driver mentioned above, it says successfully installed and needs a restart, but when i restart i have the same problem.
  10. MihaiG

    MihaiG New Member

    I encountered initially, lots of problems trying to connect S2 to PC using Kies. Although Kies was installed and had drivers for S2, when plugging the phone in the USB port, Windows would start installing drivers.
    Also, after Windows drivers were installed, I was asked everytime I plugged the phone to select the Winows application to work with the device. At the same time Kies was trying to connect to the device as well.
    If you select a Windows app to work with the device, Kies will not connect anymore.
    To correct the connection problem, select the option "Take no action" and mark the check-box "Always execute this action".
    On Win 7, the pop-up menu does not have the option for "Take no action", so you have to click on hyperlink for additional options and you will see a list of all devices including GT-I9100. There is a droplist for the action to take for each device. Select in the droplist for GT-I9100 the option "Take no action".
    Since I did this, my S2 has been connecting without problems to Kies.
    I was able to backup my phone and upgrade the firmaware to JellyBean (4.1.2).
Loading...

Share This Page